continue merging hack to workaround #392592, against my better judgment

svn path=/dists/trunk/linux-2.6/; revision=8401
This commit is contained in:
dann frazier 2007-03-26 22:30:51 +00:00
parent 0ec747e73e
commit 537e23dc56
3 changed files with 53 additions and 1 deletions

8
debian/changelog vendored
View File

@ -165,7 +165,13 @@ linux-2.6 (2.6.20-1~experimental.1) UNRELEASED; urgency=low
[ Frederik Schüler ]
* Disable NAPI on forcedeth, it is broken.
-- Bastian Blank <waldi@debian.org> Fri, 16 Mar 2007 19:24:10 +0100
[ dann frazier ]
* Hardcode the output of the scripts under arch/ia64/scripts as executed
in an etch environment so that we can build out of tree modules correctly
(re-add; patch seems to have been dropped during a merge.)
See: #392592
-- dann frazier <dannf@debian.org> Mon, 26 Mar 2007 15:57:54 -0600
linux-2.6 (2.6.18.dfsg.1-10) unstable; urgency=low

View File

@ -0,0 +1,45 @@
--- linux-source-2.6.18/arch/ia64/Makefile.orig 2007-01-03 17:26:31.000000000 -0700
+++ linux-source-2.6.18/arch/ia64/Makefile 2007-01-03 17:57:52.000000000 -0700
@@ -28,16 +28,7 @@
-falign-functions=32 -frename-registers -fno-optimize-sibling-calls
CFLAGS_KERNEL := -mconstant-gp
-GAS_STATUS = $(shell $(srctree)/arch/ia64/scripts/check-gas "$(CC)" "$(OBJDUMP)")
-CPPFLAGS += $(shell $(srctree)/arch/ia64/scripts/toolchain-flags "$(CC)" "$(OBJDUMP)" "$(READELF)")
-
-ifeq ($(GAS_STATUS),buggy)
-$(error Sorry, you need a newer version of the assember, one that is built from \
- a source-tree that post-dates 18-Dec-2002. You can find a pre-compiled \
- static binary of such an assembler at: \
- \
- ftp://ftp.hpl.hp.com/pub/linux-ia64/gas-030124.tar.gz)
-endif
+CPPFLAGS += -DHAVE_WORKING_TEXT_ALIGN -DHAVE_MODEL_SMALL_ATTRIBUTE -DHAVE_SERIALIZE_DIRECTIVE
ifeq ($(call cc-version),0304)
cflags-$(CONFIG_ITANIUM) += -mtune=merced
@@ -67,7 +58,7 @@
PHONY += boot compressed check
-all: compressed unwcheck
+all: compressed
compressed: vmlinux.gz
@@ -76,9 +67,6 @@
vmlinux.gz: vmlinux
$(Q)$(MAKE) $(build)=$(boot) $@
-unwcheck: vmlinux
- -$(Q)READELF=$(READELF) $(srctree)/arch/ia64/scripts/unwcheck.py $<
-
archclean:
$(Q)$(MAKE) $(clean)=$(boot)
@@ -94,5 +82,4 @@
echo '* compressed - Build compressed kernel image'
echo ' install - Install compressed kernel image'
echo ' boot - Build vmlinux and bootloader for Ski simulator'
- echo '* unwcheck - Check vmlinux for invalid unwind info'
endef

View File

@ -38,3 +38,4 @@
+ bugfix/all/stable/2.6.20.2
+ bugfix/powerpc/drivers_macintosh-broken.patch
+ bugfix/2.6.20.3
+ bugfix/ia64/hardcode-arch-script-output.patch