lockdep: Add missing macros

This commit is contained in:
Ben Hutchings 2016-02-18 04:14:17 +00:00
parent c536b8098a
commit 32be752344
3 changed files with 36 additions and 0 deletions

3
debian/changelog vendored
View File

@ -2,6 +2,9 @@ linux-tools (4.5~rc4-1~exp1) UNRELEASED; urgency=medium
* New upstream release candidate
[ Ben Hutchings ]
* lockdep: Add missing macros
-- Ben Hutchings <ben@decadent.org.uk> Thu, 18 Feb 2016 03:19:14 +0000
linux-tools (4.4-1) unstable; urgency=medium

View File

@ -0,0 +1,32 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Thu, 18 Feb 2016 03:34:25 +0000
Subject: lockdep: Add missing macros
liblockdep is broken again due to lockdep using kernel macros that it
doesn't have substitutes for.
---
--- a/tools/lib/lockdep/uinclude/linux/kernel.h
+++ b/tools/lib/lockdep/uinclude/linux/kernel.h
@@ -6,6 +6,7 @@
#include <linux/rcu.h>
#include <linux/hardirq.h>
#include <linux/kern_levels.h>
+#include <linux/compiler.h>
#ifndef container_of
#define container_of(ptr, type, member) ({ \
--- a/tools/lib/lockdep/uinclude/linux/list.h
+++ b/tools/lib/lockdep/uinclude/linux/list.h
@@ -1 +1,2 @@
#include "../../../include/linux/list.h"
+#define hlist_for_each_entry_rcu hlist_for_each_entry
--- a/tools/lib/lockdep/uinclude/linux/compiler.h
+++ b/tools/lib/lockdep/uinclude/linux/compiler.h
@@ -3,6 +3,7 @@
#define __used __attribute__((__unused__))
#define unlikely
+#define READ_ONCE(x) (x)
#define WRITE_ONCE(x, val) x=(val)
#define RCU_INIT_POINTER(p, v) p=(v)

View File

@ -16,3 +16,4 @@ revert-perf-build-fix-libunwind-feature-detection-on.patch
alpha-uapi-add-support-for-__sane_userspace_types__.patch
perf-fix-misleadingly-indented-assignment-whitespace.patch
perf-tools-fix-unused-variables-x86_-32-64-_regoffse.patch
lockdep-add-missing-macros.patch