Update to 4.5-rc4

Drop/refresh patches as appropriate.
This commit is contained in:
Ben Hutchings 2016-02-18 03:19:23 +00:00
parent d7161dc252
commit c536b8098a
9 changed files with 25 additions and 124 deletions

6
debian/changelog vendored
View File

@ -1,3 +1,9 @@
linux-tools (4.5~rc4-1~exp1) UNRELEASED; urgency=medium
* New upstream release candidate
-- Ben Hutchings <ben@decadent.org.uk> Thu, 18 Feb 2016 03:19:14 +0000
linux-tools (4.4-1) unstable; urgency=medium
* Upload to unstable

View File

@ -6,7 +6,7 @@ Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
--- a/tools/lib/lockdep/Makefile
+++ b/tools/lib/lockdep/Makefile
@@ -98,7 +98,7 @@ build := -f $(srctree)/tools/build/Makef
@@ -100,7 +100,7 @@ include $(srctree)/tools/build/Makefile.
do_compile_shared_library = \
($(print_shared_lib_compile) \
@ -15,7 +15,7 @@ Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
do_build_static_lib = \
($(print_static_lib_build) \
@@ -116,10 +116,10 @@ all_cmd: $(CMD_TARGETS)
@@ -118,10 +118,10 @@ all_cmd: $(CMD_TARGETS)
$(LIB_IN): force
$(Q)$(MAKE) $(build)=liblockdep
@ -28,12 +28,12 @@ Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
$(Q)$(do_build_static_lib)
tags: force
@@ -147,7 +147,7 @@ install_lib: all_cmd
@@ -149,7 +149,7 @@ install_lib: all_cmd
install: install_lib
clean:
- $(RM) *.o *~ $(TARGETS) *.a *liblockdep*.so* $(VERSION_FILES) .*.d
+ $(RM) $(OUTPUT)*.o *~ $(TARGETS) $(OUTPUT)*.a $(OUTPUT)*liblockdep*.so* $(VERSION_FILES) $(OUTPUT).*.d
- $(RM) *.o *~ $(TARGETS) *.a *liblockdep*.so* $(VERSION_FILES) .*.d .*.cmd
+ $(RM) $(OUTPUT)*.o *~ $(TARGETS) $(OUTPUT)*.a $(OUTPUT)*liblockdep*.so* $(VERSION_FILES) $(OUTPUT).*.d $(OUTPUT).*.cmd
$(RM) tags TAGS
PHONY += force

View File

@ -1,23 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Mon, 14 Dec 2015 01:09:32 +0000
Subject: nvme: Stop installing kernel-only <linux/nvme.h> as UAPI
Forwarded: http://mid.gmane.org/20151214011442.GL28542@decadent.org.uk
Fixes: 9d99a8dda154 ("nvme: move hardware structures out of the uapi ...")
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
include/uapi/linux/Kbuild | 1 -
1 file changed, 1 deletion(-)
diff --git a/include/uapi/linux/Kbuild b/include/uapi/linux/Kbuild
index 628e6e6..41652af 100644
--- a/include/uapi/linux/Kbuild
+++ b/include/uapi/linux/Kbuild
@@ -306,7 +306,6 @@ header-y += nfs_mount.h
header-y += nl80211.h
header-y += n_r3964.h
header-y += nubus.h
-header-y += nvme.h
header-y += nvram.h
header-y += omap3isp.h
header-y += omapfb.h

View File

@ -1,30 +0,0 @@
From: Markus Trippelsdorf <markus@trippelsdorf.de>
Subject: Add missing braces to if statement
Date: Mon, 14 Dec 2015 16:44:03 +0100
Origin: http://article.gmane.org/gmane.linux.kernel/2108038
Add missing braces to if statement.
The issue was pointed out by gcc-6's -Wmisleading-indentation.
Acked-by: Ingo Molnar <mingo@kernel.org>
Signed-off-by: Markus Trippelsdorf <markus@trippelsdorf.de>
---
diff --git a/tools/perf/ui/browsers/annotate.c b/tools/perf/ui/browsers/annotate.c
index d4d7cc27252f..718bd46d47fa 100644
--- a/tools/perf/ui/browsers/annotate.c
+++ b/tools/perf/ui/browsers/annotate.c
@@ -755,11 +755,11 @@ static int annotate_browser__run(struct annotate_browser *browser,
nd = browser->curr_hot;
break;
case K_UNTAB:
- if (nd != NULL)
+ if (nd != NULL) {
nd = rb_next(nd);
if (nd == NULL)
nd = rb_first(&browser->entries);
- else
+ } else
nd = browser->curr_hot;
break;
case K_F1:

View File

@ -1,26 +0,0 @@
From: Markus Trippelsdorf <markus@trippelsdorf.de>
Subject: Remove wrong semicolon in while loop
Date: Mon, 14 Dec 2015 16:43:35 +0100
Origin: http://article.gmane.org/gmane.linux.kernel/2108037
The while loop was spinning. Fix by removing a semicolon.
The issue was pointed out by gcc-6's -Wmisleading-indentation.
Reviewed-by: Matt Fleming <matt@codeblueprint.co.uk>
Acked-by: Ingo Molnar <mingo@kernel.org>
Signed-off-by: Markus Trippelsdorf <markus@trippelsdorf.de>
---
diff --git a/tools/perf/arch/x86/tests/intel-cqm.c b/tools/perf/arch/x86/tests/intel-cqm.c
index d28c1b6a3b54..fa5d17af88b7 100644
--- a/tools/perf/arch/x86/tests/intel-cqm.c
+++ b/tools/perf/arch/x86/tests/intel-cqm.c
@@ -17,7 +17,7 @@ static pid_t spawn(void)
if (pid)
return pid;
- while(1);
+ while(1)
sleep(5);
return 0;
}

View File

@ -1,26 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Wed, 13 Jan 2016 15:16:30 +0000
Subject: perf tools: Fix reading of build-id from vDSO
Forwarded: http://mid.gmane.org/20160113172301.GT28542@decadent.org.uk
We need to use the long name (the filename) when reading the build-id
from a DSO. Using the short name doesn't work for (at least) vDSOs.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
tools/perf/util/symbol.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tools/perf/util/symbol.c b/tools/perf/util/symbol.c
index cd08027..b60bc49 100644
--- a/tools/perf/util/symbol.c
+++ b/tools/perf/util/symbol.c
@@ -1465,7 +1465,7 @@ int dso__load(struct dso *dso, struct map *map, symbol_filter_t filter)
* Read the build id if possible. This is required for
* DSO_BINARY_TYPE__BUILDID_DEBUGINFO to work
*/
- if (filename__read_build_id(dso->name, build_id, BUILD_ID_SIZE) > 0)
+ if (filename__read_build_id(dso->long_name, build_id, BUILD_ID_SIZE) > 0)
dso__set_build_id(dso, build_id);
/*

View File

@ -14,9 +14,5 @@ tools-lib-lockdep-use-ldflags.patch
tools-hv-fix-fortify-format-warning.patch
revert-perf-build-fix-libunwind-feature-detection-on.patch
alpha-uapi-add-support-for-__sane_userspace_types__.patch
nvme-stop-installing-kernel-only-linux-nvme.h-as-uap.patch
perf-tools-fix-reading-of-build-id-from-vdso.patch
perf-fix-misleadingly-indented-assignment-whitespace.patch
perf-add-missing-braces-to-if-statement.patch
perf-tools-fix-unused-variables-x86_-32-64-_regoffse.patch
perf-remove-wrong-semicolon-in-while-loop.patch

View File

@ -7,7 +7,7 @@ Forwarded: no
--- a/tools/perf/Makefile.perf
+++ b/tools/perf/Makefile.perf
@@ -510,8 +510,8 @@ endif
@@ -563,8 +563,8 @@ endif
ifndef NO_LIBPERL
$(call QUIET_INSTALL, perl-scripts) \
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/perl/Perf-Trace-Util/lib/Perf/Trace'; \
@ -18,7 +18,7 @@ Forwarded: no
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/perl/bin'; \
$(INSTALL) scripts/perl/bin/* -t '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/perl/bin'
endif
@@ -519,20 +519,20 @@ ifndef NO_LIBPYTHON
@@ -572,23 +572,23 @@ ifndef NO_LIBPYTHON
$(call QUIET_INSTALL, python-scripts) \
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/python/Perf-Trace-Util/lib/Perf/Trace'; \
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(perfexec_instdir_SQ)/scripts/python/bin'; \
@ -32,6 +32,10 @@ Forwarded: no
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(sysconfdir_SQ)/bash_completion.d'; \
- $(INSTALL) perf-completion.sh '$(DESTDIR_SQ)$(sysconfdir_SQ)/bash_completion.d/perf_$(VERSION)'
+ $(INSTALL) -m 644 perf-completion.sh '$(DESTDIR_SQ)$(sysconfdir_SQ)/bash_completion.d/perf_$(VERSION)'
$(call QUIET_INSTALL, perf-tip) \
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(tip_instdir_SQ)'; \
- $(INSTALL) Documentation/tips.txt -t '$(DESTDIR_SQ)$(tip_instdir_SQ)'
+ $(INSTALL) -m 644 Documentation/tips.txt -t '$(DESTDIR_SQ)$(tip_instdir_SQ)'
install-tests: all install-gtk
$(call QUIET_INSTALL, tests) \

View File

@ -9,7 +9,7 @@ version-dependent name. And do the same for trace.]
--- a/tools/perf/Makefile.perf
+++ b/tools/perf/Makefile.perf
@@ -491,18 +491,18 @@ install-gtk:
@@ -539,18 +539,18 @@ install-gtk:
install-tools: all install-gtk
$(call QUIET_INSTALL, binaries) \
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(bindir_SQ)'; \
@ -34,16 +34,16 @@ version-dependent name. And do the same for trace.]
$(call QUIET_INSTALL, perf-archive) \
$(INSTALL) $(OUTPUT)perf-archive -t '$(DESTDIR_SQ)$(perfexec_instdir_SQ)'
$(call QUIET_INSTALL, perf-with-kcore) \
@@ -525,7 +525,7 @@ ifndef NO_LIBPYTHON
@@ -578,7 +578,7 @@ ifndef NO_LIBPYTHON
endif
$(call QUIET_INSTALL, perf_completion-script) \
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(sysconfdir_SQ)/bash_completion.d'; \
- $(INSTALL) perf-completion.sh '$(DESTDIR_SQ)$(sysconfdir_SQ)/bash_completion.d/perf'
+ $(INSTALL) perf-completion.sh '$(DESTDIR_SQ)$(sysconfdir_SQ)/bash_completion.d/perf_$(VERSION)'
install-tests: all install-gtk
$(call QUIET_INSTALL, tests) \
@@ -543,7 +543,7 @@ install-python_ext:
$(call QUIET_INSTALL, perf-tip) \
$(INSTALL) -d -m 755 '$(DESTDIR_SQ)$(tip_instdir_SQ)'; \
$(INSTALL) Documentation/tips.txt -t '$(DESTDIR_SQ)$(tip_instdir_SQ)'
@@ -599,7 +599,7 @@ install-python_ext:
# 'make install-doc' should call 'make -C Documentation install'
$(INSTALL_DOC_TARGETS):
@ -79,8 +79,8 @@ version-dependent name. And do the same for trace.]
--- a/tools/perf/util/Build
+++ b/tools/perf/util/Build
@@ -130,6 +130,7 @@ CFLAGS_find_next_bit.o += -Wno-unused-pa
CFLAGS_rbtree.o += -Wno-unused-parameter -DETC_PERFCONFIG="BUILD_STR($(ETC_PERFCONFIG_SQ))"
@@ -138,6 +138,7 @@ CFLAGS_rbtree.o += -Wno-unused-pa
CFLAGS_libstring.o += -Wno-unused-parameter -DETC_PERFCONFIG="BUILD_STR($(ETC_PERFCONFIG_SQ))"
CFLAGS_hweight.o += -Wno-unused-parameter -DETC_PERFCONFIG="BUILD_STR($(ETC_PERFCONFIG_SQ))"
CFLAGS_parse-events.o += -Wno-redundant-decls
+CFLAGS_vdso.o += -DPERFEXECDIR='"$(perfexec_instdir_SQ)"'