[x86] powercap / RAPL: change domain detection message (Closes: #781418)

svn path=/dists/sid/linux/; revision=22484
This commit is contained in:
Ben Hutchings 2015-04-06 20:19:39 +00:00
parent 2058e12678
commit 2e1bc269ef
3 changed files with 42 additions and 0 deletions

1
debian/changelog vendored
View File

@ -197,6 +197,7 @@ linux (3.16.7-ckt9-1) UNRELEASED; urgency=medium
* HID: thingm: fix workqueue race on remove (Closes: #780055)
* [x86] Disable X86_VERBOSE_BOOTUP (Closes: #781953)
* eMMC: Don't initialize partitions on RPMB flagged areas (Closes: #782038)
* [x86] powercap / RAPL: change domain detection message (Closes: #781418)
-- Ian Campbell <ijc@debian.org> Wed, 18 Mar 2015 21:07:15 +0000

View File

@ -0,0 +1,40 @@
From: Jacob Pan <jacob.jun.pan@linux.intel.com>
Date: Tue, 2 Sep 2014 02:55:21 -0700
Subject: powercap / RAPL: change domain detection message
Origin: https://git.kernel.org/linus/fcdf1797e1f8f6605b194e620a333e6d47e07672
Many CPUs do not support complete set of RAPL domains, as a
result this detection failed message is very misleading and
can be annoying.
[ 5.082632] intel_rapl: RAPL domain core detection failed
[ 5.088370] intel_rapl: RAPL domain uncore detection failed
So lower the warning message to info and only print out the RAPL
domains that are supported.
Signed-off-by: Jacob Pan <jacob.jun.pan@linux.intel.com>
Signed-off-by: Rafael J. Wysocki <rafael.j.wysocki@intel.com>
---
drivers/powercap/intel_rapl.c | 7 +++----
1 file changed, 3 insertions(+), 4 deletions(-)
diff --git a/drivers/powercap/intel_rapl.c b/drivers/powercap/intel_rapl.c
index a362dcc..45e05b3 100644
--- a/drivers/powercap/intel_rapl.c
+++ b/drivers/powercap/intel_rapl.c
@@ -1167,11 +1167,10 @@ static int rapl_detect_domains(struct rapl_package *rp, int cpu)
for (i = 0; i < RAPL_DOMAIN_MAX; i++) {
/* use physical package id to read counters */
- if (!rapl_check_domain(cpu, i))
+ if (!rapl_check_domain(cpu, i)) {
rp->domain_map |= 1 << i;
- else
- pr_warn("RAPL domain %s detection failed\n",
- rapl_domain_names[i]);
+ pr_info("Found RAPL domain %s\n", rapl_domain_names[i]);
+ }
}
rp->nr_domains = bitmap_weight(&rp->domain_map, RAPL_DOMAIN_MAX);
if (!rp->nr_domains) {

View File

@ -574,3 +574,4 @@ features/all/psmouse/input-psmouse-disable-palm-detection-in-the-focaltec.patch
bugfix/x86/drm-i915-add-limited-color-range-readout-for-hdmi-dp.patch
bugfix/all/hid-thingm-fix-workqueue-race-on-remove.patch
debian/emmc-don-t-initialize-partitions-on-rpmb-flagged-areas.patch
bugfix/x86/powercap-rapl-change-domain-detection-message.patch