eMMC: Don't initialize partitions on RPMB flagged areas (Closes: #782038)

svn path=/dists/sid/linux/; revision=22483
This commit is contained in:
Ben Hutchings 2015-04-06 19:34:26 +00:00
parent 29d76076b2
commit 2058e12678
3 changed files with 29 additions and 0 deletions

1
debian/changelog vendored
View File

@ -196,6 +196,7 @@ linux (3.16.7-ckt9-1) UNRELEASED; urgency=medium
g4x/vlv/chv (Closes: #775217)
* HID: thingm: fix workqueue race on remove (Closes: #780055)
* [x86] Disable X86_VERBOSE_BOOTUP (Closes: #781953)
* eMMC: Don't initialize partitions on RPMB flagged areas (Closes: #782038)
-- Ian Campbell <ijc@debian.org> Wed, 18 Mar 2015 21:07:15 +0000

View File

@ -0,0 +1,27 @@
From: Nell Hardcastle <nell@dev-nell.com>
Date: Thu, 29 May 2014 22:06:50 -0700
Subject: [PATCH] eMMC: Don't initialize partitions on RPMB flagged areas.
Origin: https://dev-nell.com/rpmb-emmc-errors-under-linux.html
Bug-Debian: https://bugs.debian.org/782038
Prevents a lot of pointless hanging at boot on some devices.
---
[bwh: An RPMB is unlikely to be useful on any platform supported by a Debian
kernel, so I think it's best to hide them for now. Once we are confident
that userland will ignore them or the kernel does a better job of avoiding
hanging reads, we can drop this patch.]
drivers/mmc/card/block.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
--- a/drivers/mmc/card/block.c
+++ b/drivers/mmc/card/block.c
@@ -2258,7 +2258,7 @@ static int mmc_blk_alloc_parts(struct mm
return 0;
for (idx = 0; idx < card->nr_parts; idx++) {
- if (card->part[idx].size) {
+ if (card->part[idx].size && !(card->part[idx].area_type & MMC_BLK_DATA_AREA_RPMB)) {
ret = mmc_blk_alloc_part(card, md,
card->part[idx].part_cfg,
card->part[idx].size >> 9,

View File

@ -573,3 +573,4 @@ features/all/psmouse/input-psmouse-disable-changing-resolution-rate-scale.patch
features/all/psmouse/input-psmouse-disable-palm-detection-in-the-focaltec.patch
bugfix/x86/drm-i915-add-limited-color-range-readout-for-hdmi-dp.patch
bugfix/all/hid-thingm-fix-workqueue-race-on-remove.patch
debian/emmc-don-t-initialize-partitions-on-rpmb-flagged-areas.patch