Update the powerpc-ppc64-biarch-override.patch

from Sven, include as it now applies cleanly.

svn path=/branches/linux-kernel-2.6.12/; revision=3394
This commit is contained in:
Jurij Smakov 2005-06-23 00:46:11 +00:00
parent 13637a762a
commit 2b67fabed9
3 changed files with 47 additions and 2 deletions

4
debian/TODO.patches vendored
View File

@ -10,14 +10,14 @@ powerpc-g4-l2-flush-errata.patch
NOT ACCEPTED. Needs to be reviewed. Last hunk fails to apply NOT ACCEPTED. Needs to be reviewed. Last hunk fails to apply
to include/asm-ppc/cputable.h, as patch introduces a #define to include/asm-ppc/cputable.h, as patch introduces a #define
conflicting with the existing one. conflicting with the existing one.
powerpc-ppc64-biarch-override.patch
NOT ACCEPTED. Needs to be reviewed, as fails to apply completely.
sparc32-hypersparc-srmmu.patch sparc32-hypersparc-srmmu.patch
Presumably not required, but as sparc32 is currently Presumably not required, but as sparc32 is currently
broken, there is no way to tell for sure. broken, there is no way to tell for sure.
These are already processed: These are already processed:
---------------------------- ----------------------------
powerpc-ppc64-biarch-override.patch
ACCEPTED in akpm tree, INCLUDED as a backport.
ia64-generic-nosmp.patch ia64-generic-nosmp.patch
NOT ACCEPTED | REDIFFED | INCLUDED. NOT ACCEPTED | REDIFFED | INCLUDED.
qla2xxx-removed.patch qla2xxx-removed.patch

View File

@ -0,0 +1,44 @@
# Subject: [patch 059/167] ppc64: override command line AS/LD/CC variables when adding -m64 and co for biarch compilers
# To: torvalds@osdl.org
# Cc: akpm@osdl.org, sven.luther@wanadoo.fr, anton@samba.org,
# benh@kernel.crashing.org, paulus@samba.org
# From: akpm@osdl.org
#
# The following kind of calls currently fails :
#
# make ARCH=ppc64 CC="gcc-3.4"
#
# Since the code for detecting a biarch compiler and adding the needed 64bit
# magic argument fails if the AS/LD/CC commands are overriden in the command
# line.
#
# The attached patch fixes this by using the make override and += directive,
# but i am not 100% sure this will work without gmake, as i am no Makefile
# expert.
#
# Cc: Paul Mackerras <paulus@samba.org>
# Cc: Anton Blanchard <anton@samba.org>
# Cc: Benjamin Herrenschmidt <benh@kernel.crashing.org>
# Signed-off-by: Andrew Morton <akpm@osdl.org>
# ---
#
# arch/ppc64/Makefile | 6 +++---
# 1 files changed, 3 insertions(+), 3 deletions(-)
#
diff -puN arch/ppc64/Makefile~ppc64-override-command-line-as-ld-cc-variables-when-adding-m64-and-co-for-biarch-compilers arch/ppc64/Makefile
--- 25/arch/ppc64/Makefile~ppc64-override-command-line-as-ld-cc-variables-when-adding-m64-and-co-for-biarch-compilers 2005-06-21 16:29:10.000000000 -0700
+++ 25-akpm/arch/ppc64/Makefile 2005-06-21 16:29:10.000000000 -0700
@@ -35,9 +35,9 @@ CROSS32AS := $(AS) -a32
CROSS32LD := $(LD) -m elf32ppc
CROSS32OBJCOPY := $(OBJCOPY)
endif
-AS := $(AS) -a64
-LD := $(LD) -m elf64ppc
-CC := $(CC) -m64
+override AS += -a64
+override LD += -m elf64ppc
+override CC += -m64
endif
export CROSS32CC CROSS32AS CROSS32LD CROSS32OBJCOPY
_

View File

@ -21,3 +21,4 @@
+ tty-locking-fixes9.patch + tty-locking-fixes9.patch
+ ia64-generic-nosmp.patch + ia64-generic-nosmp.patch
+ patch-2.6.12.1 + patch-2.6.12.1
+ powerpc-ppc64-biarch-override.patch