irq: Always define devm_{request_threaded,free}_irq() (fixes FTBFS on s390,s390x)

svn path=/dists/trunk/linux/; revision=20501
This commit is contained in:
Ben Hutchings 2013-08-15 20:50:28 +00:00
parent 6fc4aa1bc4
commit 2880548214
3 changed files with 49 additions and 0 deletions

2
debian/changelog vendored
View File

@ -7,6 +7,8 @@ linux (3.11~rc5-1~exp1) UNRELEASED; urgency=low
* trace: Enable KPROBE_EVENT (Closes: #640953)
* trace: Enable UPROBES, UPROBE_EVENT (Closes: #691167)
* [arm] Fix the world famous typo with is_gate_vma()
* irq: Always define devm_{request_threaded,free}_irq() (fixes FTBFS on
s390,s390x)
-- Ben Hutchings <ben@decadent.org.uk> Sun, 11 Aug 2013 19:34:47 +0200

View File

@ -0,0 +1,46 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Thu, 15 Aug 2013 22:00:29 +0200
Subject: irq: Always define devm_{request_threaded,free}_irq()
Forwarded: not-yet
These functions are currently defined only if CONFIG_GENERIC_HARDIRQS
is enabled. But they may still be needed on architectures with their
own IRQ management (e.g. s390).
References: https://buildd.debian.org/status/fetch.php?pkg=linux&arch=s390&ver=3.11%7Erc4-1%7Eexp1&stamp=1376009959
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
kernel/Makefile | 2 +-
kernel/irq/Makefile | 6 ++++--
2 files changed, 5 insertions(+), 3 deletions(-)
diff --git a/kernel/Makefile b/kernel/Makefile
index 35ef118..ed2c9a9 100644
--- a/kernel/Makefile
+++ b/kernel/Makefile
@@ -79,7 +79,7 @@ obj-$(CONFIG_KPROBES) += kprobes.o
obj-$(CONFIG_KGDB) += debug/
obj-$(CONFIG_DETECT_HUNG_TASK) += hung_task.o
obj-$(CONFIG_LOCKUP_DETECTOR) += watchdog.o
-obj-$(CONFIG_GENERIC_HARDIRQS) += irq/
+obj-y += irq/
obj-$(CONFIG_SECCOMP) += seccomp.o
obj-$(CONFIG_RCU_TORTURE_TEST) += rcutorture.o
obj-$(CONFIG_TREE_RCU) += rcutree.o
diff --git a/kernel/irq/Makefile b/kernel/irq/Makefile
index fff1738..639b2e1 100644
--- a/kernel/irq/Makefile
+++ b/kernel/irq/Makefile
@@ -1,8 +1,10 @@
-
-obj-y := irqdesc.o handle.o manage.o spurious.o resend.o chip.o dummychip.o devres.o
+obj-y += devres.o
+ifdef CONFIG_GENERIC_HARDIRQS
+obj-y += irqdesc.o handle.o manage.o spurious.o resend.o chip.o dummychip.o
obj-$(CONFIG_GENERIC_IRQ_CHIP) += generic-chip.o
obj-$(CONFIG_GENERIC_IRQ_PROBE) += autoprobe.o
obj-$(CONFIG_IRQ_DOMAIN) += irqdomain.o
obj-$(CONFIG_PROC_FS) += proc.o
obj-$(CONFIG_GENERIC_PENDING_IRQ) += migration.o
obj-$(CONFIG_PM_SLEEP) += pm.o
+endif

View File

@ -79,3 +79,4 @@ bugfix/m68k/ethernat-kconfig.patch
bugfix/all/nl80211-fix-another-nl80211_fam-attrbuf-race.patch
bugfix/arm/ARM-Fix-the-world-famous-typo-with-is_gate_vma.patch
bugfix/all/irq-Always-define-devm_-request_threaded-free-_irq.patch