mac80211_hwsim: fix possible memory leak in hwsim_new_radio_nl() (CVE-2018-8087)

This commit is contained in:
Salvatore Bonaccorso 2018-03-19 22:30:12 +01:00
parent 6a020907c6
commit 1d363986d0
3 changed files with 42 additions and 0 deletions

4
debian/changelog vendored
View File

@ -669,6 +669,10 @@ linux (4.15.11-1) UNRELEASED; urgency=medium
* [arm64] Apply patch from linux-next to fix eMMC corruption on
Odroid-C2 (Closes: #879072).
[ Salvatore Bonaccorso ]
* mac80211_hwsim: fix possible memory leak in hwsim_new_radio_nl()
(CVE-2018-8087)
-- Salvatore Bonaccorso <carnil@debian.org> Tue, 20 Feb 2018 21:51:39 +0100
linux (4.15.4-1) unstable; urgency=medium

View File

@ -0,0 +1,37 @@
From: "weiyongjun (A)" <weiyongjun1@huawei.com>
Date: Thu, 18 Jan 2018 02:23:34 +0000
Subject: mac80211_hwsim: fix possible memory leak in hwsim_new_radio_nl()
Origin: https://git.kernel.org/linus/0ddcff49b672239dda94d70d0fcf50317a9f4b51
Bug-Debian-Security: https://security-tracker.debian.org/tracker/CVE-2018-8087
'hwname' is malloced in hwsim_new_radio_nl() and should be freed
before leaving from the error handling cases, otherwise it will cause
memory leak.
Fixes: ff4dd73dd2b4 ("mac80211_hwsim: check HWSIM_ATTR_RADIO_NAME length")
Signed-off-by: Wei Yongjun <weiyongjun1@huawei.com>
Reviewed-by: Ben Hutchings <ben.hutchings@codethink.co.uk>
Signed-off-by: Johannes Berg <johannes.berg@intel.com>
---
drivers/net/wireless/mac80211_hwsim.c | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/drivers/net/wireless/mac80211_hwsim.c b/drivers/net/wireless/mac80211_hwsim.c
index 6bf063adcbde..66c2ac0397da 100644
--- a/drivers/net/wireless/mac80211_hwsim.c
+++ b/drivers/net/wireless/mac80211_hwsim.c
@@ -3197,8 +3197,10 @@ static int hwsim_new_radio_nl(struct sk_buff *msg, struct genl_info *info)
if (info->attrs[HWSIM_ATTR_REG_CUSTOM_REG]) {
u32 idx = nla_get_u32(info->attrs[HWSIM_ATTR_REG_CUSTOM_REG]);
- if (idx >= ARRAY_SIZE(hwsim_world_regdom_custom))
+ if (idx >= ARRAY_SIZE(hwsim_world_regdom_custom)) {
+ kfree(hwname);
return -EINVAL;
+ }
param.regd = hwsim_world_regdom_custom[idx];
}
--
2.16.2

View File

@ -119,6 +119,7 @@ features/all/lockdown/arm64-add-kernel-config-option-to-lock-down-when.patch
# Security fixes
debian/i386-686-pae-pci-set-pci-nobios-by-default.patch
bugfix/all/mac80211_hwsim-fix-possible-memory-leak-in-hwsim_new.patch
# Fix exported symbol versions
bugfix/all/module-disable-matching-missing-version-crc.patch