Update to 4.15.11

Drop bugfix/all/crypto-ecc-fix-null-pointer-deref.-on-no-default_rng.patch

Cleanup debian/changelog file
This commit is contained in:
Salvatore Bonaccorso 2018-03-19 11:09:11 +01:00
parent dcdf9a112f
commit 6a020907c6
3 changed files with 107 additions and 39 deletions

108
debian/changelog vendored
View File

@ -1,4 +1,4 @@
linux (4.15.10-1) UNRELEASED; urgency=medium
linux (4.15.11-1) UNRELEASED; urgency=medium
* New upstream stable update:
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.15.5
@ -529,6 +529,112 @@ linux (4.15.10-1) UNRELEASED; urgency=medium
- NFS: Fix an incorrect type in struct nfs_direct_req
- pNFS: Prevent the layout header refcount going to zero in pnfs_roc()
- NFS: Fix unstable write completion
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.15.11
- [x86] Treat R_X86_64_PLT32 as R_X86_64_PC32
- usb: host: xhci-rcar: add support for r8a77965
- xhci: Fix front USB ports on ASUS PRIME B350M-A
- xhci: fix endpoint context tracer output
- [sh4] serial: sh-sci: prevent lockup on full TTY buffers
- tty/serial: atmel: add new version check for usart
- uas: fix comparison for error code
- [x86] staging: comedi: fix comedi_nsamples_left.
- USB: storage: Add JMicron bridge 152d:2567 to unusual_devs.h
- usbip: vudc: fix null pointer dereference on udc->lock
- usb: quirks: add control message delay for 1b1c:1b20
- usb: usbmon: Read text within supplied buffer size
- usb: gadget: f_fs: Fix use-after-free in ffs_fs_kill_sb()
- [arm64,armhf] usb: dwc3: Fix lock-up on ID change during system
suspend/resume
- serial: 8250_pci: Add Brainboxes UC-260 4 port serial device
- serial: core: mark port as initialized in autoconfig
- earlycon: add reg-offset to physical address before mapping
- dm mpath: fix passing integrity data
- Revert "btrfs: use proper endianness accessors for super_copy"
- gfs2: Clean up {lookup,fillup}_metapath
- gfs2: Fixes to "Implement iomap for block_map" (2)
- [armhf] spi: imx: Fix failure path leak on GPIO request error correctly
- HID: multitouch: Only look at non touch fields in first packet of a
frame
- [powerpc*] KVM: Book3S HV: Avoid shifts by negative amounts
- drm/edid: set ELD connector type in drm_edid_to_eld()
- dma-buf/fence: Fix lock inversion within dma-fence-array
- video/hdmi: Allow "empty" HDMI infoframes
- [powerpc*] KVM: Book3S HV: Fix typo in kvmppc_hv_get_dirty_log_radix()
- HID: elo: clear BTN_LEFT mapping
- iwlwifi: mvm: rs: don't override the rate history in the search cycle
- [armhf] dts: exynos: Correct Trats2 panel reset line
- drm/amdgpu: fix get_max_engine_clock_in_mhz
- USB: ledtrig-usbport: fix of-node leak
- dt-bindings: serial: Add common rs485 binding for RTS polarity
- sched: Stop switched_to_rt() from sending IPIs to offline CPUs
- sched: Stop resched_cpu() from sending IPIs to offline CPUs
- crypto: chelsio - Fix an error code in chcr_hash_dma_map()
- crypto: keywrap - Add missing ULL suffixes for 64-bit constants
- crypto: cavium - fix memory leak on info
- test_firmware: fix setting old custom fw path back on exit
- drm/vblank: Fix vblank timestamp debugs
- net: ieee802154: adf7242: Fix bug if defined DEBUG
- perf report: Fix -D output for user metadata events
- net: xfrm: allow clearing socket xfrm policies.
- gpiolib: don't allow OPEN_DRAIN & OPEN_SOURCE flags simultaneously
- mtd: nand: fix interpretation of NAND_CMD_NONE in nand_command[_lp]()
- [arm64] net: thunderx: Set max queue count taking XDP_TX into account
- [armhf] dts: am335x-pepper: Fix the audio CODEC's reset pin
- [armhf] dts: omap3-n900: Fix the audio CODEC's reset pin
- mtd: nand: ifc: update bufnum mask for ver >= 2.0.0
- userns: Don't fail follow_automount based on s_user_ns
- xfrm: Fix xfrm_replay_overflow_offload_esn
- leds: pm8058: Silence pointer to integer size warning
- bpf: fix stack state printing in verifier log
- [armhf] drm/etnaviv: make THERMAL selectable
- ath10k: update tdls teardown state to target
- cpufreq: Fix governor module removal race
- [x86] KVM: Restart the guest when insn_len is zero and SEV is enabled
- drm/amdgpu:fix random missing of FLR NOTIFY
- scsi: lpfc: Fix crash during driver unload with running nvme traffic
- scsi: ses: don't ask for diagnostic pages repeatedly during probe
- [armhf] drm/sun4i: Fix format mask in DE2 driver
- [s390x] perf annotate: Fix unnecessary memory allocation for s390x
- perf annotate: Fix objdump comment parsing for Intel mov dissassembly
- iwlwifi: mvm: avoid dumping assert log when device is stopped
- drm/amdgpu:fix virtual dce bug
- drm/amdgpu: fix amdgpu_sync_resv v2
- bnxt_en: Uninitialized variable in bnxt_tc_parse_actions()
- [arm64] clk: qcom: msm8916: fix mnd_width for codec_digcodec
- mwifiex: cfg80211: do not change virtual interface during scan
processing
- ath10k: fix invalid STS_CAP_OFFSET_MASK
- tools/usbip: fixes build with musl libc toolchain
- [armhf] spi: sun6i: disable/unprepare clocks on remove
- bnxt_en: Don't print "Link speed -1 no longer supported" messages.
- scsi: core: scsi_get_device_flags_keyed(): Always return device flags
- scsi: devinfo: apply to HP XP the same flags as Hitachi VSP
- scsi: dh: add new rdac devices
- media: vsp1: Prevent suspending and resuming DRM pipelines
- dm raid: fix raid set size revalidation
- media: cpia2: Fix a couple off by one bugs
- [arm*] media: davinci: vpif_capture: add NULL check on devm_kzalloc
return value
- virtio_net: Disable interrupts if napi_complete_done rescheduled napi
- net: sched: drop qdisc_reset from dev_graft_qdisc
- veth: set peer GSO values
- [x86] drm/amdkfd: Fix memory leaks in kfd topology
- [powerpc*] modules: Don't try to restore r2 after a sibling call
- [powerpc/powerpc64,ppc64*] Don't trace irqs-off at interrupt return to
soft-disabled context
- [arm64] dts: renesas: salvator-common: Add EthernetAVB PHY reset
- agp/intel: Flush all chipset writes after updating the GGTT
- mac80211_hwsim: enforce PS_MANUAL_POLL to be set after PS_ENABLED
- mac80211: remove BUG() when interface type is invalid
- crypto: caam/qi - use correct print specifier for size_t
- mmc: mmc_test: Ensure command queue is disabled for testing
- Fix misannotated out-of-line _copy_to_user()
- ipvlan: add L2 check for packets arriving via virtual devices
- locking/locktorture: Fix num reader/writer corner cases
- ima: relax requiring a file signature for new files with zero length
- IB/mlx5: revisit -Wmaybe-uninitialized warning
- [arm64] dmaengine: qcom_hidma: check pending interrupts
- [x86] drm/i915/glk: Disable Guc and HuC on GLK
[ Ben Hutchings ]
* aufs: gen-patch: Fix Subject generation to skip SPDX-License-Identifier

View File

@ -1,37 +0,0 @@
From: Pierre <pinaraf@pinaraf.info>
Date: Sun, 12 Nov 2017 15:24:32 +0100
Subject: crypto: ecc - Fix NULL pointer deref. on no default_rng
Origin: https://git.kernel.org/linus/4c0e22c90510308433272d7ba281b1eb4eda8209
Bug-Debian: https://bugs.debian.org/886556
If crypto_get_default_rng returns an error, the
function ecc_gen_privkey should return an error.
Instead, it currently tries to use the default_rng
nevertheless, thus creating a kernel panic with a
NULL pointer dereference.
Returning the error directly, as was supposedly
intended when looking at the code, fixes this.
Signed-off-by: Pierre Ducroquet <pinaraf@pinaraf.info>
Reviewed-by: PrasannaKumar Muralidharan <prasannatsmkumar@gmail.com>
Signed-off-by: Herbert Xu <herbert@gondor.apana.org.au>
---
crypto/ecc.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/crypto/ecc.c b/crypto/ecc.c
index 633a9bcdc574..18f32f2a5e1c 100644
--- a/crypto/ecc.c
+++ b/crypto/ecc.c
@@ -964,7 +964,7 @@ int ecc_gen_privkey(unsigned int curve_id, unsigned int ndigits, u64 *privkey)
* DRBG with a security strength of 256.
*/
if (crypto_get_default_rng())
- err = -EFAULT;
+ return -EFAULT;
err = crypto_rng_get_bytes(crypto_default_rng, (u8 *)priv, nbytes);
crypto_put_default_rng();
--
2.11.0

View File

@ -79,7 +79,6 @@ bugfix/all/fs-add-module_softdep-declarations-for-hard-coded-cr.patch
bugfix/all/partially-revert-usb-kconfig-using-select-for-usb_co.patch
bugfix/all/kbuild-include-addtree-remove-quotes-before-matching-path.patch
debian/revert-objtool-fix-config_stack_validation-y-warning.patch
bugfix/all/crypto-ecc-fix-null-pointer-deref.-on-no-default_rng.patch
# Miscellaneous features