openwrt/toolchain/uClibc/patches-0.9.33.2/210-mips_use_pic_crt1.patch

12 lines
285 B
Diff

--- a/libc/sysdeps/linux/mips/Makefile.arch
+++ b/libc/sysdeps/linux/mips/Makefile.arch
@@ -20,6 +20,8 @@ ifneq ($(UCLIBC_HAS_THREADS_NATIVE),y)
SSRC += vfork.S clone.S
endif
+CFLAGS-crt1.S += $(PICFLAG)
+
ASFLAGS-syscall_error.S += -D_LIBC_REENTRANT
ARCH_HEADERS := sgidefs.h