BB: ubox: fix segmentation fault in insmod

Fix segfault in kmodloader insmod mode due to uninitialized module
directory list.

Apply the required fix as patch for now since we don't have the
ulog infrastructure in BB (yet) required for the git head of ubox.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>

git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@44550 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jow 2015-02-26 21:29:57 +00:00
parent 11fa76da82
commit 878af3117f
2 changed files with 13 additions and 1 deletions

View File

@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ubox
PKG_VERSION:=2015-02-25
PKG_VERSION:=2015-02-25.1
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git

View File

@ -0,0 +1,12 @@
--- a/kmodloader.c
+++ b/kmodloader.c
@@ -605,6 +605,9 @@ static int main_insmod(int argc, char **
cur += sprintf(cur, "%s", argv[i]);
}
+ if (init_module_folders())
+ return -1;
+
if (get_module_path(argv[1])) {
name = argv[1];
} else if (!get_module_path(name)) {