BB: polarssl: update to v1.3.9 and patch CVE-2015-1182

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>

git-svn-id: svn://svn.openwrt.org/openwrt/branches/barrier_breaker@44061 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jow 2015-01-20 13:02:38 +00:00
parent 60abf1305e
commit 179d925d85
3 changed files with 15 additions and 41 deletions

View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2011-2013 OpenWrt.org
# Copyright (C) 2011-2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -8,15 +8,16 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=polarssl
PKG_VERSION:=1.3.8
PKG_VERSION:=1.3.9
PKG_RELEASE:=2
PKG_USE_MIPS16:=0
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-gpl.tgz
PKG_SOURCE_URL:=https://polarssl.org/code/releases
PKG_MD5SUM:=d1a2b4f21727e888f143414d2e3144e6
PKG_MD5SUM:=48af7d1f0d5de512cbd6dacf5407884c
PKG_BUILD_PARALLEL:=1
PKG_LICENSE:=GPL-2.0+
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk

View File

@ -1,38 +0,0 @@
--- a/programs/pkey/gen_key.c
+++ b/programs/pkey/gen_key.c
@@ -215,7 +215,9 @@ int main( int argc, char *argv[] )
opt.type = DFL_TYPE;
opt.rsa_keysize = DFL_RSA_KEYSIZE;
+#if defined(POLARSSL_ECP_C)
opt.ec_curve = DFL_EC_CURVE;
+#endif
opt.filename = DFL_FILENAME;
opt.format = DFL_FORMAT;
opt.use_dev_random = DFL_USE_DEV_RANDOM;
@@ -231,8 +233,10 @@ int main( int argc, char *argv[] )
{
if( strcmp( q, "rsa" ) == 0 )
opt.type = POLARSSL_PK_RSA;
+#if defined(POLARSSL_ECP_C)
else if( strcmp( q, "ec" ) == 0 )
opt.type = POLARSSL_PK_ECKEY;
+#endif
else
goto usage;
}
@@ -251,12 +255,14 @@ int main( int argc, char *argv[] )
if( opt.rsa_keysize < 1024 || opt.rsa_keysize > 8192 )
goto usage;
}
+#if defined(POLARSSL_ECP_C)
else if( strcmp( p, "ec_curve" ) == 0 )
{
if( ( curve_info = ecp_curve_info_from_name( q ) ) == NULL )
goto usage;
opt.ec_curve = curve_info->grp_id;
}
+#endif
else if( strcmp( p, "filename" ) == 0 )
opt.filename = q;
else if( strcmp( p, "use_dev_random" ) == 0 )

View File

@ -0,0 +1,11 @@
--- a/library/asn1parse.c
+++ b/library/asn1parse.c
@@ -278,6 +278,8 @@ int asn1_get_sequence_of( unsigned char
if( cur->next == NULL )
return( POLARSSL_ERR_ASN1_MALLOC_FAILED );
+ memset( cur->next, 0, sizeof( asn1_sequence ) );
+
cur = cur->next;
}
}