Browse Source

cramfs: mark as obsolete

Who needs cramfs when you have squashfs?  At least, we should warn people
that cramfs is obsolete.

Signed-off-by: Michael Opdenacker <michael.opdenacker@free-electrons.com>
Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
master
Michael Opdenacker 8 years ago
committed by Linus Torvalds
parent
commit
54886a7153
  1. 2
      MAINTAINERS
  2. 5
      fs/cramfs/Kconfig

2
MAINTAINERS

@ -2373,7 +2373,7 @@ F: kernel/cpuset.c
CRAMFS FILESYSTEM
W: http://sourceforge.net/projects/cramfs/
S: Orphan
S: Orphan / Obsolete
F: Documentation/filesystems/cramfs.txt
F: fs/cramfs/

5
fs/cramfs/Kconfig

@ -1,5 +1,5 @@
config CRAMFS
tristate "Compressed ROM file system support (cramfs)"
tristate "Compressed ROM file system support (cramfs) (OBSOLETE)"
depends on BLOCK
select ZLIB_INFLATE
help
@ -16,4 +16,7 @@ config CRAMFS
cramfs. Note that the root file system (the one containing the
directory /) cannot be compiled as a module.
This filesystem is obsoleted by SquashFS, which is much better
in terms of performance and features.
If unsure, say N.
Loading…
Cancel
Save