libspatialite: Upgrade to version 4.2.0

Package the new sqlite3 plugin into a new package and skip
the dev-so qa issue. Add some extra depends that are now used
by the library.
This commit is contained in:
Holger Hans Peter Freyther 2014-11-22 15:12:43 +01:00
parent 188f5fc60c
commit 37deb6091c
5 changed files with 27 additions and 210 deletions

View File

@ -0,0 +1,13 @@
Index: libspatialite-4.2.0/configure.ac
===================================================================
--- libspatialite-4.2.0.orig/configure.ac
+++ libspatialite-4.2.0/configure.ac
@@ -260,7 +260,7 @@ if test x"$enable_geos" != "xno"; then
fi
# Extract the linker and include flags
GEOS_LDFLAGS=`$GEOSCONFIG --ldflags`
- GEOS_CFLAGS=-I`$GEOSCONFIG --includes`
+ GEOS_CFLAGS=`$GEOSCONFIG --cflags`
AC_SUBST([GEOS_LDFLAGS])
AC_SUBST([GEOS_CFLAGS])
# Ensure that we can parse geos_c.h

View File

@ -1,7 +1,7 @@
DESCRIPTION = "Library extending the SQLite core to support fully fledged Spatial SQL capabilities"
HOMEPAGE = "https://www.gaia-gis.it/fossil/libspatialite/"
SECTION = "libs"
DEPENDS = "proj geos sqlite3"
DEPENDS = "proj geos sqlite3 libxml2 zlib"
INC_PR = "r0"
@ -14,3 +14,8 @@ inherit autotools pkgconfig
EXTRA_OECONF = "--enable-freexl=no"
# A plugins for SQLite3
PACKAGES += "${PN}-plugin"
INSANE_SKIP_${PN}-plugin = "dev-so"
FILES_${PN}-plugin += "${libdir}/mod_*"

View File

@ -1,200 +0,0 @@
From upstream fossil repo, extracted via git, dropping configure.ac for amalgamation
From: sandro <sandro>
Date: Sat, 21 Jan 2012 16:53:28 +0000
Subject: [PATCH] fixing the ./configure script: --enable-geocallbacks=no is
the new default and fixing some flaws for
--enable-freexl=no
---
configure | 20 ++++++++++----------
configure.ac | 20 ++++++++++----------
src/shapefiles/shapefiles.c | 2 ++
4 files changed, 32 insertions(+), 30 deletions(-)
diff --git a/configure b/configure
index e8cf620..917bfca 100755
--- a/configure
+++ b/configure
@@ -1410,7 +1410,7 @@ Optional Features:
optimize for fast installation [default=yes]
--disable-libtool-lock avoid locking (might break parallel builds)
--enable-mathsql enables SQL math functions [default=yes]
- --enable-geocallbacks enables geometry callbacks [default=yes]
+ --enable-geocallbacks enables geometry callbacks [default=no]
--enable-proj enables PROJ.4 inclusion [default=yes]
--enable-geos enables GEOS inclusion [default=yes]
--enable-geosadvanced enables GEOS advanced features [default=yes]
@@ -16980,7 +16980,7 @@ ac_config_files="$ac_config_files Makefile src/Makefile src/headers/Makefile src
if test "${enable_mathsql+set}" = set; then :
enableval=$enable_mathsql;
else
- mathsql=yes
+ enable_mathsql=yes
fi
if test x"$enable_mathsql" != "xno"; then
@@ -16998,10 +16998,10 @@ fi
if test "${enable_geocallbacks+set}" = set; then :
enableval=$enable_geocallbacks;
else
- geocallbacks=yes
+ enable_geocallbacks=no
fi
-if test x"$enable_geocallbacks" != "xno"; then
+if test x"$enable_geocallbacks" == "xyes"; then
OMIT_GEOCALLBACKS_FLAGS=
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for sqlite3_rtree_geometry_callback in -lsqlite3" >&5
$as_echo_n "checking for sqlite3_rtree_geometry_callback in -lsqlite3... " >&6; }
@@ -17063,7 +17063,7 @@ fi
if test "${enable_proj+set}" = set; then :
enableval=$enable_proj;
else
- proj=yes
+ enable_proj=yes
fi
if test x"$enable_proj" != "xno"; then
@@ -17153,7 +17153,7 @@ fi
if test "${enable_geos+set}" = set; then :
enableval=$enable_geos;
else
- geos=yes
+ enable_geos=yes
fi
if test x"$enable_geos" != "xno"; then
@@ -17237,7 +17237,7 @@ fi
if test "${enable_geosadvanced+set}" = set; then :
enableval=$enable_geosadvanced;
else
- geosadvanced=yes
+ enable_geosadvanced=yes
fi
if test x"$enable_geosadvanced" != "xno"; then
@@ -17316,7 +17316,7 @@ fi
if test "${enable_iconv+set}" = set; then :
enableval=$enable_iconv;
else
- geos=yes
+ enable_iconv=yes
fi
if test x"$enable_iconv" != "xno"; then
@@ -17579,7 +17579,7 @@ fi
if test "${enable_freexl+set}" = set; then :
enableval=$enable_freexl;
else
- proj=yes
+ enable_freexl=yes
fi
if test x"$enable_freexl" != "xno"; then
@@ -17669,7 +17669,7 @@ fi
if test "${enable_epsg+set}" = set; then :
enableval=$enable_epsg;
else
- epsg=yes
+ enable_epsg=yes
fi
if test x"$enable_epsg" != "xno"; then
diff --git a/configure.ac b/configure.ac
index 216cc9f..69cb6c5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -79,7 +79,7 @@ AC_CONFIG_FILES([Makefile \
#
AC_ARG_ENABLE(mathsql, [AS_HELP_STRING(
[--enable-mathsql], [enables SQL math functions [default=yes]])],
- [], [mathsql=yes])
+ [], [enable_mathsql=yes])
if test x"$enable_mathsql" != "xno"; then
OMIT_MATHSQL_FLAGS=
else
@@ -92,9 +92,9 @@ AC_SUBST(OMIT_MATHSQL_FLAGS)
# --enable-geocallbacks
#
AC_ARG_ENABLE(geocallbacks, [AS_HELP_STRING(
- [--enable-geocallbacks], [enables geometry callbacks [default=yes]])],
- [], [geocallbacks=yes])
-if test x"$enable_geocallbacks" != "xno"; then
+ [--enable-geocallbacks], [enables geometry callbacks [default=no]])],
+ [], [enable_geocallbacks=no])
+if test x"$enable_geocallbacks" == "xyes"; then
OMIT_GEOCALLBACKS_FLAGS=
AC_CHECK_LIB(sqlite3,sqlite3_rtree_geometry_callback,,AC_MSG_ERROR([obsolete 'libsqlite3' (< v.3.7.3). please retry specifying: --disable-geocallbacks]),-lm)
else
@@ -108,7 +108,7 @@ AC_SUBST(OMIT_GEOCALLBACKS_FLAGS)
#
AC_ARG_ENABLE(proj, [AS_HELP_STRING(
[--enable-proj], [enables PROJ.4 inclusion [default=yes]])],
- [], [proj=yes])
+ [], [enable_proj=yes])
if test x"$enable_proj" != "xno"; then
OMIT_PROJ_FLAGS=
AC_CHECK_HEADERS(proj_api.h,, [AC_MSG_ERROR([cannot find proj_api.h, bailing out])])
@@ -124,7 +124,7 @@ AC_SUBST(OMIT_PROJ_FLAGS)
#
AC_ARG_ENABLE(geos, [AS_HELP_STRING(
[--enable-geos], [enables GEOS inclusion [default=yes]])],
- [], [geos=yes])
+ [], [enable_geos=yes])
if test x"$enable_geos" != "xno"; then
OMIT_GEOS_FLAGS=
AC_CHECK_HEADERS(geos_c.h,, [AC_MSG_ERROR([cannot find geos_c.h, bailing out])])
@@ -134,7 +134,7 @@ if test x"$enable_geos" != "xno"; then
#
AC_ARG_ENABLE(geosadvanced, [AS_HELP_STRING(
[--enable-geosadvanced], [enables GEOS advanced features [default=yes]])],
- [], [geosadvanced=yes])
+ [], [enable_geosadvanced=yes])
if test x"$enable_geosadvanced" != "xno"; then
GEOSADVANCED_FLAGS=-DGEOS_ADVANCED
AC_SEARCH_LIBS(GEOSCoveredBy,geos_c,,AC_MSG_ERROR([obsolete 'libgeos_c' (< v.3.3.0). please retry specifying: --disable-geosadvanced.]),-lm -lgeos)
@@ -152,7 +152,7 @@ AC_SUBST(OMIT_GEOS_FLAGS)
#
AC_ARG_ENABLE(iconv, [AS_HELP_STRING(
[--enable-iconv], [enables ICONV inclusion [default=yes]])],
- [], [geos=yes])
+ [], [enable_iconv=yes])
if test x"$enable_iconv" != "xno"; then
OMIT_ICONV_FLAGS=
AC_CHECK_HEADERS(iconv.h,, [AC_MSG_ERROR([cannot find iconv.h, bailing out])])
@@ -172,7 +172,7 @@ AC_SUBST(OMIT_ICONV_FLAGS)
#
AC_ARG_ENABLE(freexl, [AS_HELP_STRING(
[--enable-freexl], [enables FreeXL inclusion [default=yes]])],
- [], [proj=yes])
+ [], [enable_freexl=yes])
if test x"$enable_freexl" != "xno"; then
OMIT_FREEXL_FLAGS=
AC_CHECK_HEADERS(freexl.h,, [AC_MSG_ERROR([cannot find freexl.h, bailing out])])
@@ -188,7 +188,7 @@ AC_SUBST(OMIT_FREEXL_FLAGS)
#
AC_ARG_ENABLE(epsg, [AS_HELP_STRING(
[--enable-epsg], [enables full EPSG dataset support [default=yes]])],
- [], [epsg=yes])
+ [], [enable_epsg=yes])
if test x"$enable_epsg" != "xno"; then
OMIT_EPSG_FLAGS=
else
diff --git a/src/shapefiles/shapefiles.c b/src/shapefiles/shapefiles.c
index 4bf5fd0..09e3cd3 100644
--- a/src/shapefiles/shapefiles.c
+++ b/src/shapefiles/shapefiles.c
@@ -62,7 +62,9 @@ the terms of any one of the MPL, the GPL or the LGPL.
#include <spatialite/gaiageo.h>
#include <spatialite.h>
+#ifndef OMIT_FREEXL
#include <freexl.h>
+#endif
#if defined(_WIN32) && !defined(__MINGW32__)
#define strcasecmp _stricmp
--
1.7.9.1

View File

@ -1,9 +0,0 @@
require libspatialite.inc
PR = "${INC_PR}.0"
SRC_URI[md5sum] = "450d1a0d9da1bd9f770b7db3f2509f69"
SRC_URI[sha256sum] = "4983d6584069fd5ff0cfcccccee1015088dab2db177c0dc7050ce8306b68f8e6"
SRC_URI =+ "file://fix-the-configure-script-and-freexl.patch"

View File

@ -0,0 +1,8 @@
require libspatialite.inc
PR = "${INC_PR}.0"
SRC_URI[md5sum] = "83305ed694a77152120d1f74c5151779"
SRC_URI[sha256sum] = "9f138a6854740c7827fdee53845eb1485fce3e805a7aa9fc9151f8046ebd312d"
SRC_URI += "file://geos-config.patch"