dizzy: Begin with the Poky/Yocto 1.7 release

We are currently using 1.5 (dora). Copy the bbappends to the
yocto-dizzy directory and update the version numbers. For busybox
enable all features that were enabled between dora and origin/master.

For opkg_svn.bbapend. In dizzy there is a version attached to it.
This means we need to remove it from the yocto-shared directory
and keep it everywhere else.
This commit is contained in:
Holger Hans Peter Freyther 2014-09-24 18:26:10 +02:00
parent 12a661314b
commit 20b1decdd2
22 changed files with 1142 additions and 2 deletions

View File

@ -8,8 +8,8 @@ BBFILES += "${LAYERDIR}/yocto-shared/*.bbappend"
# Now we will need to include the matching fixes for a yocto version
BBFILES += "${BBFILES_SYSMOCOM_BSP}"
# selects specific distro or master when DISTRO_VERSION contains SNAPSHOT
BBFILES_SYSMOCOM_BSP = "${LAYERDIR}/yocto-${@ [dict([('1.5', 'dora'), ('1.1','edison')])[d.getVar('DISTRO_VERSION', True)[0:3]], 'master']['SNAPSHOT' in d.getVar('DISTRO_VERSION', True)]}/*.bbappend"
# selects specific distro or master when DISTRO_VERSION contains snapshot
BBFILES_SYSMOCOM_BSP = "${LAYERDIR}/yocto-${@ [dict([('1.5', 'dora'), ('1.1','edison'), ('1.7', 'dizzy')])[d.getVar('DISTRO_VERSION', True)[0:3]], 'master']['snapshot' in d.getVar('DISTRO_VERSION', True)]}/*.bbappend"
BBFILE_COLLECTIONS += "sysmocom-bsp"
BBFILE_PATTERN_sysmocom-bsp := "^${LAYERDIR}/"

View File

@ -0,0 +1,36 @@
#!/bin/sh
DAEMON=/usr/sbin/ifplugd
NAME=ifplugd
DESC="Busybox ifplugd Server"
ARGS=" -i eth0 -M -I -r /etc/ifplugd.sh"
test -f $DAEMON || exit 1
set -e
case "$1" in
start)
echo -n "starting $DESC: $NAME... "
/sbin/start-stop-daemon -S -b -n $NAME -a $DAEMON -- $ARGS
echo "done."
;;
stop)
echo -n "stopping $DESC: $NAME... "
/sbin/start-stop-daemon -K -n $NAME
echo "done."
;;
restart)
echo "Not restarting $DESC: $NAME... "
;;
reload)
echo -n "reloading $DESC: $NAME... "
killall -HUP $(basename ${DAEMON})
echo "done."
;;
*)
echo "Usage: $0 {start|stop|restart|reload}"
exit 1
;;
esac
exit 0

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,62 @@
Upstream-Status: Backport
Signed-off-by: Henning Heinold <henning@itconsulting-heinold.de>
From da331d779c19d7d5d4ef05152ee467d617913a01 Mon Sep 17 00:00:00 2001
From: Tito Ragusa <farmatito@tiscali.it>
Date: Sun, 4 Aug 2013 18:08:40 +0200
Subject: [PATCH 001/104] ifplugd: use a larger netlink buffer
function old new delta
check_existence_through_netlink 310 321 +11
Signed-off-by: Tito Ragusa <farmatito@tiscali.it>
Signed-off-by: Denys Vlasenko <vda.linux@googlemail.com>
---
networking/ifplugd.c | 14 ++++++++++----
1 file changed, 10 insertions(+), 4 deletions(-)
diff --git a/networking/ifplugd.c b/networking/ifplugd.c
index 3cdc2c9..b578f4c 100644
--- a/networking/ifplugd.c
+++ b/networking/ifplugd.c
@@ -451,20 +451,24 @@ static smallint detect_link(void)
static NOINLINE int check_existence_through_netlink(void)
{
int iface_len;
- char replybuf[1024];
+ /* Buffer was 1K, but on linux-3.9.9 it was reported to be too small.
+ * netlink.h: "limit to 8K to avoid MSG_TRUNC when PAGE_SIZE is very large".
+ * Note: on error returns (-1) we exit, no need to free replybuf.
+ */
+ enum { BUF_SIZE = 8 * 1024 };
+ char *replybuf = xmalloc(BUF_SIZE);
iface_len = strlen(G.iface);
while (1) {
struct nlmsghdr *mhdr;
ssize_t bytes;
- bytes = recv(netlink_fd, &replybuf, sizeof(replybuf), MSG_DONTWAIT);
+ bytes = recv(netlink_fd, replybuf, BUF_SIZE, MSG_DONTWAIT);
if (bytes < 0) {
if (errno == EAGAIN)
- return G.iface_exists;
+ goto ret;
if (errno == EINTR)
continue;
-
bb_perror_msg("netlink: recv");
return -1;
}
@@ -507,6 +511,8 @@ static NOINLINE int check_existence_through_netlink(void)
}
}
+ ret:
+ free(replybuf);
return G.iface_exists;
}
--
1.7.10.4

View File

@ -0,0 +1,4 @@
# PN/PV are wrong inside the .inc file with 1.19.1
SYSMOCOM_ORIG_PV := "${PV}"
require recipes-core/busybox/${PN}_sysmocom.inc
require recipes-core/busybox/${PN}_sysmocom_systemd.inc

View File

@ -0,0 +1,2 @@
# add e2fsprogs for resize2fs need for bts installation
IMAGE_INSTALL_append = " e2fsprogs "

View File

@ -0,0 +1 @@
require recipes-fixes/${PN}/${PN}_sysmocom_systemd.inc

View File

@ -0,0 +1 @@
require recipes-fixes/dropbear/${PN}_sysmocom.inc

View File

@ -0,0 +1 @@
require recipes-bsp/netbase/${PN}_sysmocom.inc

View File

@ -0,0 +1 @@
require recipes-core/initrdscripts/${PN}_sysmocom.inc

View File

@ -0,0 +1 @@
require recipes-bsp/netbase/${PN}_sysmocom.inc

View File

@ -0,0 +1 @@
require recipes-fixes/${PN}/${PN}_sysmocom.inc

View File

@ -0,0 +1,2 @@
require recipes-fixes/systemd/${PN}_sysmocom.inc

View File

@ -0,0 +1 @@
require recipes-fixes/${PN}/${PN}_sysmocom.inc

View File

@ -0,0 +1 @@
require recipes-sysmobts/uboot/${PN}_sysmocom.inc

View File

@ -0,0 +1 @@
require recipes-fixes/${PN}/${PN}_sysmocom.inc

View File

@ -0,0 +1 @@
require recipes-fixes/${PN}/${PN}_angstrom.inc

View File

@ -0,0 +1 @@
require recipes-bsp/watchdog/${PN}_sysmocom.inc

View File

@ -0,0 +1 @@
require recipes-fixes/wireless-tools/${PN}_sysmocom.inc

View File

@ -0,0 +1 @@
require recipes-fixes/${PN}/${PN}_sysmocom.inc

View File

@ -0,0 +1 @@
require recipes-fixes/${PN}/${PN}_sysmocom.inc