Import from meta-oe to have a spatial enabled sqlite

This commit is contained in:
Holger Hans Peter Freyther 2014-11-22 13:54:17 +01:00
parent f7004f3315
commit 188f5fc60c
7 changed files with 305 additions and 0 deletions

View File

@ -0,0 +1,39 @@
From 9d51027c228dafd7db2d0cffca1f0fc695e950fd Mon Sep 17 00:00:00 2001
From: Otavio Salvador <otavio@ossystems.com.br>
Date: Mon, 2 Dec 2013 11:33:26 -0200
Subject: [PATCH] geos-config: Add includedir variable
This fixes cross-compile as it is easier to mangle the includedir
during sysroot generation.
Upstream-Status: Pending
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
---
tools/geos-config.in | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/tools/geos-config.in b/tools/geos-config.in
index 9b45b5f..1749892 100644
--- a/tools/geos-config.in
+++ b/tools/geos-config.in
@@ -1,6 +1,7 @@
#!/bin/sh
prefix=@prefix@
exec_prefix=@exec_prefix@
+includedir=@includedir@
libdir=@libdir@
usage()
@@ -38,7 +39,7 @@ case $1 in
echo @VERSION@
;;
--cflags)
- echo -I${prefix}/include
+ echo -I${includedir}
;;
--libs)
# TODO: make an alias for --clibs
--
1.7.10.4

View File

@ -0,0 +1,21 @@
DESCRIPTION = "GEOS - Geometry Engine, Open Source"
HOMEPAGE = "http://trac.osgeo.org/geos/"
SECTION = "libs"
LICENSE = "LGPLv2.1+"
LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
SRC_URI = "http://download.osgeo.org/geos/geos-${PV}.tar.bz2"
inherit autotools pkgconfig binconfig
PACKAGES =+ "geoslib ${PN}-c1"
DESCRIPTION_${PN}lib = "Geometry engine for Geographic Information Systems - C++ Library"
FILES_${PN}lib += "${libdir}/libgeos-${PV}.so"
DESCRIPTION_${PN}-c1 = "Geometry engine for Geographic Information Systems - C Library"
FILES_${PN}-c1 += "${libdir}/libgeos_c.so.*"
ALLOW_EMPTY_${PN} = "1"
RDEPENDS_${PN} += "geoslib ${PN}-c1"

View File

@ -0,0 +1,6 @@
require geos.inc
SRC_URI += "file://geos-config-Add-includedir-variable.patch"
SRC_URI[md5sum] = "fc5df2d926eb7e67f988a43a92683bae"
SRC_URI[sha256sum] = "15e8bfdf7e29087a957b56ac543ea9a80321481cef4d4f63a7b268953ad26c53"

View File

@ -0,0 +1,16 @@
DESCRIPTION = "Library extending the SQLite core to support fully fledged Spatial SQL capabilities"
HOMEPAGE = "https://www.gaia-gis.it/fossil/libspatialite/"
SECTION = "libs"
DEPENDS = "proj geos sqlite3"
INC_PR = "r0"
LICENSE = "MPLv1.1 GPLv2+ LGPLv2.1+"
LIC_FILES_CHKSUM = "file://COPYING;md5=0e92e1a36cc384b60f5b31dde0bdd39e"
SRC_URI = "http://www.gaia-gis.it/gaia-sins/libspatialite-sources/libspatialite-${PV}.tar.gz"
inherit autotools pkgconfig
EXTRA_OECONF = "--enable-freexl=no"

View File

@ -0,0 +1,200 @@
From upstream fossil repo, extracted via git, dropping configure.ac for amalgamation
From: sandro <sandro>
Date: Sat, 21 Jan 2012 16:53:28 +0000
Subject: [PATCH] fixing the ./configure script: --enable-geocallbacks=no is
the new default and fixing some flaws for
--enable-freexl=no
---
configure | 20 ++++++++++----------
configure.ac | 20 ++++++++++----------
src/shapefiles/shapefiles.c | 2 ++
4 files changed, 32 insertions(+), 30 deletions(-)
diff --git a/configure b/configure
index e8cf620..917bfca 100755
--- a/configure
+++ b/configure
@@ -1410,7 +1410,7 @@ Optional Features:
optimize for fast installation [default=yes]
--disable-libtool-lock avoid locking (might break parallel builds)
--enable-mathsql enables SQL math functions [default=yes]
- --enable-geocallbacks enables geometry callbacks [default=yes]
+ --enable-geocallbacks enables geometry callbacks [default=no]
--enable-proj enables PROJ.4 inclusion [default=yes]
--enable-geos enables GEOS inclusion [default=yes]
--enable-geosadvanced enables GEOS advanced features [default=yes]
@@ -16980,7 +16980,7 @@ ac_config_files="$ac_config_files Makefile src/Makefile src/headers/Makefile src
if test "${enable_mathsql+set}" = set; then :
enableval=$enable_mathsql;
else
- mathsql=yes
+ enable_mathsql=yes
fi
if test x"$enable_mathsql" != "xno"; then
@@ -16998,10 +16998,10 @@ fi
if test "${enable_geocallbacks+set}" = set; then :
enableval=$enable_geocallbacks;
else
- geocallbacks=yes
+ enable_geocallbacks=no
fi
-if test x"$enable_geocallbacks" != "xno"; then
+if test x"$enable_geocallbacks" == "xyes"; then
OMIT_GEOCALLBACKS_FLAGS=
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for sqlite3_rtree_geometry_callback in -lsqlite3" >&5
$as_echo_n "checking for sqlite3_rtree_geometry_callback in -lsqlite3... " >&6; }
@@ -17063,7 +17063,7 @@ fi
if test "${enable_proj+set}" = set; then :
enableval=$enable_proj;
else
- proj=yes
+ enable_proj=yes
fi
if test x"$enable_proj" != "xno"; then
@@ -17153,7 +17153,7 @@ fi
if test "${enable_geos+set}" = set; then :
enableval=$enable_geos;
else
- geos=yes
+ enable_geos=yes
fi
if test x"$enable_geos" != "xno"; then
@@ -17237,7 +17237,7 @@ fi
if test "${enable_geosadvanced+set}" = set; then :
enableval=$enable_geosadvanced;
else
- geosadvanced=yes
+ enable_geosadvanced=yes
fi
if test x"$enable_geosadvanced" != "xno"; then
@@ -17316,7 +17316,7 @@ fi
if test "${enable_iconv+set}" = set; then :
enableval=$enable_iconv;
else
- geos=yes
+ enable_iconv=yes
fi
if test x"$enable_iconv" != "xno"; then
@@ -17579,7 +17579,7 @@ fi
if test "${enable_freexl+set}" = set; then :
enableval=$enable_freexl;
else
- proj=yes
+ enable_freexl=yes
fi
if test x"$enable_freexl" != "xno"; then
@@ -17669,7 +17669,7 @@ fi
if test "${enable_epsg+set}" = set; then :
enableval=$enable_epsg;
else
- epsg=yes
+ enable_epsg=yes
fi
if test x"$enable_epsg" != "xno"; then
diff --git a/configure.ac b/configure.ac
index 216cc9f..69cb6c5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -79,7 +79,7 @@ AC_CONFIG_FILES([Makefile \
#
AC_ARG_ENABLE(mathsql, [AS_HELP_STRING(
[--enable-mathsql], [enables SQL math functions [default=yes]])],
- [], [mathsql=yes])
+ [], [enable_mathsql=yes])
if test x"$enable_mathsql" != "xno"; then
OMIT_MATHSQL_FLAGS=
else
@@ -92,9 +92,9 @@ AC_SUBST(OMIT_MATHSQL_FLAGS)
# --enable-geocallbacks
#
AC_ARG_ENABLE(geocallbacks, [AS_HELP_STRING(
- [--enable-geocallbacks], [enables geometry callbacks [default=yes]])],
- [], [geocallbacks=yes])
-if test x"$enable_geocallbacks" != "xno"; then
+ [--enable-geocallbacks], [enables geometry callbacks [default=no]])],
+ [], [enable_geocallbacks=no])
+if test x"$enable_geocallbacks" == "xyes"; then
OMIT_GEOCALLBACKS_FLAGS=
AC_CHECK_LIB(sqlite3,sqlite3_rtree_geometry_callback,,AC_MSG_ERROR([obsolete 'libsqlite3' (< v.3.7.3). please retry specifying: --disable-geocallbacks]),-lm)
else
@@ -108,7 +108,7 @@ AC_SUBST(OMIT_GEOCALLBACKS_FLAGS)
#
AC_ARG_ENABLE(proj, [AS_HELP_STRING(
[--enable-proj], [enables PROJ.4 inclusion [default=yes]])],
- [], [proj=yes])
+ [], [enable_proj=yes])
if test x"$enable_proj" != "xno"; then
OMIT_PROJ_FLAGS=
AC_CHECK_HEADERS(proj_api.h,, [AC_MSG_ERROR([cannot find proj_api.h, bailing out])])
@@ -124,7 +124,7 @@ AC_SUBST(OMIT_PROJ_FLAGS)
#
AC_ARG_ENABLE(geos, [AS_HELP_STRING(
[--enable-geos], [enables GEOS inclusion [default=yes]])],
- [], [geos=yes])
+ [], [enable_geos=yes])
if test x"$enable_geos" != "xno"; then
OMIT_GEOS_FLAGS=
AC_CHECK_HEADERS(geos_c.h,, [AC_MSG_ERROR([cannot find geos_c.h, bailing out])])
@@ -134,7 +134,7 @@ if test x"$enable_geos" != "xno"; then
#
AC_ARG_ENABLE(geosadvanced, [AS_HELP_STRING(
[--enable-geosadvanced], [enables GEOS advanced features [default=yes]])],
- [], [geosadvanced=yes])
+ [], [enable_geosadvanced=yes])
if test x"$enable_geosadvanced" != "xno"; then
GEOSADVANCED_FLAGS=-DGEOS_ADVANCED
AC_SEARCH_LIBS(GEOSCoveredBy,geos_c,,AC_MSG_ERROR([obsolete 'libgeos_c' (< v.3.3.0). please retry specifying: --disable-geosadvanced.]),-lm -lgeos)
@@ -152,7 +152,7 @@ AC_SUBST(OMIT_GEOS_FLAGS)
#
AC_ARG_ENABLE(iconv, [AS_HELP_STRING(
[--enable-iconv], [enables ICONV inclusion [default=yes]])],
- [], [geos=yes])
+ [], [enable_iconv=yes])
if test x"$enable_iconv" != "xno"; then
OMIT_ICONV_FLAGS=
AC_CHECK_HEADERS(iconv.h,, [AC_MSG_ERROR([cannot find iconv.h, bailing out])])
@@ -172,7 +172,7 @@ AC_SUBST(OMIT_ICONV_FLAGS)
#
AC_ARG_ENABLE(freexl, [AS_HELP_STRING(
[--enable-freexl], [enables FreeXL inclusion [default=yes]])],
- [], [proj=yes])
+ [], [enable_freexl=yes])
if test x"$enable_freexl" != "xno"; then
OMIT_FREEXL_FLAGS=
AC_CHECK_HEADERS(freexl.h,, [AC_MSG_ERROR([cannot find freexl.h, bailing out])])
@@ -188,7 +188,7 @@ AC_SUBST(OMIT_FREEXL_FLAGS)
#
AC_ARG_ENABLE(epsg, [AS_HELP_STRING(
[--enable-epsg], [enables full EPSG dataset support [default=yes]])],
- [], [epsg=yes])
+ [], [enable_epsg=yes])
if test x"$enable_epsg" != "xno"; then
OMIT_EPSG_FLAGS=
else
diff --git a/src/shapefiles/shapefiles.c b/src/shapefiles/shapefiles.c
index 4bf5fd0..09e3cd3 100644
--- a/src/shapefiles/shapefiles.c
+++ b/src/shapefiles/shapefiles.c
@@ -62,7 +62,9 @@ the terms of any one of the MPL, the GPL or the LGPL.
#include <spatialite/gaiageo.h>
#include <spatialite.h>
+#ifndef OMIT_FREEXL
#include <freexl.h>
+#endif
#if defined(_WIN32) && !defined(__MINGW32__)
#define strcasecmp _stricmp
--
1.7.9.1

View File

@ -0,0 +1,9 @@
require libspatialite.inc
PR = "${INC_PR}.0"
SRC_URI[md5sum] = "450d1a0d9da1bd9f770b7db3f2509f69"
SRC_URI[sha256sum] = "4983d6584069fd5ff0cfcccccee1015088dab2db177c0dc7050ce8306b68f8e6"
SRC_URI =+ "file://fix-the-configure-script-and-freexl.patch"

View File

@ -0,0 +1,14 @@
SUMMARY = "PROJ.4 - Cartographic Projections library"
HOMEPAGE = "http://trac.osgeo.org/proj/"
SECTION = "libs"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://COPYING;md5=74d9aaec5fa0cd734341e8c4dc91b608"
SRC_URI = "http://download.osgeo.org/proj/proj-${PV}.tar.gz"
SRC_URI[md5sum] = "d815838c92a29179298c126effbb1537"
SRC_URI[sha256sum] = "2db2dbf0fece8d9880679154e0d6d1ce7c694dd8e08b4d091028093d87a9d1b5"
inherit autotools pkgconfig lib_package
FILES_${PN} += "${datadir}/proj"