generic-poky/meta/packages/gcc/gcc-4.5.0/zecke-xgcc-cpp.patch

29 lines
1.3 KiB
Diff

upstream: n/a
comment: Use the preprocessor we have just compiled instead the one of
the system. There might be incompabilities between us and them.
Index: gcc-4.5.0/Makefile.in
===================================================================
--- gcc-4.5.0.orig/Makefile.in 2010-02-17 03:01:44.000000000 -0800
+++ gcc-4.5.0/Makefile.in 2010-06-25 11:22:08.421381364 -0700
@@ -266,6 +266,7 @@
AR="$(AR_FOR_TARGET)"; export AR; \
AS="$(COMPILER_AS_FOR_TARGET)"; export AS; \
CC="$(CC_FOR_TARGET) $(XGCC_FLAGS_FOR_TARGET) $$TFLAGS"; export CC; \
+ CPP="$(CC_FOR_TARGET) -E"; export CPP; \
CFLAGS="$(CFLAGS_FOR_TARGET)"; export CFLAGS; \
CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \
CPPFLAGS="$(CPPFLAGS_FOR_TARGET)"; export CPPFLAGS; \
Index: gcc-4.5.0/Makefile.tpl
===================================================================
--- gcc-4.5.0.orig/Makefile.tpl 2010-02-17 03:01:44.000000000 -0800
+++ gcc-4.5.0/Makefile.tpl 2010-06-25 11:22:16.945631990 -0700
@@ -269,6 +269,7 @@
AR="$(AR_FOR_TARGET)"; export AR; \
AS="$(COMPILER_AS_FOR_TARGET)"; export AS; \
CC="$(CC_FOR_TARGET) $(XGCC_FLAGS_FOR_TARGET) $$TFLAGS"; export CC; \
+ CPP="$(CC_FOR_TARGET) -E"; export CPP; \
CFLAGS="$(CFLAGS_FOR_TARGET)"; export CFLAGS; \
CONFIG_SHELL="$(SHELL)"; export CONFIG_SHELL; \
CPPFLAGS="$(CPPFLAGS_FOR_TARGET)"; export CPPFLAGS; \