generic-poky/meta/packages/gdb/gdb/no-werror.patch

79 lines
2.5 KiB
Diff

---
bfd/warning.m4 | 2 +-
configure.ac | 2 +-
gdb/Makefile.in | 4 ++--
gdb/configure.ac | 8 ++------
4 files changed, 6 insertions(+), 10 deletions(-)
Index: gdb-7.1/bfd/warning.m4
===================================================================
--- gdb-7.1.orig/bfd/warning.m4
+++ gdb-7.1/bfd/warning.m4
@@ -23,7 +23,7 @@ esac
# Enable -Werror by default when using gcc
if test "${GCC}" = yes -a -z "${ERROR_ON_WARNING}" ; then
- ERROR_ON_WARNING=yes
+ ERROR_ON_WARNING=no
fi
NO_WERROR=
Index: gdb-7.1/configure.ac
===================================================================
--- gdb-7.1.orig/configure.ac
+++ gdb-7.1/configure.ac
@@ -3371,7 +3371,7 @@ AC_SUBST(stage1_checking)
AC_ARG_ENABLE(werror,
[ --enable-werror enable -Werror in bootstrap stage2 and later], [],
[if test -d ${srcdir}/gcc && test x"`cat $srcdir/gcc/DEV-PHASE`" = xexperimental; then
- enable_werror=yes
+ enable_werror=no
else
enable_werror=no
fi])
Index: gdb-7.1/gdb/Makefile.in
===================================================================
--- gdb-7.1.orig/gdb/Makefile.in
+++ gdb-7.1/gdb/Makefile.in
@@ -151,9 +151,9 @@ READLINE_CFLAGS = @READLINE_CFLAGS@
LIBEXPAT = @LIBEXPAT@
WARN_CFLAGS = @WARN_CFLAGS@
-WERROR_CFLAGS = @WERROR_CFLAGS@
+WERROR_CFLAGS =
GDB_WARN_CFLAGS = $(WARN_CFLAGS)
-GDB_WERROR_CFLAGS = $(WERROR_CFLAGS)
+GDB_WERROR_CFLAGS =
GDB_WARN_CFLAGS_NO_FORMAT = `echo " $(GDB_WARN_CFLAGS) " | sed "s/ -Wformat-nonliteral / /g"`
Index: gdb-7.1/gdb/configure.ac
===================================================================
--- gdb-7.1.orig/gdb/configure.ac
+++ gdb-7.1/gdb/configure.ac
@@ -1525,15 +1525,12 @@ GDB_AC_WITH_DIR(SYSTEM_GDBINIT, system-g
AC_ARG_ENABLE(werror,
AS_HELP_STRING([--enable-werror], [treat compile warnings as errors]),
[case "${enableval}" in
- yes | y) ERROR_ON_WARNING="yes" ;;
+ yes | y) ERROR_ON_WARNING="no" ;;
no | n) ERROR_ON_WARNING="no" ;;
*) AC_MSG_ERROR(bad value ${enableval} for --enable-werror) ;;
esac])
WERROR_CFLAGS=""
-if test "${ERROR_ON_WARNING}" = yes ; then
- WERROR_CFLAGS="-Werror"
-fi
# The entries after -Wno-pointer-sign are disabled warnings which may
# be enabled in the future, which can not currently be used to build
@@ -1587,7 +1584,6 @@ then
# compiled with it enabled.
for w in ${build_warnings}; do
case $w in
- -Werr*) WERROR_CFLAGS=-Werror ;;
*) # Check that GCC accepts it
saved_CFLAGS="$CFLAGS"
CFLAGS="$CFLAGS $w"