generic-poky/meta/packages/openssl/openssl-0.9.8g/shared-libs.patch

46 lines
1.6 KiB
Diff

diff -urN openssl-0.9.8g.orig/crypto/Makefile openssl-0.9.8g/crypto/Makefile
--- openssl-0.9.8g.orig/crypto/Makefile 2006-02-04 02:48:41.000000000 +0100
+++ openssl-0.9.8g/crypto/Makefile 2008-05-12 15:17:03.000000000 +0200
@@ -103,7 +103,7 @@
shared: buildinf.h lib subdirs
if [ -n "$(SHARED_LIBS)" ]; then \
- (cd ..; $(MAKE) $(SHARED_LIB)); \
+ (cd ..; $(MAKE) -e $(SHARED_LIB)); \
fi
libs:
diff -urN openssl-0.9.8g.orig/Makefile.org openssl-0.9.8g/Makefile.org
--- openssl-0.9.8g.orig/Makefile.org 2007-04-24 01:49:54.000000000 +0200
+++ openssl-0.9.8g/Makefile.org 2008-05-12 15:16:34.000000000 +0200
@@ -246,7 +246,7 @@
libcrypto$(SHLIB_EXT): libcrypto.a
@if [ "$(SHLIB_TARGET)" != "" ]; then \
- $(MAKE) SHLIBDIRS=crypto build-shared; \
+ $(MAKE) -e SHLIBDIRS=crypto build-shared; \
else \
echo "There's no support for shared libraries on this platform" >&2; \
exit 1; \
@@ -254,7 +254,7 @@
libssl$(SHLIB_EXT): libcrypto$(SHLIB_EXT) libssl.a
@if [ "$(SHLIB_TARGET)" != "" ]; then \
- $(MAKE) SHLIBDIRS=ssl SHLIBDEPS='-lcrypto' build-shared; \
+ $(MAKE) -e SHLIBDIRS=ssl SHLIBDEPS='-lcrypto' build-shared; \
else \
echo "There's no support for shared libraries on this platform" >&2; \
exit 1; \
diff -urN openssl-0.9.8g.orig/ssl/Makefile openssl-0.9.8g/ssl/Makefile
--- openssl-0.9.8g.orig/ssl/Makefile 2007-10-11 16:36:59.000000000 +0200
+++ openssl-0.9.8g/ssl/Makefile 2008-05-12 15:17:26.000000000 +0200
@@ -62,7 +62,7 @@
shared: lib
if [ -n "$(SHARED_LIBS)" ]; then \
- (cd ..; $(MAKE) $(SHARED_LIB)); \
+ (cd ..; $(MAKE) -e $(SHARED_LIB)); \
fi
files: