Browse Source

Add PEP-0396 compatible __version__ to the module and bump to 0.5

laforge/am_exchange 0.5
Harald Welte 3 years ago
parent
commit
fc2365d3d7
  1. 1
      inema/__init__.py
  2. 2
      inema/inema.py
  3. 3
      setup.py

1
inema/__init__.py

@ -1 +1,2 @@
from .inema import Internetmarke
from .inema import __version__

2
inema/inema.py

@ -11,6 +11,8 @@ import requests, zipfile
import io
import logging
__version__ = "0.5"
_logger = logging.getLogger(__name__)
products_json = resource_stream(__name__, "data/products.json").read().decode()

3
setup.py

@ -1,4 +1,5 @@
from setuptools import find_packages, setup
from inema import __version__
install_requires = [
'zeep >= 0.12.0',
@ -7,7 +8,7 @@ install_requires = [
setup(
name='inema',
version='0.4',
version=__version__,
description='A Python interface to the Deutsche Post Internetmarke Online Franking',
long_description=open('README.rst').read(),
author='Harald Welte',

Loading…
Cancel
Save