linux/debian/patches-rt/0225-panic-skip-get_random_...

38 lines
1.1 KiB
Diff

From 340f4b392711cbe438ad5706cd90ba5263fcd0db Mon Sep 17 00:00:00 2001
Message-Id: <340f4b392711cbe438ad5706cd90ba5263fcd0db.1601675152.git.zanussi@kernel.org>
In-Reply-To: <5b5a156f9808b1acf1205606e03da117214549ea.1601675151.git.zanussi@kernel.org>
References: <5b5a156f9808b1acf1205606e03da117214549ea.1601675151.git.zanussi@kernel.org>
From: Thomas Gleixner <tglx@linutronix.de>
Date: Tue, 14 Jul 2015 14:26:34 +0200
Subject: [PATCH 225/333] panic: skip get_random_bytes for RT_FULL in
init_oops_id
Origin: https://www.kernel.org/pub/linux/kernel/projects/rt/4.19/older/patches-4.19.148-rt64.tar.xz
Disable on -RT. If this is invoked from irq-context we will have problems
to acquire the sleeping lock.
Signed-off-by: Thomas Gleixner <tglx@linutronix.de>
---
kernel/panic.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/kernel/panic.c b/kernel/panic.c
index 8138a676fb7d..fa114be5c30f 100644
--- a/kernel/panic.c
+++ b/kernel/panic.c
@@ -480,9 +480,11 @@ static u64 oops_id;
static int init_oops_id(void)
{
+#ifndef CONFIG_PREEMPT_RT_FULL
if (!oops_id)
get_random_bytes(&oops_id, sizeof(oops_id));
else
+#endif
oops_id++;
return 0;
--
2.17.1