iwlwifi: Do not request unreleased firmware for IWL6000 (Closes: #689416)

svn path=/dists/sid/linux/; revision=19420
This commit is contained in:
Ben Hutchings 2012-10-08 13:58:15 +00:00
parent b0f9128000
commit fe2bf16875
3 changed files with 27 additions and 0 deletions

1
debian/changelog vendored
View File

@ -4,6 +4,7 @@ linux (3.2.30-2) UNRELEASED; urgency=low
* [mips,mipsel] Ignore NFS/SunRPC ABI changes in 3.2.30 (fixes FTBFS)
* tg3: Fix TSO CAP for 5704 devs w / ASF enabled
* SUNRPC: Set alloc_slot for backchannel tcp ops (regression in 3.2.30)
* iwlwifi: Do not request unreleased firmware for IWL6000 (Closes: #689416)
-- Ben Hutchings <ben@decadent.org.uk> Sat, 29 Sep 2012 14:19:46 +0200

View File

@ -0,0 +1,25 @@
From: Ben Hutchings <ben@decadent.org.uk>
Subject: iwlwifi: Do not request unreleased firmware for IWL6000
Bug-Debian: http://bugs.debian.org/689416
The iwlwifi driver currently supports firmware API versions 4-6 for
these devices. It will request the file for the latest supported
version and then fall back to earlier versions. However, the latest
version that has actually been released is 4, so we expect the
requests for versions 6 and then 5 to fail.
The installer appears to report any failed request, and it is probably
not easy to detect that this particular failure is harmless. So stop
requesting the unreleased firmware.
--- a/drivers/net/wireless/iwlwifi/iwl-6000.c
+++ b/drivers/net/wireless/iwlwifi/iwl-6000.c
@@ -46,7 +46,7 @@
#include "iwl-cfg.h"
/* Highest firmware API version supported */
-#define IWL6000_UCODE_API_MAX 6
+#define IWL6000_UCODE_API_MAX 4 /* v5-6 are supported but not released */
#define IWL6050_UCODE_API_MAX 5
#define IWL6000G2_UCODE_API_MAX 6
#define IWL6035_UCODE_API_MAX 6

View File

@ -400,3 +400,4 @@ bugfix/all/speakup-lower-default-software-speech-rate.patch
debian/perf-hide-abi-change-in-3.2.30.patch
bugfix/all/tg3-Fix-TSO-CAP-for-5704-devs-w-ASF-enabled.patch
bugfix/all/SUNRPC-Set-alloc_slot-for-backchannel-tcp-ops.patch
debian/iwlwifi-do-not-request-unreleased-firmware.patch