[alpha] add io{read,write}{16,32}be functions, thanks to Michael Cree

svn path=/dists/trunk/linux-2.6/; revision=18517
This commit is contained in:
Ben Hutchings 2012-01-13 03:01:43 +00:00
parent ad450cd218
commit fd9c780956
3 changed files with 44 additions and 0 deletions

1
debian/changelog vendored
View File

@ -17,6 +17,7 @@ linux-2.6 (3.2.1-1~experimental.1) UNRELEASED; urgency=low
(Closes: #654800)
* [um,m68k] Register a generic CPU device (fixes regression introduced by
the fix for #649216)
* [alpha] add io{read,write}{16,32}be functions, thanks to Michael Cree
[ Bastian Blank ]
* [amd64] crypt: Enable some amd64 only ciphers.

View File

@ -0,0 +1,42 @@
From: Michael Cree <mcree@orcon.net.nz>
To: linux-alpha@vger.kernel.org
Cc: Michael Cree <mcree@orcon.net.nz>, linux-kernel@vger.kernel.org, Matt
Turner <mattst88@gmail.com>, Richard Henderson <rth@twiddle.net>, Ivan
Kokshaysky <ink@jurassic.park.msu.ru>, 649468@bugs.debian.org, Ben
Hutchings <ben@decadent.org.uk>
Subject: [PATCH] alpha: add io{read,write}{16,32}be functions
Date: Wed, 30 Nov 2011 21:01:40 +1300
Message-Id: <1322640100-14534-1-git-send-email-mcree@orcon.net.nz>
These functions are used in some PCI drivers with big-endian
MMIO space.
Admittedly it is almost certain that no one this side of the
Moon would use such a card in an Alpha but it does get us
closer to being able to build allyesconfig or allmodconfig,
and it enables the Debian default generic config to build.
Signed-off-by: Michael Cree <mcree@orcon.net.nz>
---
arch/alpha/include/asm/io.h | 5 +++++
1 files changed, 5 insertions(+), 0 deletions(-)
diff --git a/arch/alpha/include/asm/io.h b/arch/alpha/include/asm/io.h
index 56ff965..6365ef2 100644
--- a/arch/alpha/include/asm/io.h
+++ b/arch/alpha/include/asm/io.h
@@ -490,6 +490,11 @@ extern inline void writeq(u64 b, volatile void __iomem *addr)
}
#endif
+#define ioread16be(p) be16_to_cpu(ioread16(p))
+#define ioread32be(p) be32_to_cpu(ioread32(p))
+#define iowrite16be(v,p) iowrite16(cpu_to_be16(v), (p))
+#define iowrite32be(v,p) iowrite32(cpu_to_be32(v), (p))
+
#define inb_p inb
#define inw_p inw
#define inl_p inl
--
1.7.4.3

View File

@ -61,3 +61,4 @@
+ debian/ARM-Remove-use-of-possibly-undefined-BUILD_BUG_ON-in.patch
+ bugfix/arm/ARM-ixp4xx-gpiolib-support.patch
+ bugfix/arm/ARM-topdown-mmap.patch
+ bugfix/alpha/alpha-add-io-read-write-16-32-be-functions.patch