Merge /dists/sid/linux-2.6.

svn path=/dists/trunk/linux-2.6/; revision=15275
This commit is contained in:
Bastian Blank 2010-02-25 11:00:39 +00:00
commit f9ec680974
9 changed files with 332 additions and 10 deletions

35
debian/changelog vendored
View File

@ -44,7 +44,7 @@ linux-2.6 (2.6.33-1~experimental.1) UNRELEASED; urgency=low
-- maximilian attems <maks@debian.org> Mon, 15 Feb 2010 23:54:52 +0200
linux-2.6 (2.6.32-9) UNRELEASED; urgency=low
linux-2.6 (2.6.32-9) unstable; urgency=high
[ Ben Hutchings ]
* Do not build obsolete lgs8gl5 driver
@ -52,6 +52,11 @@ linux-2.6 (2.6.32-9) UNRELEASED; urgency=low
* Ignore failure of lsusb when gathering information for bug reports
(Closes: #569725)
* macvlan: Add bridge, VEPA and private modes (Closes: #568756)
* [sparc] sunxvr500: Support Intergraph graphics chips again
(Closes: #508108)
* sfc: Apply fixes from 2.6.33
* ath9k: Add support for AR2427
* fs/exec.c: fix initial stack reservation (regression in 2.6.32.9)
[ maximilian attems]
* Postinst don't refercence k-p related manpage. (closes: #542208)
@ -60,11 +65,37 @@ linux-2.6 (2.6.32-9) UNRELEASED; urgency=low
* hwmon: Add driver for VIA CPU core temperature.
* wireless: report reasonable bitrate for MCS rates through wext.
* efifb: fix framebuffer handoff. (bugzilla.k.o #15151)
* Add stable 2.6.32.9:
- drm/i915: Fix DDC on some systems by clearing BIOS GMBUS setup.
(closes: #567747)
- futex: Handle futex value corruption gracefully. (CVE-2010-0623)
- futex_lock_pi() key refcnt fix. (CVE-2010-0623)
- Staging: fix rtl8187se compilation errors with mac80211.
(closes: #566726)
* r8169 patch for rx length check errors. (CVE-2009-4537)
* vgaarb: fix incorrect dereference of userspace pointer.
* Bump ABI to 3.
* drm/i915: give up on 8xx lid status.
* vgaarb: fix "target=default" passing.
* drm/radeon: block ability for userspace app to trash 0 page and beyond.
(closes: #550562)
[ Bastian Blank ]
* Restrict access to sensitive SysRq keys by default.
* debian/rules.real: Install arch specific scripts.
-- Ben Hutchings <ben@decadent.org.uk> Fri, 12 Feb 2010 02:59:33 +0000
[ Moritz Muehlenhoff ]
* Set source format to 1.0
[ Martin Michlmayr ]
* [armel/iop32x] Enable ARCH_IQ80321 and ARCH_IQ31244 (Thanks Arnaud
Patard).
* [armel/kirkwood] Disable MTD_NAND_VERIFY_WRITE to avoid errors
with ubifs on OpenRD (Thanks Gert Doering) (Closes: #570407)
* OpenRD-Base: allow SD/UART1 selection (Closes: #571019)
* D-Link DNS-323 revision A1: implement power LED (Closes: 503172).
-- maximilian attems <maks@debian.org> Wed, 24 Feb 2010 17:06:27 +0100
linux-2.6 (2.6.32-8) unstable; urgency=high

View File

@ -44,8 +44,8 @@ CONFIG_FPE_NWFPE=y
## file: arch/arm/mach-iop32x/Kconfig
##
CONFIG_MACH_GLANTANK=y
# CONFIG_ARCH_IQ80321 is not set
# CONFIG_ARCH_IQ31244 is not set
CONFIG_ARCH_IQ80321=y
CONFIG_ARCH_IQ31244=y
CONFIG_MACH_N2100=y
CONFIG_MACH_EM7210=y

View File

@ -402,7 +402,7 @@ CONFIG_MTD_PHYSMAP_BANKWIDTH=0
## file: drivers/mtd/nand/Kconfig
##
CONFIG_MTD_NAND=y
CONFIG_MTD_NAND_VERIFY_WRITE=y
# CONFIG_MTD_NAND_VERIFY_WRITE is not set
# CONFIG_MTD_NAND_ECC_SMC is not set
# CONFIG_MTD_NAND_MUSEUM_IDS is not set
# CONFIG_MTD_NAND_DISKONCHIP is not set

View File

@ -0,0 +1,100 @@
From 5ffaf8a361b4c9025963959a744f21d8173c7669 Mon Sep 17 00:00:00 2001
From: Luis R. Rodriguez <lrodriguez@atheros.com>
Date: Tue, 2 Feb 2010 11:58:33 -0500
Subject: [PATCH] ath9k: add support for 802.11n bonded out AR2427
Some single chip family devices are sold in the market with
802.11n bonded out, these have no hardware capability for
802.11n but ath9k can still support them. These are called
AR2427.
Cc: stable@kernel.org
[bwh: backported to 2.6.32]
Reported-by: Rolf Leggewie <bugzilla.kernel.org@rolf.leggewie.biz>
Tested-by: Bernhard Reiter <ockham@raz.or.at>
Signed-off-by: Luis R. Rodriguez <lrodriguez@atheros.com>
Signed-off-by: John W. Linville <linville@tuxdriver.com>
---
drivers/net/wireless/ath/ath9k/hw.c | 7 ++++++-
drivers/net/wireless/ath/ath9k/hw.h | 1 +
drivers/net/wireless/ath/ath9k/init.c | 4 +++-
drivers/net/wireless/ath/ath9k/pci.c | 1 +
4 files changed, 11 insertions(+), 2 deletions(-)
diff --git a/drivers/net/wireless/ath/ath9k/hw.c b/drivers/net/wireless/ath/ath9k/hw.c
index 0b1dd10..0b1b88f 100644
--- a/drivers/net/wireless/ath/ath9k/hw.c
+++ b/drivers/net/wireless/ath/ath9k/hw.c
@@ -398,7 +398,6 @@ static void ath9k_hw_init_config(struct ath_hw *ah)
ah->config.pcie_clock_req = 0;
ah->config.pcie_waen = 0;
ah->config.analog_shiftreg = 1;
- ah->config.ht_enable = 1;
ah->config.ofdm_trig_low = 200;
ah->config.ofdm_trig_high = 500;
ah->config.cck_trig_high = 200;
@@ -412,6 +411,11 @@ static void ath9k_hw_init_config(struct ath_hw *ah)
ah->config.spurchans[i][1] = AR_NO_SPUR;
}
+ if (ah->hw_version.devid != AR2427_DEVID_PCIE)
+ ah->config.ht_enable = 1;
+ else
+ ah->config.ht_enable = 0;
+
ah->config.intr_mitigation = true;
/*
@@ -618,5 +622,6 @@ static bool ath9k_hw_devid_supported(u16 devid)
case AR5416_DEVID_AR9287_PCI:
case AR5416_DEVID_AR9287_PCIE:
+ case AR2427_DEVID_PCIE:
return true;
default:
break;
diff --git a/drivers/net/wireless/ath/ath9k/hw.h b/drivers/net/wireless/ath/ath9k/hw.h
index ab1f198..dbbf7ca 100644
--- a/drivers/net/wireless/ath/ath9k/hw.h
+++ b/drivers/net/wireless/ath/ath9k/hw.h
@@ -37,6 +37,7 @@
#define AR9280_DEVID_PCI 0x0029
#define AR9280_DEVID_PCIE 0x002a
#define AR9285_DEVID_PCIE 0x002b
+#define AR2427_DEVID_PCIE 0x002c
#define AR5416_AR9100_DEVID 0x000b
#define AR_SUBVENDOR_ID_NOG 0x0e11
#define AR_SUBVENDOR_ID_NEW_A 0x7065
diff --git a/drivers/net/wireless/ath/ath9k/init.c b/drivers/net/wireless/ath/ath9k/init.c
index c3066b5..4b5e548 100644
--- a/drivers/net/wireless/ath/ath9k/main.c
+++ b/drivers/net/wireless/ath/ath9k/main.c
@@ -1541,11 +1541,13 @@ void ath9k_set_hw_capab(struct ath_softc *sc, struct ieee80211_hw *hw)
hw->flags = IEEE80211_HW_RX_INCLUDES_FCS |
IEEE80211_HW_HOST_BROADCAST_PS_BUFFERING |
IEEE80211_HW_SIGNAL_DBM |
- IEEE80211_HW_AMPDU_AGGREGATION |
IEEE80211_HW_SUPPORTS_PS |
IEEE80211_HW_PS_NULLFUNC_STACK |
IEEE80211_HW_SPECTRUM_MGMT;
+ if (sc->sc_ah->caps.hw_caps & ATH9K_HW_CAP_HT)
+ hw->flags |= IEEE80211_HW_AMPDU_AGGREGATION;
+
if (AR_SREV_9160_10_OR_LATER(sc->sc_ah) || modparam_nohwcrypt)
hw->flags |= IEEE80211_HW_MFP_CAPABLE;
diff --git a/drivers/net/wireless/ath/ath9k/pci.c b/drivers/net/wireless/ath/ath9k/pci.c
index f2afcbe..f318b3b 100644
--- a/drivers/net/wireless/ath/ath9k/pci.c
+++ b/drivers/net/wireless/ath/ath9k/pci.c
@@ -25,6 +25,7 @@ static struct pci_device_id ath_pci_id_table[] __devinitdata = {
{ PCI_VDEVICE(ATHEROS, 0x0029) }, /* PCI */
{ PCI_VDEVICE(ATHEROS, 0x002A) }, /* PCI-E */
{ PCI_VDEVICE(ATHEROS, 0x002B) }, /* PCI-E */
+ { PCI_VDEVICE(ATHEROS, 0x002C) }, /* PCI-E 802.11n bonded out */
{ PCI_VDEVICE(ATHEROS, 0x002D) }, /* PCI */
{ PCI_VDEVICE(ATHEROS, 0x002E) }, /* PCI-E */
{ 0 }
--
1.6.6.2

View File

@ -0,0 +1,94 @@
From: Laurie Bradshaw <bradshaw.laurie@googlemail.com>
Date: Wed, 10 Feb 2010 16:10:43 +0000 (+0000)
Subject: [ARM] orion5x: D-link DNS-323 revision A1 power LED
X-Git-Url: http://git.marvell.com/?p=orion.git;a=commitdiff_plain;h=b2a731aa5cbca7e0252da75e16de7ae5feb1313a
[ARM] orion5x: D-link DNS-323 revision A1 power LED
This patch fixes the power LED on DNS-323 revision A1, and adds timer
support for (hopefully) both A1 and B1 revisions.
Power LED on revision A1 is active low and also requires GPIO 4 to be
low to work.
Tested on my DNS-323 revision A1.
I have set the default trigger to timer as that replicates the
behaviour of the original firmware, userspace can change the trigger
at the end of the boot process providing a useful indication that
booting has completed.
Signed-off-by: Nicolas Pitre <nico@marvell.com>
---
diff --git a/arch/arm/mach-orion5x/dns323-setup.c b/arch/arm/mach-orion5x/dns323-setup.c
index 8f159db..421b82f 100644
--- a/arch/arm/mach-orion5x/dns323-setup.c
+++ b/arch/arm/mach-orion5x/dns323-setup.c
@@ -34,7 +34,8 @@
#define DNS323_GPIO_LED_RIGHT_AMBER 1
#define DNS323_GPIO_LED_LEFT_AMBER 2
#define DNS323_GPIO_SYSTEM_UP 3
-#define DNS323_GPIO_LED_POWER 5
+#define DNS323_GPIO_LED_POWER1 4
+#define DNS323_GPIO_LED_POWER2 5
#define DNS323_GPIO_OVERTEMP 6
#define DNS323_GPIO_RTC 7
#define DNS323_GPIO_POWER_OFF 8
@@ -237,11 +238,31 @@ error_fail:
* GPIO LEDs (simple - doesn't use hardware blinking support)
*/
+#define ORION_BLINK_HALF_PERIOD 100 /* ms */
+
+static int dns323_gpio_blink_set(unsigned gpio,
+ unsigned long *delay_on, unsigned long *delay_off)
+{
+ static int value = 0;
+
+ if (!*delay_on && !*delay_off)
+ *delay_on = *delay_off = ORION_BLINK_HALF_PERIOD;
+
+ if (ORION_BLINK_HALF_PERIOD == *delay_on
+ && ORION_BLINK_HALF_PERIOD == *delay_off) {
+ value = !value;
+ orion_gpio_set_blink(gpio, value);
+ return 0;
+ }
+
+ return -EINVAL;
+}
+
static struct gpio_led dns323_leds[] = {
{
.name = "power:blue",
- .gpio = DNS323_GPIO_LED_POWER,
- .default_state = LEDS_GPIO_DEFSTATE_ON,
+ .gpio = DNS323_GPIO_LED_POWER2,
+ .default_trigger = "default-on",
}, {
.name = "right:amber",
.gpio = DNS323_GPIO_LED_RIGHT_AMBER,
@@ -256,6 +277,7 @@ static struct gpio_led dns323_leds[] = {
static struct gpio_led_platform_data dns323_led_data = {
.num_leds = ARRAY_SIZE(dns323_leds),
.leds = dns323_leds,
+ .gpio_blink_set = dns323_gpio_blink_set,
};
static struct platform_device dns323_gpio_leds = {
@@ -412,6 +434,14 @@ static void __init dns323_init(void)
orion5x_setup_dev_boot_win(DNS323_NOR_BOOT_BASE, DNS323_NOR_BOOT_SIZE);
platform_device_register(&dns323_nor_flash);
+ /* The 5181 power LED is active low and requires
+ * DNS323_GPIO_LED_POWER1 to also be low.
+ */
+ if (dns323_dev_id() == MV88F5181_DEV_ID) {
+ dns323_leds[0].active_low = 1;
+ gpio_direction_output(DNS323_GPIO_LED_POWER1, 0);
+ }
+
platform_device_register(&dns323_gpio_leds);
platform_device_register(&dns323_button_device);

View File

@ -0,0 +1,95 @@
From: Tanmay Upadhyay <tanmay.upadhyay@einfochips.com>
Date: Wed, 3 Feb 2010 11:56:21 +0530
Subject: [PATCH] ARM: Kirkwood: OpenRD: SD/UART1 selection
To select UART1, pass "uart=232" in the boot argument. Else SDIO lines will be
selected.
Signed-off-by: Tanmay Upadhyay <tanmay.upadhyay@einfochips.com>
---
arch/arm/mach-kirkwood/openrd_base-setup.c | 49 +++++++++++++++++++++++++++-
1 files changed, 48 insertions(+), 1 deletions(-)
--- a/arch/arm/mach-kirkwood/openrd_base-setup.c 2009-12-03 03:51:21.000000000 +0000
+++ b/arch/arm/mach-kirkwood/openrd_base-setup.c 2010-02-22 21:07:11.000000000 +0000
@@ -14,6 +14,8 @@
#include <linux/mtd/partitions.h>
#include <linux/ata_platform.h>
#include <linux/mv643xx_eth.h>
+#include <linux/io.h>
+#include <linux/gpio.h>
#include <asm/mach-types.h>
#include <asm/mach/arch.h>
#include <mach/kirkwood.h>
@@ -50,16 +52,48 @@
};
static unsigned int openrd_base_mpp_config[] __initdata = {
+ MPP12_SD_CLK,
+ MPP13_SD_CMD,
+ MPP14_SD_D0,
+ MPP15_SD_D1,
+ MPP16_SD_D2,
+ MPP17_SD_D3,
+ MPP29_GPIO,
MPP29_GPIO,
0
};
+static int uart1;
+
+static void sd_uart_selection(void)
+{
+ char *ptr = NULL;
+
+ /* Parse boot_command_line string uart=no/232 */
+ ptr = strstr(boot_command_line, "uart=");
+
+ /* Default is SD. Change if required, for UART */
+ if (ptr != NULL) {
+ if (!strncmp(ptr + 5, "232", 3)) {
+ /* Configure MPP for UART */
+ openrd_base_mpp_config[1] = MPP13_UART1_TXD;
+ openrd_base_mpp_config[2] = MPP14_UART1_RXD;
+
+ uart1 = 232;
+ }
+ }
+}
+
static void __init openrd_base_init(void)
{
/*
* Basic setup. Needs to be called early.
*/
kirkwood_init();
+
+ /* This function modifies MPP config according to boot argument */
+ sd_uart_selection();
+
kirkwood_mpp_conf(openrd_base_mpp_config);
kirkwood_uart0_init();
@@ -69,7 +103,20 @@
kirkwood_ge00_init(&openrd_base_ge00_data);
kirkwood_sata_init(&openrd_base_sata_data);
- kirkwood_sdio_init(&openrd_base_mvsdio_data);
+
+ if (!uart1) {
+ /* Select SD
+ * Pin # 34: 0 => UART1, 1 => SD */
+ writel(readl(GPIO_OUT(34)) | 4, GPIO_OUT(34));
+
+ kirkwood_sdio_init(&openrd_base_mvsdio_data);
+ } else {
+ /* Select UART1
+ * Pin # 34: 0 => UART1, 1 => SD */
+ writel(readl(GPIO_OUT(34)) & ~(4), GPIO_OUT(34));
+
+ kirkwood_uart1_init();
+ }
kirkwood_i2c_init();
}

View File

@ -50,3 +50,7 @@
+ bugfix/x86/kvm-Check-CPL-level-during-privilege-instruction-emulation.patch
+ debian/sysrq-mask.patch
+ features/arm/dns323-rev-a1-powerled.patch
+ features/arm/openrd-base-uart.patch
#+ features/all/ath9k-add-support-for-802.11n-bonded-out-AR2427.patch

6
debian/rules.real vendored
View File

@ -200,7 +200,7 @@ install-headers_$(ARCH)_$(FEATURESET): $(STAMPS_DIR)/source_$(ARCH)_$(FEATURESET
echo Makefile; \
find arch/$(KERNEL_ARCH) -maxdepth 1 -name 'Makefile*' -print; \
find arch/$(KERNEL_ARCH) -name 'module.lds' -print; \
find $$(find arch/$(KERNEL_ARCH) -name include -type d -print) -print; \
find $$(find arch/$(KERNEL_ARCH) \( -name include -o -name scripts \) -type d -print) -print; \
find include -name 'asm*' -prune -o -print; \
find include/asm-generic -print; \
) \
@ -208,10 +208,6 @@ install-headers_$(ARCH)_$(FEATURESET): $(STAMPS_DIR)/source_$(ARCH)_$(FEATURESET
cpio -pd --preserve-modification-time '$(CURDIR)/$(DIR)'
ln -s /usr/lib/$(PACKAGE_NAME_KBUILD)/{Kbuild,scripts} $(DIR)
if [ -d $(SOURCE_DIR)/arch/$(KERNEL_ARCH)/scripts ]; then \
ln -s /usr/lib/$(PACKAGE_NAME_KBUILD)/arch/$(KERNEL_ARCH)/scripts \
$(DIR)/arch/$(KERNEL_ARCH); \
fi
+$(MAKE_SELF) install-base

2
debian/source/format vendored Normal file
View File

@ -0,0 +1,2 @@
1.0