Update to 3.2.38

svn path=/dists/sid/linux/; revision=19788
This commit is contained in:
Ben Hutchings 2013-02-06 05:33:01 +00:00
parent 500933e7a9
commit f9a611b41e
5 changed files with 227 additions and 258 deletions

31
debian/changelog vendored
View File

@ -1,4 +1,4 @@
linux (3.2.37-1) UNRELEASED; urgency=low
linux (3.2.38-1) UNRELEASED; urgency=low
* New upstream stable update:
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.2.36
@ -43,6 +43,31 @@ linux (3.2.37-1) UNRELEASED; urgency=low
- tcp: RFC 5961 5.2 Blind Data Injection Attack Mitigation
- RDMA/nes: Fix for crash when registering zero length MR for CQ
- ACPI : do not use Lid and Sleep button for S5 wakeup
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.2.38
- staging: comedi: comedi_test: fix race when cancelling command
- mm: use aligned zone start for pfn_to_bitidx calculation
- [s390] s390/time: fix sched_clock() overflow (Closes: #698382)
- [i386] xen: Fix stack corruption in xen_failsafe_callback for 32bit
PVOPS guests. (CVE-2013-0190)
- KVM: PPC: Emulate dcbf
- evm: checking if removexattr is not a NULL
- ath9k_htc: Fix memory leak
- ath9k: do not link receive buffers during flush
- ath9k: fix double-free bug on beacon generate failure
- x86/msr: Add capabilities check
- can: c_can: fix invalid error codes
- can: ti_hecc: fix invalid error codes
- can: pch_can: fix invalid error codes
- smp: Fix SMP function call empty cpu mask race
- xfs: Fix possible use-after-free with AIO
- EDAC: Test correct variable in ->store function
- samsung-laptop: Disable on EFI hardware, to avoid damaging it
- NFS: Don't silently fail setattr() requests on mountpoints
- intel-iommu: Prevent devices with RMRRs from being placed into SI Domain
- ALSA: usb-audio: Fix regression by disconnection-race-fix patch
(Closes: #696321)
- printk: fix buffer overflow when calling log_prefix function from
call_console_drivers
[ Ben Hutchings ]
* Input: wacom - fix touch support for Bamboo Fun CTH-461
@ -79,18 +104,14 @@ linux (3.2.37-1) UNRELEASED; urgency=low
hid-quanta, hid-samsung, hid-speedlink
* radeon: Firmware is required for DRM and KMS on R600 onward, but not
for KMS on earlier chips (Closes: #697229)
* vt6656: Fix inconsistent structure packing which leads to crash on amd64
* [!powerpc] radeon: Reenable DRM_RADEON_KMS, as it apparently works on
most non-PowerMac systems
* fs: cachefiles: add support for large files in filesystem caching
(Closes: #698376)
* [i386] xen: Fix stack corruption in xen_failsafe_callback for 32bit PVOPS
guests. (CVE-2013-0190)
* [rt] Update to 3.2.37-rt55:
- sched: Adjust sched_reset_on_fork when nothing else changes
- sched: Queue RT tasks to head when prio drops
- sched: Consider pi boosting in setscheduler
* [s390] s390/time: fix sched_clock() overflow (Closes: #698382)
* bridge: Pull ip header into skb->data before looking into ip header.
(Closes: #697903)
* [armel/versatile,armhf/vexpress] i2c: Enable I2C, I2C_VERSATILE as modules

View File

@ -12,17 +12,16 @@ on the UVC interface information.
Signed-off-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Acked-by: Alan Stern <stern@rowland.harvard.edu>
Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
[bwh: Adjust context to apply after 3.2.38]
---
drivers/usb/core/quirks.c | 58 +++++++++++++--------------------------------
1 file changed, 16 insertions(+), 42 deletions(-)
diff --git a/drivers/usb/core/quirks.c b/drivers/usb/core/quirks.c
index cbd15d1..f15501f4c 100644
--- a/drivers/usb/core/quirks.c
+++ b/drivers/usb/core/quirks.c
@@ -43,53 +43,23 @@ static const struct usb_device_id usb_quirk_list[] = {
/* Creative SB Audigy 2 NX */
{ USB_DEVICE(0x041e, 0x3020), .driver_info = USB_QUIRK_RESET_RESUME },
@@ -46,53 +46,23 @@ static const struct usb_device_id usb_qu
/* Microsoft LifeCam-VX700 v2.0 */
{ USB_DEVICE(0x045e, 0x0770), .driver_info = USB_QUIRK_RESET_RESUME },
- /* Logitech Webcam C200 */
- { USB_DEVICE(0x046d, 0x0802), .driver_info = USB_QUIRK_RESET_RESUME },
@ -86,7 +85,7 @@ index cbd15d1..f15501f4c 100644
/* Logitech Harmony 700-series */
{ USB_DEVICE(0x046d, 0xc122), .driver_info = USB_QUIRK_DELAY_INIT },
@@ -162,6 +132,10 @@ static const struct usb_device_id usb_quirk_list[] = {
@@ -169,6 +139,10 @@ static const struct usb_device_id usb_qu
};
static const struct usb_device_id usb_interface_quirk_list[] = {

File diff suppressed because it is too large Load Diff

View File

@ -11,13 +11,13 @@ Cc: Matthew Garrett <mjg@redhat.com>
Signed-off-by: Matt Fleming <matt.fleming@intel.com>
Link: http://lkml.kernel.org/r/1318848017-12301-1-git-send-email-matt@console-pimps.org
Signed-off-by: H. Peter Anvin <hpa@linux.intel.com>
[bwh: Drop the hunk in arch/x86/kernel/setup.c which is unnecessary and
conflicts with a fix in 3.2.38]
---
arch/x86/include/asm/efi.h | 4 ++++
arch/x86/kernel/setup.c | 7 +------
2 files changed, 5 insertions(+), 6 deletions(-)
diff --git a/arch/x86/include/asm/efi.h b/arch/x86/include/asm/efi.h
index b8d8bfc..26d8c18 100644
--- a/arch/x86/include/asm/efi.h
+++ b/arch/x86/include/asm/efi.h
@@ -3,6 +3,8 @@
@ -29,7 +29,7 @@ index b8d8bfc..26d8c18 100644
extern unsigned long asmlinkage efi_call_phys(void *, ...);
#define efi_call_phys0(f) efi_call_phys(f)
@@ -35,6 +37,8 @@ extern unsigned long asmlinkage efi_call_phys(void *, ...);
@@ -37,6 +39,8 @@ extern unsigned long asmlinkage efi_call
#else /* !CONFIG_X86_32 */
@ -38,24 +38,3 @@ index b8d8bfc..26d8c18 100644
extern u64 efi_call0(void *fp);
extern u64 efi_call1(void *fp, u64 arg1);
extern u64 efi_call2(void *fp, u64 arg1, u64 arg2);
diff --git a/arch/x86/kernel/setup.c b/arch/x86/kernel/setup.c
index 9a9e40f..4d5243c 100644
--- a/arch/x86/kernel/setup.c
+++ b/arch/x86/kernel/setup.c
@@ -752,12 +752,7 @@ void __init setup_arch(char **cmdline_p)
#endif
#ifdef CONFIG_EFI
if (!strncmp((char *)&boot_params.efi_info.efi_loader_signature,
-#ifdef CONFIG_X86_32
- "EL32",
-#else
- "EL64",
-#endif
- 4)) {
+ EFI_LOADER_SIGNATURE, 4)) {
efi_enabled = 1;
efi_memblock_x86_reserve_range();
}
--
1.7.10

View File

@ -448,10 +448,7 @@ features/all/iguanair/0009-media-rc-do-not-wake-up-rc-thread-unless-there-is-so.
features/all/iguanair/0010-media-iguanair-do-not-modify-transmit-buffer.patch
features/all/iguanair/0011-media-iguanair-cannot-send-data-from-the-stack.patch
features/all/rt2800-add-chipset-revision-RT5390R-support.patch
bugfix/all/vt6656-Fix-inconsistent-structure-packing.patch
bugfix/all/fs-cachefiles-add-support-for-large-files-in-filesys.patch
bugfix/x86/xen-Fix-stack-corruption-in-xen_failsafe_callback-fo.patch
bugfix/s390/s390-time-fix-sched_clock-overflow.patch
bugfix/all/bridge-Pull-ip-header-into-skb-data-before-looking-i.patch
bugfix/all/ext4-rewrite-punch-hole-to-use-ext4_ext_remove_space.patch
bugfix/all/ext4-fix-hole-punch-failure-when-depth-is-greater-th.patch