[rt] Refresh 0253-watchdog-prevent-deferral-of-watchdogd-wakeup-on-RT.patch (Context changes in 4.19.93)

This commit is contained in:
Salvatore Bonaccorso 2020-01-08 22:14:27 +01:00
parent be9871ff2f
commit f96fb9cfd5
2 changed files with 8 additions and 10 deletions

3
debian/changelog vendored
View File

@ -948,6 +948,9 @@ linux (4.19.93-1) UNRELEASED; urgency=medium
* [rt] Drop 0245-Revert-arm64-preempt-Fix-big-endian-when-checking-pr.patch
* Refresh 0013-scsi-hisi_sas-Relocate-some-codes-to-avoid-an-unused.patch
for context changes in 4.19.93.
* [rt] Refresh
0253-watchdog-prevent-deferral-of-watchdogd-wakeup-on-RT.patch (Context
changes in 4.19.93)
-- Salvatore Bonaccorso <carnil@debian.org> Sat, 14 Dec 2019 22:00:16 +0100

View File

@ -36,11 +36,9 @@ Signed-off-by: Sebastian Andrzej Siewior <bigeasy@linutronix.de>
drivers/watchdog/watchdog_dev.c | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/watchdog/watchdog_dev.c b/drivers/watchdog/watchdog_dev.c
index f6c24b22b37c..ff19f9503c23 100644
--- a/drivers/watchdog/watchdog_dev.c
+++ b/drivers/watchdog/watchdog_dev.c
@@ -147,7 +147,7 @@ static inline void watchdog_update_worker(struct watchdog_device *wdd)
@@ -146,7 +146,7 @@
ktime_t t = watchdog_next_keepalive(wdd);
if (t > 0)
@ -49,7 +47,7 @@ index f6c24b22b37c..ff19f9503c23 100644
} else {
hrtimer_cancel(&wd_data->timer);
}
@@ -166,7 +166,7 @@ static int __watchdog_ping(struct watchdog_device *wdd)
@@ -165,7 +165,7 @@
if (ktime_after(earliest_keepalive, now)) {
hrtimer_start(&wd_data->timer,
ktime_sub(earliest_keepalive, now),
@ -58,7 +56,7 @@ index f6c24b22b37c..ff19f9503c23 100644
return 0;
}
@@ -945,7 +945,7 @@ static int watchdog_cdev_register(struct watchdog_device *wdd, dev_t devno)
@@ -948,7 +948,7 @@
return -ENODEV;
kthread_init_work(&wd_data->work, watchdog_ping_work);
@ -67,15 +65,12 @@ index f6c24b22b37c..ff19f9503c23 100644
wd_data->timer.function = watchdog_timer_expired;
if (wdd->id == 0) {
@@ -992,7 +992,7 @@ static int watchdog_cdev_register(struct watchdog_device *wdd, dev_t devno)
@@ -1005,7 +1005,7 @@
__module_get(wdd->ops->owner);
kref_get(&wd_data->kref);
get_device(&wd_data->dev);
if (handle_boot_enabled)
- hrtimer_start(&wd_data->timer, 0, HRTIMER_MODE_REL);
+ hrtimer_start(&wd_data->timer, 0, HRTIMER_MODE_REL_HARD);
else
pr_info("watchdog%d running and kernel based pre-userspace handler disabled\n",
wdd->id);
--
2.24.0