backport arm bpf jit support. runtime tested with tcpdump and kirkwood iconnect

kernel

svn path=/dists/sid/linux/; revision=19205
This commit is contained in:
Arnaud Patard 2012-06-25 09:54:07 +00:00
parent f5a7e1900a
commit f853c20597
5 changed files with 1304 additions and 0 deletions

3
debian/changelog vendored
View File

@ -21,6 +21,9 @@ linux (3.2.21-2) UNRELEASED; urgency=low
regressions for other devices (Closes: #677164)
* linux-image, README.Debian: Suggest debian-kernel-handbook package
[ Arnaud Patard ]
* [armel, armhf] backport BPF JIT support
-- Ben Hutchings <ben@decadent.org.uk> Sat, 23 Jun 2012 20:19:15 +0100
linux (3.2.21-1) unstable; urgency=low

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,29 @@
From fada8dcf2d085f4e2eb1ba760c8d37111977dbec Mon Sep 17 00:00:00 2001
From: Russell King <rmk+kernel@arm.linux.org.uk>
Date: Tue, 27 Mar 2012 10:44:23 +0100
Subject: [PATCH] ARM: fix Kconfig warning for HAVE_BPF_JIT
Last night's randconfig and the allnoconfig builds spat out the
following warning while building:
warning: (ARM) selects HAVE_BPF_JIT which has unmet direct dependencies (NET)
Acked-by: Mircea Gherzan <mgherzan@gmail.com>
Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
---
arch/arm/Kconfig | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
Index: linux/arch/arm/Kconfig
===================================================================
--- linux.orig/arch/arm/Kconfig 2012-06-24 23:38:52.000000000 +0200
+++ linux/arch/arm/Kconfig 2012-06-24 23:41:24.000000000 +0200
@@ -30,7 +30,7 @@
select HAVE_SPARSE_IRQ
select GENERIC_IRQ_SHOW
select CPU_PM if (SUSPEND || CPU_IDLE)
- select HAVE_BPF_JIT
+ select HAVE_BPF_JIT if NET
help
The ARM series is a line of low-power-consumption RISC chip designs
licensed by ARM Ltd and targeted at embedded applications and

View File

@ -0,0 +1,86 @@
From e47b65b032f2997aa0a7392ecdf656c86d4d7561 Mon Sep 17 00:00:00 2001
From: Sam Ravnborg <sam@ravnborg.org>
Date: Mon, 21 May 2012 20:45:37 +0200
Subject: [PATCH] net: drop NET dependency from HAVE_BPF_JIT
There is no point having the NET dependency on the select target, as it
forces all users to depend on NET to tell they support BPF_JIT. Move
the config option to the bottom of the file - this could be a nice place
also for future "selectable" config symbols.
Fix up all users to drop the dependency on NET now that it is not
required to supress warnings for non-NET builds.
Reported-by: Linus Torvalds <torvalds@linux-foundation.org>
Signed-off-by: Sam Ravnborg <sam@ravnborg.org>
Acked-by: David Miller <davem@davemloft.net>
Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
---
arch/arm/Kconfig | 2 +-
arch/powerpc/Kconfig | 2 +-
arch/sparc/Kconfig | 2 +-
arch/x86/Kconfig | 2 +-
net/Kconfig | 7 ++++---
5 files changed, 8 insertions(+), 7 deletions(-)
Index: linux/arch/arm/Kconfig
===================================================================
--- linux.orig/arch/arm/Kconfig 2012-06-24 23:41:24.000000000 +0200
+++ linux/arch/arm/Kconfig 2012-06-24 23:49:03.000000000 +0200
@@ -30,7 +30,7 @@
select HAVE_SPARSE_IRQ
select GENERIC_IRQ_SHOW
select CPU_PM if (SUSPEND || CPU_IDLE)
- select HAVE_BPF_JIT if NET
+ select HAVE_BPF_JIT
help
The ARM series is a line of low-power-consumption RISC chip designs
licensed by ARM Ltd and targeted at embedded applications and
Index: linux/arch/powerpc/Kconfig
===================================================================
--- linux.orig/arch/powerpc/Kconfig 2012-06-20 00:18:30.000000000 +0200
+++ linux/arch/powerpc/Kconfig 2012-06-24 23:49:03.000000000 +0200
@@ -134,7 +134,7 @@
select GENERIC_IRQ_SHOW_LEVEL
select HAVE_RCU_TABLE_FREE if SMP
select HAVE_SYSCALL_TRACEPOINTS
- select HAVE_BPF_JIT if (PPC64 && NET)
+ select HAVE_BPF_JIT if PPC64
select HAVE_ARCH_JUMP_LABEL
select ARCH_HAVE_NMI_SAFE_CMPXCHG
Index: linux/arch/x86/Kconfig
===================================================================
--- linux.orig/arch/x86/Kconfig 2012-06-23 17:09:51.000000000 +0200
+++ linux/arch/x86/Kconfig 2012-06-24 23:49:03.000000000 +0200
@@ -72,7 +72,7 @@
select GENERIC_CLOCKEVENTS_MIN_ADJUST
select IRQ_FORCED_THREADING
select USE_GENERIC_SMP_HELPERS if SMP
- select HAVE_BPF_JIT if (X86_64 && NET)
+ select HAVE_BPF_JIT if X86_64
select CLKEVT_I8253
select ARCH_HAVE_NMI_SAFE_CMPXCHG
Index: linux/net/Kconfig
===================================================================
--- linux.orig/net/Kconfig 2012-06-20 00:18:30.000000000 +0200
+++ linux/net/Kconfig 2012-06-24 23:49:03.000000000 +0200
@@ -232,9 +232,6 @@
depends on SMP && SYSFS && USE_GENERIC_SMP_HELPERS
default y
-config HAVE_BPF_JIT
- bool
-
config BPF_JIT
bool "enable BPF Just In Time compiler"
depends on HAVE_BPF_JIT
@@ -326,3 +323,7 @@
endif # if NET
+
+# Used by archs to tell that they support BPF_JIT
+config HAVE_BPF_JIT
+ bool

View File

@ -361,3 +361,6 @@ features/arm/kirkwood-add-configuration-for-mpp12-as-gpio.patch
features/arm/kirkwood-add-iconnect-support.patch
features/all/Input-add-Synaptics-USB-device-driver.patch
features/arm/ARM-7259-3-net-JIT-compiler-for-packet-filters.patch
features/arm/ARM-fix-Kconfig-warning-for-HAVE_BPF_JIT.patch
features/arm/net-drop-NET-dependency-from-HAVE_BPF_JIT.patch