Update to 4.8.11

This commit is contained in:
Salvatore Bonaccorso 2016-11-29 14:25:54 +01:00
parent 3536d5d7a6
commit f82ecfdc9e
3 changed files with 65 additions and 39 deletions

66
debian/changelog vendored
View File

@ -1,4 +1,4 @@
linux (4.8.10-1) UNRELEASED; urgency=medium
linux (4.8.11-1) UNRELEASED; urgency=medium
* New upstream stable update:
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.8.8
@ -160,6 +160,70 @@ linux (4.8.10-1) UNRELEASED; urgency=medium
- [sparc64] Delete now unused user copy fixup functions.
- usb: gadget: f_fs: edit epfile->ep under lock
- usb: gadget: f_fs: stop sleeping in ffs_func_eps_disable
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.8.11
- [x86] cpu/AMD: Fix cpu_llc_id for AMD Fam17h systems
- [x86] KVM: fix missed SRCU usage in kvm_lapic_set_vapic_addr
- [x86] KVM: Disable irq while unregistering user notifier
- ftrace: Ignore FTRACE_FL_DISABLED while walking dyn_ftrace records
- ftrace: Add more checks for FTRACE_FL_DISABLED in processing ip records
- genirq: Use irq type from irqdata instead of irqdesc
- fuse: fix fuse_write_end() if zero bytes were copied
- IB/rdmavt: rdmavt can handle non aligned page maps
- IB/hfi1: Fix rnr_timer addition
- [x86] mfd: intel-lpss: Do not put device in reset state on suspend
- [armhf] mfd: stmpe: Fix RESET regression on STMPE2401
- can: bcm: fix warning in bcm_connect/proc_register
- gpio: do not double-check direction on sleeping chips
- [x86] ALSA: usb-audio: Fix use-after-free of usb_device at disconnect
- [x86] ALSA: hda - add a new condition to check if it is thinkpad
- ALSA: hda - Fix mic regression by ASRock mobo fixup
- [armhf] i2c: mux: fix up dependencies
- [armhf] i2c: i2c-mux-pca954x: fix deselect enabling for device-tree
- kbuild: add -fno-PIE
- scripts/has-stack-protector: add -fno-PIE
- x86/kexec: add -fno-PIE
- kbuild: Steal gcc's pie from the very beginning
- ext4: sanity check the block and cluster size at mount time
- [armhf] dts: imx53-qsb: Fix regulator constraints
- crypto: caam - do not register AES-XTS mode on LP units
- [powerpc*] Fix setting of AIL in hypervisor mode
- [x86] drm/amdgpu: Attach exclusive fence to prime exported bo's.
- [x86] drm/i915: Refresh that status of MST capable connectors in
->detect()
- [x86] drm/i915: Assume non-DP++ port if dvo_port is HDMI and there's no
AUX ch specified in the VBT
- virtio-net: drop legacy features in virtio 1 mode
- [armhf] clk: imx: fix integer overflow in AV PLL round rate
- [armhf] rtc: omap: Fix selecting external osc
- iwlwifi: pcie: fix SPLC structure parsing
- iwlwifi: pcie: mark command queue lock with separate lockdep class
- iwlwifi: mvm: fix netdetect starting/stopping for unified images
- iwlwifi: mvm: fix d3_test with unified D0/D3 images
- iwlwifi: mvm: wake the wait queue when the RX sync counter is zero
- mfd: core: Fix device reference leak in mfd_clone_cell
- sunrpc: svc_age_temp_xprts_now should not call setsockopt non-tcp
transports
- uwb: fix device reference leaks
- PM / sleep: fix device reference leak in test_suspend
- PM / sleep: don't suspend parent when async child suspend_{noirq,
late} fails
- perf hists: Fix column length on --hierarchy
- IB/mlx4: Check gid_index return value
- IB/mlx4: Fix create CQ error flow
- IB/mlx5: Validate requested RQT size
- IB/mlx5: Use cache line size to select CQE stride
- IB/mlx5: Fix memory leak in query device
- IB/mlx5: Fix fatal error dispatching
- IB/mlx5: Fix NULL pointer dereference on debug print
- IB/core: Avoid unsigned int overflow in sg_alloc_table
- IB/hfi1: Remove incorrect IS_ERR check
- IB/uverbs: Fix leak of XRC target QPs
- IB/cm: Mark stale CM id's whenever the mad agent was unregistered
- netfilter: nft_dynset: fix element timeout for HZ != 1000
- [arm64, armhf] gpio: pca953x: Move memcpy into mutex lock for set
multiple
- [arm64, armhf] gpio: pca953x: Fix corruption of other gpios in
set_multiple.
[ Salvatore Bonaccorso ]
* Bump ABI to 2 and remove ABI reference for 4.8.0-1

View File

@ -1,37 +0,0 @@
From 5f490bfc33f69f490c6c7a90889287e84f1556c0 Mon Sep 17 00:00:00 2001
From: Sebastian Andrzej Siewior <bigeasy@linutronix.de>
Date: Fri, 21 Oct 2016 12:21:07 +0200
Subject: [PATCH] kbuild: add -fno-PIE
Origin: https://www.kernel.org/pub/linux/kernel/projects/rt/4.8/older/patches-4.8.6-rt5.tar.xz
Debian started to build the gcc with -fPIE by default so the kernel
build ends before it starts properly with:
|kernel/bounds.c:1:0: error: code model kernel does not support PIC mode
Also add to KBUILD_AFLAGSi due to:
|gcc -Wp,-MD,arch/x86/entry/vdso/vdso32/.note.o.d … -mfentry -DCC_USING_FENTRY … vdso/vdso32/note.S
|arch/x86/entry/vdso/vdso32/note.S:1:0: sorry, unimplemented: -mfentry isnt supported for 32-bit in c ombination with -fpic
Signed-off-by: Sebastian Andrzej Siewior <bigeasy@linutronix.de>
---
Makefile | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
--- a/Makefile
+++ b/Makefile
@@ -398,12 +398,12 @@ KBUILD_CPPFLAGS := -D__KERNEL__
KBUILD_CFLAGS := -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs \
-fno-strict-aliasing -fno-common \
-Werror-implicit-function-declaration \
- -Wno-format-security \
+ -Wno-format-security -fno-PIE \
-std=gnu89
KBUILD_AFLAGS_KERNEL :=
KBUILD_CFLAGS_KERNEL :=
-KBUILD_AFLAGS := -D__ASSEMBLY__
+KBUILD_AFLAGS := -D__ASSEMBLY__ -fno-PIE
KBUILD_AFLAGS_MODULE := -DMODULE
KBUILD_CFLAGS_MODULE := -DMODULE
KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds

View File

@ -37,7 +37,6 @@ features/all/rt/iommu-vt-d-don-t-disable-preemption-while-accessing-.patch
features/all/rt/lockdep-Quiet-gcc-about-dangerous-__builtin_return_a.patch
features/all/rt/x86-apic-get-rid-of-warning-acpi_ioapic_lock-defined.patch
features/all/rt/rxrpc-remove-unused-static-variables.patch
features/all/rt/kbuild-add-fno-PIE.patch
# Wants a different fix for upstream
features/all/rt/NFSv4-replace-seqcount_t-with-a-seqlock_t.patch