Update to 4.17.14

This updates the debian changelog for listing changes of this stable
update. It also removes patches that have been applied upstream.
This commit is contained in:
Romain Perier 2018-08-12 19:19:25 +02:00 committed by Bastian Blank
parent f632b75347
commit f813b6ebf5
4 changed files with 22 additions and 134 deletions

27
debian/changelog vendored
View File

@ -1,4 +1,4 @@
linux (4.17.13-1) UNRELEASED; urgency=medium
linux (4.17.14-1) UNRELEASED; urgency=medium
* New upstream stable update:
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.17.9
@ -556,6 +556,27 @@ linux (4.17.13-1) UNRELEASED; urgency=medium
- drm/atomic: Initialize variables in drm_atomic_helper_async_check() to
make gcc happy
- scsi: sg: fix minor memory leak in error path
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.17.14
- scsi: qla2xxx: Fix unintialized List head crash
- scsi: qla2xxx: Fix NPIV deletion by calling wait_for_sess_deletion
- scsi: qla2xxx: Fix driver unload by shutting down chip
- scsi: qla2xxx: Fix ISP recovery on unload
- scsi: qla2xxx: Return error when TMF returns
- jfs: Fix usercopy whitelist for inline inode data
- genirq: Make force irq threading setup more robust
- [x86] perf/x86/intel/uncore: Fix hardcoded index of Broadwell extra PCI
devices
- nohz: Fix local_timer_softirq_pending()
- nohz: Fix missing tick reprogram when interrupting an inline softirq
- netlink: Don't shift on 64 for ngroups
- ring_buffer: tracing: Inherit the tracing setting to next ring buffer
- i2c: imx: Fix reinit_completion() use
- Btrfs: fix file data corruption after cloning a range and fsync
- Partially revert "block: fail op_is_write() requests to read-only
partitions" (Closes: #900442)
- xfs: don't call xfs_da_shrink_inode with NULL bp
- xfs: validate cached inodes are free when allocated
- jfs: Fix inconsistency between memory allocation and ea_buf->max_size
[ Ben Hutchings ]
* [armhf] gpu: host1x: Drop my build fix in favour of upstream fix:
@ -565,10 +586,6 @@ linux (4.17.13-1) UNRELEASED; urgency=medium
* mtd: powernv_flash: set of_node in mtd's dev (Closes: #904380)
* block: really disable runtime-pm for blk-mq (Closes: #904441)
[ Salvatore Bonaccorso ]
* Partially revert "block: fail op_is_write() requests to read-only
partitions" (Closes: #900442)
-- Romain Perier <romain.perier@gmail.com> Wed, 25 Jul 2018 14:05:34 +0200
linux (4.17.8-1) unstable; urgency=medium

View File

@ -1,88 +0,0 @@
From: Linus Torvalds <torvalds@linux-foundation.org>
Date: Fri, 3 Aug 2018 12:22:09 -0700
Subject: Partially revert "block: fail op_is_write() requests to read-only
partitions"
Origin: https://git.kernel.org/linus/a32e236eb93e62a0f692e79b7c3c9636689559b9
Bug-Debian: https://bugs.debian.org/900442
Bug: https://bugzilla.kernel.org/show_bug.cgi?id=200439
It turns out that commit 721c7fc701c7 ("block: fail op_is_write()
requests to read-only partitions"), while obviously correct, causes
problems for some older lvm2 installations.
The reason is that the lvm snapshotting will continue to write to the
snapshow COW volume, even after the volume has been marked read-only.
End result: snapshot failure.
This has actually been fixed in newer version of the lvm2 tool, but the
old tools still exist, and the breakage was reported both in the kernel
bugzilla and in the Debian bugzilla:
https://bugzilla.kernel.org/show_bug.cgi?id=200439
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=900442
The lvm2 fix is here
https://sourceware.org/git/?p=lvm2.git;a=commit;h=a6fdb9d9d70f51c49ad11a87ab4243344e6701a3
but until everybody has updated to recent versions, we'll have to weaken
the "never write to read-only partitions" check. It now allows the
write to happen, but causes a warning, something like this:
generic_make_request: Trying to write to read-only block-device dm-3 (partno X)
Modules linked in: nf_tables xt_cgroup xt_owner kvm_intel iwlmvm kvm irqbypass iwlwifi
CPU: 1 PID: 77 Comm: kworker/1:1 Not tainted 4.17.9-gentoo #3
Hardware name: LENOVO 20B6A019RT/20B6A019RT, BIOS GJET91WW (2.41 ) 09/21/2016
Workqueue: ksnaphd do_metadata
RIP: 0010:generic_make_request_checks+0x4ac/0x600
...
Call Trace:
generic_make_request+0x64/0x400
submit_bio+0x6c/0x140
dispatch_io+0x287/0x430
sync_io+0xc3/0x120
dm_io+0x1f8/0x220
do_metadata+0x1d/0x30
process_one_work+0x1b9/0x3e0
worker_thread+0x2b/0x3c0
kthread+0x113/0x130
ret_from_fork+0x35/0x40
Note that this is a "revert" in behavior only. I'm leaving alone the
actual code cleanups in commit 721c7fc701c7, but letting the previously
uncaught request go through with a warning instead of stopping it.
Fixes: 721c7fc701c7 ("block: fail op_is_write() requests to read-only partitions")
Reported-and-tested-by: WGH <wgh@torlan.ru>
Acked-by: Mike Snitzer <snitzer@redhat.com>
Cc: Sagi Grimberg <sagi@grimberg.me>
Cc: Ilya Dryomov <idryomov@gmail.com>
Cc: Jens Axboe <axboe@kernel.dk>
Cc: Zdenek Kabelac <zkabelac@redhat.com>
Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
---
block/blk-core.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
diff --git a/block/blk-core.c b/block/blk-core.c
index f84a9b7b6f5a..ee33590f54eb 100644
--- a/block/blk-core.c
+++ b/block/blk-core.c
@@ -2155,11 +2155,12 @@ static inline bool bio_check_ro(struct bio *bio, struct hd_struct *part)
if (part->policy && op_is_write(bio_op(bio))) {
char b[BDEVNAME_SIZE];
- printk(KERN_ERR
+ WARN_ONCE(1,
"generic_make_request: Trying to write "
"to read-only block-device %s (partno %d)\n",
bio_devname(bio, b), part->partno);
- return true;
+ /* Older lvm-tools actually trigger this */
+ return false;
}
return false;
--
2.18.0

View File

@ -1,39 +0,0 @@
From: Shankara Pailoor <shankarapailoor@gmail.com>
Date: Tue, 5 Jun 2018 08:33:27 -0500
Subject: jfs: Fix inconsistency between memory allocation and ea_buf->max_size
Origin: https://git.kernel.org/linus/92d34134193e5b129dc24f8d79cb9196626e8d7a
Bug-Debian-Security: https://security-tracker.debian.org/tracker/CVE-2018-12233
The code is assuming the buffer is max_size length, but we weren't
allocating enough space for it.
Signed-off-by: Shankara Pailoor <shankarapailoor@gmail.com>
Signed-off-by: Dave Kleikamp <dave.kleikamp@oracle.com>
---
fs/jfs/xattr.c | 10 ++++++----
1 file changed, 6 insertions(+), 4 deletions(-)
--- a/fs/jfs/xattr.c
+++ b/fs/jfs/xattr.c
@@ -491,15 +491,17 @@ static int ea_get(struct inode *inode, s
if (size > PSIZE) {
/*
* To keep the rest of the code simple. Allocate a
- * contiguous buffer to work with
+ * contiguous buffer to work with. Make the buffer large
+ * enough to make use of the whole extent.
*/
- ea_buf->xattr = kmalloc(size, GFP_KERNEL);
+ ea_buf->max_size = (size + sb->s_blocksize - 1) &
+ ~(sb->s_blocksize - 1);
+
+ ea_buf->xattr = kmalloc(ea_buf->max_size, GFP_KERNEL);
if (ea_buf->xattr == NULL)
return -ENOMEM;
ea_buf->flag = EA_MALLOC;
- ea_buf->max_size = (size + sb->s_blocksize - 1) &
- ~(sb->s_blocksize - 1);
if (ea_size == 0)
return 0;

View File

@ -95,7 +95,6 @@ bugfix/all/kbuild-include-addtree-remove-quotes-before-matching-path.patch
debian/revert-objtool-fix-config_stack_validation-y-warning.patch
bugfix/all/i40e-build-for-64-bit-targets-only.patch
bugfix/all/block-really-disable-runtime-pm-for-blk-mq.patch
bugfix/all/Partially-revert-block-fail-op_is_write-requests-to-.patch
# Miscellaneous features
features/all/kbuild-add-build-salt-to-the-kernel-and-modules.patch
@ -139,7 +138,6 @@ features/all/lockdown/arm64-add-kernel-config-option-to-lock-down-when.patch
# Security fixes
debian/i386-686-pae-pci-set-pci-nobios-by-default.patch
bugfix/all/jfs-fix-inconsistency-between-memory-allocation-and-.patch
# Fix exported symbol versions
bugfix/all/module-disable-matching-missing-version-crc.patch