[x86] i8259: Add missing include file

This commit is contained in:
Salvatore Bonaccorso 2018-08-16 21:17:42 +02:00
parent 757e7a9cb1
commit f7fa757621
3 changed files with 44 additions and 0 deletions

1
debian/changelog vendored
View File

@ -119,6 +119,7 @@ linux (4.17.15-1) UNRELEASED; urgency=medium
[ Salvatore Bonaccorso ]
* [x86] l1tf: Fix build error seen if CONFIG_KVM_INTEL is disabled
* [x86] i8259: Add missing include file
-- Ben Hutchings <ben@decadent.org.uk> Tue, 14 Aug 2018 00:07:30 +0800

View File

@ -0,0 +1,42 @@
From 0a957467c5fd46142bc9c52758ffc552d4c5e2f7 Mon Sep 17 00:00:00 2001
From: Guenter Roeck <linux@roeck-us.net>
Date: Wed, 15 Aug 2018 13:22:27 -0700
Subject: x86: i8259: Add missing include file
From: Guenter Roeck <linux@roeck-us.net>
commit 0a957467c5fd46142bc9c52758ffc552d4c5e2f7 upstream.
i8259.h uses inb/outb and thus needs to include asm/io.h to avoid the
following build error, as seen with x86_64:defconfig and CONFIG_SMP=n.
In file included from drivers/rtc/rtc-cmos.c:45:0:
arch/x86/include/asm/i8259.h: In function 'inb_pic':
arch/x86/include/asm/i8259.h:32:24: error:
implicit declaration of function 'inb'
arch/x86/include/asm/i8259.h: In function 'outb_pic':
arch/x86/include/asm/i8259.h:45:2: error:
implicit declaration of function 'outb'
Reported-by: Sebastian Gottschall <s.gottschall@dd-wrt.com>
Suggested-by: Sebastian Gottschall <s.gottschall@dd-wrt.com>
Fixes: 447ae3166702 ("x86: Don't include linux/irq.h from asm/hardirq.h")
Signed-off-by: Guenter Roeck <linux@roeck-us.net>
Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
---
arch/x86/include/asm/i8259.h | 1 +
1 file changed, 1 insertion(+)
--- a/arch/x86/include/asm/i8259.h
+++ b/arch/x86/include/asm/i8259.h
@@ -3,6 +3,7 @@
#define _ASM_X86_I8259_H
#include <linux/delay.h>
+#include <asm/io.h>
extern unsigned int cached_irq_mask;

View File

@ -70,6 +70,7 @@ bugfix/x86/mmap-add-an-exception-to-the-stack-gap-for-hotspot-jvm.patch
bugfix/powerpc/powerpc-lib-sstep-fix-building-for-powerpcspe.patch
bugfix/powerpc/powerpc-lib-makefile-don-t-pull-in-quad.o-for-32-bit.patch
bugfix/x86/x86-l1tf-fix-build-error-seen-if-config_kvm_intel-is-disabled.patch
bugfix/x86/x86-i8259-add-missing-include-file.patch
# Arch features
features/mips/MIPS-increase-MAX-PHYSMEM-BITS-on-Loongson-3-only.patch