add mips build fix

svn path=/dists/sid/linux-2.6/; revision=14468
This commit is contained in:
Martin Michlmayr 2009-10-27 13:21:06 +00:00
parent b8107af4c8
commit f74c146281
3 changed files with 95 additions and 0 deletions

1
debian/changelog vendored
View File

@ -2,6 +2,7 @@ linux-2.6 (2.6.31-2) UNRELEASED; urgency=low
[ Martin Michlmayr ]
* [armel/kirkwood] Enable CRYPTO_DEV_MV_CESA (Closes: #552270).
* mips: fix build of vmlinux.lds (Closes: #552422).
-- Martin Michlmayr <tbm@cyrius.com> Tue, 27 Oct 2009 21:18:29 +0800

View File

@ -0,0 +1,93 @@
On Mon, Oct 26, 2009 at 11:03:27AM +0100, Aurelien Jarno wrote:
> Martin Michlmayr a écrit :
> > * Andreas Barth <aba@not.so.argh.org> [2009-10-26 07:22]:
> >> Package: linux-2.6
> >> Version: 2.6.31-1
> >> Severity: serious
> >
> >> this package FTBFS on mipsel:
> >> MODPOST vmlinux.o
> >> GEN .version
> >> CHK include/linux/compile.h
> >> UPD include/linux/compile.h
> >> CC init/version.o
> >> LD init/built-in.o
> >> LD .tmp_vmlinux1
> >> ld:arch/mips/kernel/vmlinux.lds:168: syntax error
> >
> > Aurelien, can you take a look at this?
>
> I'll try to have a look, but I don't know when. There are plenty of RC
> bugs on eglibc to fix first.
Could it be this? I don't have hardware to test.
commit d71789b6fa37c21ce5eb588d279f57904a62e7e2
Author: Manuel Lauss <manuel.lauss@gmail.com>
Date: Thu Sep 24 21:44:24 2009 +0200
mips: fix build of vmlinux.lds
Commit 51b563fc93c8cb5bff1d67a0a71c374e4a4ea049 ("arm, cris, mips,
sparc, powerpc, um, xtensa: fix build with bash 4.0") removed a few
CPPFLAGS with vital include paths necessary to build vmlinux.lds
on MIPS, and moved the calculation of the 'jiffies' symbol
directly to vmlinux.lds.S but forgot to change make ifdef/... to
cpp macros.
Signed-off-by: Manuel Lauss <manuel.lauss@gmail.com>
[sam: moved assignment of CPPFLAGS arch/mips/kernel/Makefile]
Signed-off-by: Sam Ravnborg <sam@ravnborg.org>
Acked-by: Dmitri Vorobiev <dmitri.vorobiev@movial.com>
diff --git a/arch/mips/kernel/Makefile b/arch/mips/kernel/Makefile
index e961221..eecd2a9 100644
--- a/arch/mips/kernel/Makefile
+++ b/arch/mips/kernel/Makefile
@@ -2,6 +2,8 @@
# Makefile for the Linux/MIPS kernel.
#
+CPPFLAGS_vmlinux.lds := $(KBUILD_CFLAGS)
+
extra-y := head.o init_task.o vmlinux.lds
obj-y += cpu-probe.o branch.o entry.o genex.o irq.o process.o \
diff --git a/arch/mips/kernel/vmlinux.lds.S b/arch/mips/kernel/vmlinux.lds.S
index 9bf0e3d..162b299 100644
--- a/arch/mips/kernel/vmlinux.lds.S
+++ b/arch/mips/kernel/vmlinux.lds.S
@@ -11,15 +11,15 @@ PHDRS {
note PT_NOTE FLAGS(4); /* R__ */
}
-ifdef CONFIG_32BIT
- ifdef CONFIG_CPU_LITTLE_ENDIAN
+#ifdef CONFIG_32BIT
+ #ifdef CONFIG_CPU_LITTLE_ENDIAN
jiffies = jiffies_64;
- else
+ #else
jiffies = jiffies_64 + 4;
- endif
-else
+ #endif
+#else
jiffies = jiffies_64;
-endif
+#endif
SECTIONS
{
--
dann frazier
--
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

1
debian/patches/series/2 vendored Normal file
View File

@ -0,0 +1 @@
+ bugfix/mips/fix-build-vmlinuxlds.patch