V4L/DVB: budget: Select correct frontend drivers (Closes: #575223)

svn path=/dists/sid/linux-2.6/; revision=15686
This commit is contained in:
Ben Hutchings 2010-05-15 16:56:27 +00:00
parent ee9726bdb7
commit f41f9fbb6a
3 changed files with 36 additions and 0 deletions

1
debian/changelog vendored
View File

@ -36,6 +36,7 @@ linux-2.6 (2.6.32-13) UNRELEASED; urgency=low
* SCSI/libata: Disable HPA if it overlaps a partition (Closes: #572618)
* partitions: Rescan partition tables after HPA is disabled
* libata: Disable HPA if it is only enabled after suspend
* V4L/DVB: budget: Select correct frontend drivers (Closes: #575223)
[ Aurelien Jarno ]
* mips/swarm: fix boot from IDE based media (Sebastian Andrzej Siewior)

View File

@ -0,0 +1,34 @@
From 67b0f5b1177a0c348d1293ab78de4d1d6a736048 Mon Sep 17 00:00:00 2001
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sat, 15 May 2010 16:45:29 +0100
Subject: [PATCH] V4L/DVB: budget: Select correct frontends
Update the Kconfig selections to match the code.
---
drivers/media/dvb/ttpci/Kconfig | 5 +++--
1 files changed, 3 insertions(+), 2 deletions(-)
diff --git a/drivers/media/dvb/ttpci/Kconfig b/drivers/media/dvb/ttpci/Kconfig
index d8d4214..32a7ec6 100644
--- a/drivers/media/dvb/ttpci/Kconfig
+++ b/drivers/media/dvb/ttpci/Kconfig
@@ -68,13 +68,14 @@ config DVB_BUDGET
select DVB_VES1820 if !DVB_FE_CUSTOMISE
select DVB_L64781 if !DVB_FE_CUSTOMISE
select DVB_TDA8083 if !DVB_FE_CUSTOMISE
- select DVB_TDA10021 if !DVB_FE_CUSTOMISE
- select DVB_TDA10023 if !DVB_FE_CUSTOMISE
select DVB_S5H1420 if !DVB_FE_CUSTOMISE
select DVB_TDA10086 if !DVB_FE_CUSTOMISE
select DVB_TDA826X if !DVB_FE_CUSTOMISE
select DVB_LNBP21 if !DVB_FE_CUSTOMISE
select DVB_TDA1004X if !DVB_FE_CUSTOMISE
+ select DVB_ISL6423 if !DVB_FE_CUSTOMISE
+ select DVB_STV090x if !DVB_FE_CUSTOMISE
+ select DVB_STV6110x if !DVB_FE_CUSTOMISE
help
Support for simple SAA7146 based DVB cards (so called Budget-
or Nova-PCI cards) without onboard MPEG2 decoder, and without
--
1.7.1

View File

@ -29,3 +29,4 @@
+ bugfix/all/libata-unlock-HPA-if-device-shrunk.patch
+ bugfix/all/libata-use-enlarged-capacity-after-late-HPA-unlock.patch
+ bugfix/all/libata-implement-on-demand-HPA-unlocking.patch
+ bugfix/all/V4L-DVB-budget-Select-correct-frontends.patch