aufs: Update to aufs3.14-20140512

svn path=/dists/sid/linux/; revision=21335
This commit is contained in:
Ben Hutchings 2014-05-13 18:06:31 +00:00
parent abe58b9c4e
commit f3eebacffb
6 changed files with 30 additions and 20 deletions

2
debian/changelog vendored
View File

@ -123,6 +123,8 @@ linux (3.14.4-1) UNRELEASED; urgency=medium
* [hppa] udeb: Add xfs-modules (Closes: #746506)
* udeb: Add mtip32xx, nvme to sata-modules
* [rt] Update to 3.14.3-rt5
* aufs: Update to aufs3.14-20140512:
- bugfix, stop calling security_mmap_file() again
-- Ben Hutchings <ben@decadent.org.uk> Thu, 01 May 2014 01:50:30 +0100

View File

@ -1,7 +1,7 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Tue Apr 1 11:01:55 2014 +0900
Subject: aufs3.14-20140407
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/66ac1c999bb00cd649d702e8b0c8e8ab7fa9b352/tree/
Date: Tue May 6 22:36:39 2014 +0900
Subject: aufs3.14-20140512
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/16de14a1266dc814561c755485f0b79efc6b25b5/tree/
Bug-Debian: http://bugs.debian.org/541828
Patch generated by debian/patches/features/all/aufs3/gen-patch
@ -94,8 +94,8 @@ Patch generated by debian/patches/features/all/aufs3/gen-patch
+ When the aufs mount option 'noxino' is specified, it
+ will be empty. About XINO files, see the aufs manual.
--- a/Documentation/filesystems/aufs/README 1970-01-01 01:00:00.000000000 +0100
+++ b/Documentation/filesystems/aufs/README 2013-12-26 11:50:18.050562502 +0000
@@ -0,0 +1,344 @@
+++ b/Documentation/filesystems/aufs/README 2014-05-13 19:05:05.248347320 +0100
@@ -0,0 +1,345 @@
+
+Aufs3 -- advanced multi layered unification filesystem version 3.x
+http://aufs.sf.net
@ -423,6 +423,7 @@ Patch generated by debian/patches/features/all/aufs3/gen-patch
+"pemasu from Finland" made a donation (2013/7).
+The Parted Magic Project made a donation (2013/9 and 11).
+Pavel Barta made a donation (2013/10).
+Nikolay Pertsev made a donation (2014/5).
+
+Thank you very much.
+Donations are always, including future donations, very important and
@ -1704,7 +1705,7 @@ Patch generated by debian/patches/features/all/aufs3/gen-patch
+#endif /* __KERNEL__ */
+#endif /* __AUFS_H__ */
--- a/fs/aufs/branch.c 1970-01-01 01:00:00.000000000 +0100
+++ b/fs/aufs/branch.c 2014-01-20 03:24:33.508760970 +0000
+++ b/fs/aufs/branch.c 2014-05-13 19:05:02.876347266 +0100
@@ -0,0 +1,1219 @@
+/*
+ * Copyright (C) 2005-2014 Junjiro R. Okajima
@ -10153,8 +10154,8 @@ Patch generated by debian/patches/features/all/aufs3/gen-patch
+ atomic_set(&sbinfo->si_xigen_next, u);
+}
--- a/fs/aufs/f_op.c 1970-01-01 01:00:00.000000000 +0100
+++ b/fs/aufs/f_op.c 2014-01-20 03:24:33.512760970 +0000
@@ -0,0 +1,718 @@
+++ b/fs/aufs/f_op.c 2014-05-13 19:05:05.252347320 +0100
@@ -0,0 +1,725 @@
+/*
+ * Copyright (C) 2005-2014 Junjiro R. Okajima
+ *
@ -10597,6 +10598,7 @@ Patch generated by debian/patches/features/all/aufs3/gen-patch
+ * The similar scenario is applied to aufs_readlink() too.
+ */
+
+#if 0 /* stop calling security_file_mmap() */
+/* cf. linux/include/linux/mman.h: calc_vm_prot_bits() */
+#define AuConv_VM_PROT(f, b) _calc_vm_trans(f, VM_##b, PROT_##b)
+
@ -10630,6 +10632,7 @@ Patch generated by debian/patches/features/all/aufs3/gen-patch
+ | AuConv_VM_MAP(flags, DENYWRITE)
+ | AuConv_VM_MAP(flags, LOCKED);
+}
+#endif
+
+static int aufs_mmap(struct file *file, struct vm_area_struct *vma)
+{
@ -10673,8 +10676,13 @@ Patch generated by debian/patches/features/all/aufs3/gen-patch
+ lockdep_on();
+
+ au_vm_file_reset(vma, h_file);
+ err = security_mmap_file(h_file, au_prot_conv(vma->vm_flags),
+ au_flag_conv(vma->vm_flags));
+ /*
+ * we cannot call security_mmap_file() here since it may acquire
+ * mmap_sem or i_mutex.
+ *
+ * err = security_mmap_file(h_file, au_prot_conv(vma->vm_flags),
+ * au_flag_conv(vma->vm_flags));
+ */
+ if (!err)
+ err = h_file->f_op->mmap(h_file, vma);
+ if (unlikely(err))
@ -11259,7 +11267,7 @@ Patch generated by debian/patches/features/all/aufs3/gen-patch
+ return ret;
+}
--- a/fs/aufs/file.c 1970-01-01 01:00:00.000000000 +0100
+++ b/fs/aufs/file.c 2014-01-20 03:24:33.512760970 +0000
+++ b/fs/aufs/file.c 2014-05-13 19:05:02.880347266 +0100
@@ -0,0 +1,724 @@
+/*
+ * Copyright (C) 2005-2014 Junjiro R. Okajima
@ -13275,7 +13283,7 @@ Patch generated by debian/patches/features/all/aufs3/gen-patch
+ }
+}
--- a/fs/aufs/hnotify.c 1970-01-01 01:00:00.000000000 +0100
+++ b/fs/aufs/hnotify.c 2014-04-08 03:07:56.523497471 +0100
+++ b/fs/aufs/hnotify.c 2014-05-13 19:05:02.880347266 +0100
@@ -0,0 +1,710 @@
+/*
+ * Copyright (C) 2005-2014 Junjiro R. Okajima
@ -27075,7 +27083,7 @@ Patch generated by debian/patches/features/all/aufs3/gen-patch
+ return 0;
+}
--- a/fs/aufs/vfsub.c 1970-01-01 01:00:00.000000000 +0100
+++ b/fs/aufs/vfsub.c 2014-01-20 03:24:33.516760970 +0000
+++ b/fs/aufs/vfsub.c 2014-05-13 19:05:02.880347266 +0100
@@ -0,0 +1,782 @@
+/*
+ * Copyright (C) 2005-2014 Junjiro R. Okajima
@ -30048,7 +30056,7 @@ Patch generated by debian/patches/features/all/aufs3/gen-patch
+#endif /* __KERNEL__ */
+#endif /* __AUFS_WHOUT_H__ */
--- a/fs/aufs/wkq.c 1970-01-01 01:00:00.000000000 +0100
+++ b/fs/aufs/wkq.c 2014-01-20 03:24:33.520760970 +0000
+++ b/fs/aufs/wkq.c 2014-05-13 19:05:02.880347266 +0100
@@ -0,0 +1,212 @@
+/*
+ * Copyright (C) 2005-2014 Junjiro R. Okajima
@ -31674,7 +31682,7 @@ Patch generated by debian/patches/features/all/aufs3/gen-patch
+ return err;
+}
--- a/include/uapi/linux/aufs_type.h 1970-01-01 01:00:00.000000000 +0100
+++ b/include/uapi/linux/aufs_type.h 2014-04-08 03:07:56.523497471 +0100
+++ b/include/uapi/linux/aufs_type.h 2014-05-13 19:05:05.252347320 +0100
@@ -0,0 +1,281 @@
+/*
+ * Copyright (C) 2005-2014 Junjiro R. Okajima
@ -31717,7 +31725,7 @@ Patch generated by debian/patches/features/all/aufs3/gen-patch
+
+#include <linux/limits.h>
+
+#define AUFS_VERSION "3.14-20140407"
+#define AUFS_VERSION "3.14-20140512"
+
+/* todo? move this to linux-2.6.19/include/magic.h */
+#define AUFS_SUPER_MAGIC ('a' << 24 | 'u' << 16 | 'f' << 8 | 's')

View File

@ -1,7 +1,7 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Tue Apr 1 11:01:55 2014 +0900
Subject: aufs3.14 base patch
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/66ac1c999bb00cd649d702e8b0c8e8ab7fa9b352/tree/
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/16de14a1266dc814561c755485f0b79efc6b25b5/tree/
Bug-Debian: http://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs3/gen-patch

View File

@ -1,7 +1,7 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Tue Apr 1 11:01:55 2014 +0900
Subject: aufs3.14 kbuild patch
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/66ac1c999bb00cd649d702e8b0c8e8ab7fa9b352/tree/
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/16de14a1266dc814561c755485f0b79efc6b25b5/tree/
Bug-Debian: http://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs3/gen-patch

View File

@ -1,7 +1,7 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Tue Apr 1 11:01:55 2014 +0900
Subject: aufs3.14 mmap patch
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/66ac1c999bb00cd649d702e8b0c8e8ab7fa9b352/tree/
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/16de14a1266dc814561c755485f0b79efc6b25b5/tree/
Bug-Debian: http://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs3/gen-patch

View File

@ -1,7 +1,7 @@
From: J. R. Okajima <hooanon05@yahoo.co.jp>
Date: Tue Apr 1 11:01:55 2014 +0900
Subject: aufs3.14 standalone patch
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/66ac1c999bb00cd649d702e8b0c8e8ab7fa9b352/tree/
Origin: http://sourceforge.net/p/aufs/aufs3-standalone/ci/16de14a1266dc814561c755485f0b79efc6b25b5/tree/
Bug-Debian: http://bugs.debian.org/541828
Patch headers added by debian/patches/features/all/aufs3/gen-patch