rt2x00: Add device IDs 5362, 5392, 539b (Closes: #694312)

svn path=/dists/sid/linux/; revision=19571
This commit is contained in:
Ben Hutchings 2012-12-02 17:20:08 +00:00
parent a218abd148
commit f39275cf2e
4 changed files with 61 additions and 0 deletions

1
debian/changelog vendored
View File

@ -84,6 +84,7 @@ linux (3.2.34-1) UNRELEASED; urgency=low
* ipv6: Treat ND option 31 as userland (DNSSL support) (Closes: #694522)
* Input: i8042 - also perform controller reset when suspending
(Closes: #693934)
* rt2x00: Add device IDs 5362, 5392, 539b (Closes: #694312)
[ Ian Campbell ]
* [xen] add support for microcode updating. (Closes: #693053)

View File

@ -0,0 +1,25 @@
From: "Zero.Lin" <Zero.Lin@mediatek.com>
Date: Thu, 10 May 2012 10:06:31 +0800
Subject: rt2x00:Add RT539b chipset support
commit 2aed691540661e9cf6dac5dd2bd8742b9d68399d upstream.
Signed-off-by: Zero.Lin <Zero.Lin@mediatek.com>
Acked-by: Gertjan van Wingerde <gwingerde@gmail.com>
Signed-off-by: John W. Linville <linville@tuxdriver.com>
---
drivers/net/wireless/rt2x00/rt2800pci.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/drivers/net/wireless/rt2x00/rt2800pci.c b/drivers/net/wireless/rt2x00/rt2800pci.c
index 931331d..cad25bf 100644
--- a/drivers/net/wireless/rt2x00/rt2800pci.c
+++ b/drivers/net/wireless/rt2x00/rt2800pci.c
@@ -1192,6 +1192,7 @@ static DEFINE_PCI_DEVICE_TABLE(rt2800pci_device_table) = {
{ PCI_DEVICE(0x1814, 0x5390) },
{ PCI_DEVICE(0x1814, 0x5392) },
{ PCI_DEVICE(0x1814, 0x539a) },
+ { PCI_DEVICE(0x1814, 0x539b) },
{ PCI_DEVICE(0x1814, 0x539f) },
#endif
{ 0, }

View File

@ -0,0 +1,33 @@
From: Xose Vazquez Perez <xose.vazquez@gmail.com>
Date: Sat, 14 Apr 2012 23:33:21 +0200
Subject: wireless: rt2x00: rt2800pci add more RT539x ids
commit f57d7b6c9db1f9e26da09694b5fcb5650547f7d2 upstream.
RT539x devices:
(0x1814, 0x5362)
(0x1814, 0x5392)
Taken from ralink driver 2011_0406_RT5390_RT5392_Linux_STA_V2.5.0.3_DPO
Signed-off-by: Xose Vazquez Perez <xose.vazquez@gmail.com>
Acked-by: Gertjan van Wingerde <gwingerde@gmail.com>
Signed-off-by: John W. Linville <linville@tuxdriver.com>
---
drivers/net/wireless/rt2x00/rt2800pci.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/drivers/net/wireless/rt2x00/rt2800pci.c b/drivers/net/wireless/rt2x00/rt2800pci.c
index f9f36cf..931331d 100644
--- a/drivers/net/wireless/rt2x00/rt2800pci.c
+++ b/drivers/net/wireless/rt2x00/rt2800pci.c
@@ -1188,7 +1188,9 @@ static DEFINE_PCI_DEVICE_TABLE(rt2800pci_device_table) = {
{ PCI_DEVICE(0x1814, 0x3593) },
#endif
#ifdef CONFIG_RT2800PCI_RT53XX
+ { PCI_DEVICE(0x1814, 0x5362) },
{ PCI_DEVICE(0x1814, 0x5390) },
+ { PCI_DEVICE(0x1814, 0x5392) },
{ PCI_DEVICE(0x1814, 0x539a) },
{ PCI_DEVICE(0x1814, 0x539f) },
#endif

View File

@ -414,3 +414,5 @@ debian/rtnetlink-avoid-ABI-change-in-3.2.34.patch
debian/mm-avoid-ABI-change-in-3.2.33.patch
features/all/ipv6-Treat-ND-option-31-as-userland-DNSSL-support.patch
bugfix/x86/Input-i8042-also-perform-controller-reset-when-suspe.patch
features/all/wireless-rt2x00-rt2800pci-add-more-RT539x-ids.patch
features/all/rt2x00-Add-RT539b-chipset-support.patch