[arm] mm: Avoid ABI change in 3.13.6 (fixes FTBFS)

svn path=/dists/sid/linux/; revision=21178
This commit is contained in:
Ben Hutchings 2014-03-21 21:02:42 +00:00
parent e53fc2abff
commit f221244ee2
3 changed files with 30 additions and 0 deletions

6
debian/changelog vendored
View File

@ -1,3 +1,9 @@
linux (3.13.6-2) UNRELEASED; urgency=medium
* [arm] mm: Avoid ABI change in 3.13.6 (fixes FTBFS)
-- Ben Hutchings <ben@decadent.org.uk> Fri, 21 Mar 2014 19:47:01 +0000
linux (3.13.6-1) unstable; urgency=high
* New upstream stable update:

View File

@ -0,0 +1,23 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Fri, 21 Mar 2014 19:44:13 +0000
Subject: ARM: mm: Avoid ABI change in 3.13.6
Forwarded: not-needed
struct mem_type gained a new member in 3.13.6, and there are two
exported functions that take/return pointers to this structure.
However the actual definition is opaque to modules, so this is not an
ABI change and we can just hide it from genksyms.
--- a/arch/arm/mm/mm.h
+++ b/arch/arm/mm/mm.h
@@ -38,7 +38,10 @@ static inline pmd_t *pmd_off_k(unsigned
struct mem_type {
pteval_t prot_pte;
+#ifndef __GENKSYMS__
+/* Added in 3.13.6, not an ABI change as the structure is opaque to modules */
pteval_t prot_pte_s2;
+#endif
pmdval_t prot_l1;
pmdval_t prot_sect;
unsigned int domain;

View File

@ -94,3 +94,4 @@ bugfix/all/ipv6-don-t-set-DST_NOCOUNT-for-remotely-added-routes.patch
debian/fs-avoid-abi-change-in-3.13.6.patch
debian/netdev-avoid-abi-change-in-3.13.6.patch
debian/can-avoid-abi-change-in-3.13.6.patch
debian/arm-mm-avoid-abi-change-in-3.13.6.patch