Update to 3.7.3

svn path=/dists/trunk/linux/; revision=19741
This commit is contained in:
Ben Hutchings 2013-01-18 01:36:03 +00:00
parent b1fcc019d0
commit f06024c7fa
4 changed files with 11 additions and 43 deletions

3
debian/changelog vendored
View File

@ -1,7 +1,8 @@
linux (3.7.2-1~experimental.1) UNRELEASED; urgency=low
linux (3.7.3-1~experimental.1) UNRELEASED; urgency=low
* New upstream stable update:
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.7.2
http://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.7.3
[ Ben Hutchings ]
* [ia64] nouveau: Disable another bit of ACPI support (fixes FTBFS)

View File

@ -1511,14 +1511,15 @@ upstream submission.
int success = 0;
--- a/drivers/net/wireless/b43/main.c
+++ b/drivers/net/wireless/b43/main.c
@@ -2132,18 +2132,8 @@ int b43_do_request_fw(struct b43_request
return -ENOSYS;
@@ -2158,19 +2158,8 @@ int b43_do_request_fw(struct b43_request
}
err = request_firmware(&blob, ctx->fwname, ctx->dev->dev->dev);
err = request_firmware(&ctx->blob, ctx->fwname,
ctx->dev->dev->dev);
- if (err == -ENOENT) {
- snprintf(ctx->errors[ctx->req_type],
- sizeof(ctx->errors[ctx->req_type]),
- "Firmware file \"%s\" not found\n", ctx->fwname);
- "Firmware file \"%s\" not found\n",
- ctx->fwname);
+ if (err)
return err;
- } else if (err) {
@ -1528,9 +1529,9 @@ upstream submission.
- ctx->fwname, err);
- return err;
- }
if (blob->size < sizeof(struct b43_fw_header))
fw_ready:
if (ctx->blob->size < sizeof(struct b43_fw_header))
goto err_format;
hdr = (struct b43_fw_header *)(blob->data);
--- a/drivers/net/wireless/b43legacy/main.c
+++ b/drivers/net/wireless/b43legacy/main.c
@@ -1554,11 +1554,8 @@ static int do_request_fw(struct b43legac
@ -2072,7 +2073,7 @@ upstream submission.
if (qla82xx_validate_firmware_blob(vha,
--- a/drivers/scsi/qla2xxx/qla_os.c
+++ b/drivers/scsi/qla2xxx/qla_os.c
@@ -4890,8 +4890,6 @@ qla2x00_request_firmware(scsi_qla_host_t
@@ -4889,8 +4889,6 @@ qla2x00_request_firmware(scsi_qla_host_t
goto out;
if (request_firmware(&blob->fw, blob->name, &ha->pdev->dev)) {
@ -2747,7 +2748,7 @@ upstream submission.
/* The FPGA is a Xilinx Spartan IIE XC2S50E */
--- a/sound/pci/hda/hda_intel.c
+++ b/sound/pci/hda/hda_intel.c
@@ -3289,10 +3289,8 @@ static void azx_firmware_cb(const struct
@@ -3292,10 +3292,8 @@ static void azx_firmware_cb(const struct
struct azx *chip = card->private_data;
struct pci_dev *pci = chip->pci;

View File

@ -1,33 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Subject: Clean modules without link-vmlinux.sh
Date: Sat, 29 Dec 2012 01:51:05 +0100
Bug-Debian: http://bugs.debian.org/696775
Calling link-vmlinux.sh when cleaning external modules is stupid.
--- a/Makefile
+++ b/Makefile
@@ -1036,11 +1036,13 @@ clean: rm-dirs := $(CLEAN_DIRS)
clean: rm-files := $(CLEAN_FILES)
clean-dirs := $(addprefix _clean_, . $(vmlinux-alldirs) Documentation samples)
-PHONY += $(clean-dirs) clean archclean
+PHONY += $(clean-dirs) clean-vmlinux clean archclean
$(clean-dirs):
$(Q)$(MAKE) $(clean)=$(patsubst _clean_%,%,$@)
+clean-vmlinux:
+ $(Q)$(CONFIG_SHELL) $(srctree)/scripts/link-vmlinux.sh clean
-clean: archclean
+clean: clean-vmlinux archclean
# mrproper - Delete all generated files, including .config
#
@@ -1267,7 +1269,6 @@ scripts: ;
endif # KBUILD_EXTMOD
clean: $(clean-dirs)
- $(Q)$(CONFIG_SHELL) $(srctree)/scripts/link-vmlinux.sh clean
$(call cmd,rmdirs)
$(call cmd,rmfiles)
@find $(if $(KBUILD_EXTMOD), $(KBUILD_EXTMOD), .) $(RCS_FIND_IGNORE) \

View File

@ -67,7 +67,6 @@ bugfix/all/pch_gbe-ptp_pch-Fix-the-dependency-direction-between.patch
debian/udl-disable-autoload.patch
debian/ast-disable-autoload.patch
debian/mgag200-disable-autoload.patch
clean-modules-without-link-vmlinux.sh.patch
bugfix/all/ath6kl-do-not-use-virt_addr_valid.patch
features/all/xen/microcode-api-update.patch