ipr: add writeq definition if needed (Closes: #584840)

svn path=/dists/trunk/linux-2.6/; revision=15846
This commit is contained in:
Ben Hutchings 2010-06-09 22:16:05 +00:00
parent b1820f6286
commit ef951cd9a1
3 changed files with 42 additions and 0 deletions

7
debian/changelog vendored
View File

@ -1,3 +1,10 @@
linux-2.6 (2.6.34-1~experimental.3) UNRELEASED; urgency=low
[ Ben Hutchings ]
* ipr: add writeq definition if needed (Closes: #584840)
-- Ben Hutchings <ben@decadent.org.uk> Wed, 09 Jun 2010 23:03:38 +0100
linux-2.6 (2.6.34-1~experimental.2) experimental; urgency=low
[ Ben Hutchings ]

View File

@ -0,0 +1,34 @@
From: Brian King <brking@linux.vnet.ibm.com>
Subject: [PATCH 1/1] ipr: add writeq definition if needed
Date: Wed, 09 Jun 2010 08:24:55 -0700
Compiling the driver will fail on 32 bit powerpc and other
architectures where writeq is not defined. This patch adds a
definition for writeq.
Signed-off-by: Wayne Boyer <wayneb@linux.vnet.ibm.com>
Acked-by: Brian King <brking@linux.vnet.ibm.com>
---
drivers/scsi/ipr.h | 8 ++++++++
1 file changed, 8 insertions(+)
Index: b/drivers/scsi/ipr.h
===================================================================
--- a/drivers/scsi/ipr.h 2010-06-08 10:06:48.000000000 -0700
+++ b/drivers/scsi/ipr.h 2010-06-08 15:14:42.000000000 -0700
@@ -1860,4 +1860,12 @@ static inline int ipr_sdt_is_fmt2(u32 sd
return 0;
}
+#ifndef writeq
+static inline void writeq(u64 val, void __iomem *addr)
+{
+ writel(((u32) (val >> 32)), addr);
+ writel(((u32) (val)), (addr + 4));
+}
#endif
+
+#endif /* _IPR_H */

View File

@ -0,0 +1 @@
+ bugfix/all/ipr-add-writeq-definition-if-needed.patch