Update to 3.12-rc5

Drop/refresh patches as needed.
Remove firmware from staging rtl8188eu driver.

svn path=/dists/trunk/linux/; revision=20714
This commit is contained in:
Ben Hutchings 2013-10-18 01:43:36 +00:00
parent 0be7018ef1
commit ee546290ba
8 changed files with 46 additions and 269 deletions

6
debian/changelog vendored
View File

@ -1,3 +1,9 @@
linux (3.12~rc5-1~exp1) UNRELEASED; urgency=low
* New upstream release candidate
-- Ben Hutchings <ben@decadent.org.uk> Fri, 18 Oct 2013 02:06:38 +0100
linux (3.11.5-1) unstable; urgency=low
* New upstream stable update:

View File

@ -1,169 +0,0 @@
From: Ingo Molnar <mingo@kernel.org>
Date: Tue, 15 Oct 2013 08:23:51 +0200
Subject: [PATCH] compiler/gcc4: Add quirk for 'asm goto' miscompilation bug
Origin: https://lkml.kernel.org/g/20131015062933.GB4666@gmail.com
Fengguang Wu, Oleg Nesterov and Peter Zijlstra tracked down
a kernel crash to a GCC bug: GCC miscompiles certain 'asm goto'
constructs, as outlined here:
http://gcc.gnu.org/bugzilla/show_bug.cgi?id=58670
Implement a workaround suggested by Jakub Jelinek.
Reported-and-tested-by: Fengguang Wu <fengguang.wu@intel.com>
Reported-by: Oleg Nesterov <oleg@redhat.com>
Reported-by: Peter Zijlstra <a.p.zijlstra@chello.nl>
Suggested-by: Jakub Jelinek <jakub@redhat.com>
Reviewed-by: Richard Henderson <rth@twiddle.net>
Cc: Linus Torvalds <torvalds@linux-foundation.org>
Cc: Andrew Morton <akpm@linux-foundation.org>
Cc: <stable@kernel.org>
Link: http://lkml.kernel.org/r/20131015062351.GA4666@gmail.com
Signed-off-by: Ingo Molnar <mingo@kernel.org>
---
arch/arm/include/asm/jump_label.h | 2 +-
arch/mips/include/asm/jump_label.h | 2 +-
arch/powerpc/include/asm/jump_label.h | 2 +-
arch/s390/include/asm/jump_label.h | 2 +-
arch/sparc/include/asm/jump_label.h | 2 +-
arch/x86/include/asm/cpufeature.h | 6 +++---
arch/x86/include/asm/jump_label.h | 2 +-
include/linux/compiler-gcc4.h | 15 +++++++++++++++
8 files changed, 24 insertions(+), 9 deletions(-)
diff --git a/arch/arm/include/asm/jump_label.h b/arch/arm/include/asm/jump_label.h
index bfc198c..863c892 100644
--- a/arch/arm/include/asm/jump_label.h
+++ b/arch/arm/include/asm/jump_label.h
@@ -16,7 +16,7 @@
static __always_inline bool arch_static_branch(struct static_key *key)
{
- asm goto("1:\n\t"
+ asm_volatile_goto("1:\n\t"
JUMP_LABEL_NOP "\n\t"
".pushsection __jump_table, \"aw\"\n\t"
".word 1b, %l[l_yes], %c0\n\t"
diff --git a/arch/mips/include/asm/jump_label.h b/arch/mips/include/asm/jump_label.h
index 4d6d77e..e194f95 100644
--- a/arch/mips/include/asm/jump_label.h
+++ b/arch/mips/include/asm/jump_label.h
@@ -22,7 +22,7 @@
static __always_inline bool arch_static_branch(struct static_key *key)
{
- asm goto("1:\tnop\n\t"
+ asm_volatile_goto("1:\tnop\n\t"
"nop\n\t"
".pushsection __jump_table, \"aw\"\n\t"
WORD_INSN " 1b, %l[l_yes], %0\n\t"
diff --git a/arch/powerpc/include/asm/jump_label.h b/arch/powerpc/include/asm/jump_label.h
index ae098c4..f016bb6 100644
--- a/arch/powerpc/include/asm/jump_label.h
+++ b/arch/powerpc/include/asm/jump_label.h
@@ -19,7 +19,7 @@
static __always_inline bool arch_static_branch(struct static_key *key)
{
- asm goto("1:\n\t"
+ asm_volatile_goto("1:\n\t"
"nop\n\t"
".pushsection __jump_table, \"aw\"\n\t"
JUMP_ENTRY_TYPE "1b, %l[l_yes], %c0\n\t"
diff --git a/arch/s390/include/asm/jump_label.h b/arch/s390/include/asm/jump_label.h
index 6c32190..346b1c8 100644
--- a/arch/s390/include/asm/jump_label.h
+++ b/arch/s390/include/asm/jump_label.h
@@ -15,7 +15,7 @@
static __always_inline bool arch_static_branch(struct static_key *key)
{
- asm goto("0: brcl 0,0\n"
+ asm_volatile_goto("0: brcl 0,0\n"
".pushsection __jump_table, \"aw\"\n"
ASM_ALIGN "\n"
ASM_PTR " 0b, %l[label], %0\n"
diff --git a/arch/sparc/include/asm/jump_label.h b/arch/sparc/include/asm/jump_label.h
index 5080d16..ec2e2e2 100644
--- a/arch/sparc/include/asm/jump_label.h
+++ b/arch/sparc/include/asm/jump_label.h
@@ -9,7 +9,7 @@
static __always_inline bool arch_static_branch(struct static_key *key)
{
- asm goto("1:\n\t"
+ asm_volatile_goto("1:\n\t"
"nop\n\t"
"nop\n\t"
".pushsection __jump_table, \"aw\"\n\t"
diff --git a/arch/x86/include/asm/cpufeature.h b/arch/x86/include/asm/cpufeature.h
index 47538a6..7290585 100644
--- a/arch/x86/include/asm/cpufeature.h
+++ b/arch/x86/include/asm/cpufeature.h
@@ -373,7 +373,7 @@ static __always_inline __pure bool __static_cpu_has(u16 bit)
* Catch too early usage of this before alternatives
* have run.
*/
- asm goto("1: jmp %l[t_warn]\n"
+ asm_volatile_goto("1: jmp %l[t_warn]\n"
"2:\n"
".section .altinstructions,\"a\"\n"
" .long 1b - .\n"
@@ -386,7 +386,7 @@ static __always_inline __pure bool __static_cpu_has(u16 bit)
: : "i" (X86_FEATURE_ALWAYS) : : t_warn);
#endif
- asm goto("1: jmp %l[t_no]\n"
+ asm_volatile_goto("1: jmp %l[t_no]\n"
"2:\n"
".section .altinstructions,\"a\"\n"
" .long 1b - .\n"
@@ -448,7 +448,7 @@ static __always_inline __pure bool _static_cpu_has_safe(u16 bit)
* have. Thus, we force the jump to the widest, 4-byte, signed relative
* offset even though the last would often fit in less bytes.
*/
- asm goto("1: .byte 0xe9\n .long %l[t_dynamic] - 2f\n"
+ asm_volatile_goto("1: .byte 0xe9\n .long %l[t_dynamic] - 2f\n"
"2:\n"
".section .altinstructions,\"a\"\n"
" .long 1b - .\n" /* src offset */
diff --git a/arch/x86/include/asm/jump_label.h b/arch/x86/include/asm/jump_label.h
index 3a16c14..0297669 100644
--- a/arch/x86/include/asm/jump_label.h
+++ b/arch/x86/include/asm/jump_label.h
@@ -13,7 +13,7 @@
static __always_inline bool arch_static_branch(struct static_key *key)
{
- asm goto("1:"
+ asm_volatile_goto("1:"
STATIC_KEY_INITIAL_NOP
".pushsection __jump_table, \"aw\" \n\t"
_ASM_ALIGN "\n\t"
diff --git a/include/linux/compiler-gcc4.h b/include/linux/compiler-gcc4.h
index 842de22..ded4299 100644
--- a/include/linux/compiler-gcc4.h
+++ b/include/linux/compiler-gcc4.h
@@ -65,6 +65,21 @@
#define __visible __attribute__((externally_visible))
#endif
+/*
+ * GCC 'asm goto' miscompiles certain code sequences:
+ *
+ * http://gcc.gnu.org/bugzilla/show_bug.cgi?id=58670
+ *
+ * Work it around via a compiler barrier quirk suggested by Jakub Jelinek.
+ * Fixed in GCC 4.8.2 and later versions.
+ *
+ * (asm goto is automatically volatile - the naming reflects this.)
+ */
+#if GCC_VERSION <= 40801
+# define asm_volatile_goto(x...) do { asm goto(x); asm (""); } while (0)
+#else
+# define asm_volatile_goto(x...) do { asm goto(x); } while (0)
+#endif
#ifdef CONFIG_ARCH_USE_BUILTIN_BSWAP
#if GCC_VERSION >= 40400

View File

@ -53,7 +53,7 @@ upstream submission.
/* disable MPU */
--- a/arch/x86/kernel/microcode_amd.c
+++ b/arch/x86/kernel/microcode_amd.c
@@ -429,10 +429,8 @@ static enum ucode_state request_microcod
@@ -430,10 +430,8 @@ static enum ucode_state request_microcod
if (c->x86 >= 0x15)
snprintf(fw_name, sizeof(fw_name), "amd-ucode/microcode_amd_fam%.2xh.bin", c->x86);
@ -96,7 +96,7 @@ upstream submission.
fw_size = firmware->size / sizeof(u32);
--- a/drivers/bluetooth/ath3k.c
+++ b/drivers/bluetooth/ath3k.c
@@ -327,10 +327,8 @@ static int ath3k_load_patch(struct usb_d
@@ -357,10 +357,8 @@ static int ath3k_load_patch(struct usb_d
fw_version.rom_version);
ret = request_firmware(&firmware, filename, &udev->dev);
@ -108,7 +108,7 @@ upstream submission.
pt_version.rom_version = *(int *)(firmware->data + firmware->size - 8);
pt_version.build_version = *(int *)
@@ -389,10 +387,8 @@ static int ath3k_load_syscfg(struct usb_
@@ -419,10 +417,8 @@ static int ath3k_load_syscfg(struct usb_
fw_version.rom_version, clk_value, ".dfu");
ret = request_firmware(&firmware, filename, &udev->dev);
@ -203,7 +203,7 @@ upstream submission.
fw->size, fw_name);
--- a/drivers/dma/imx-sdma.c
+++ b/drivers/dma/imx-sdma.c
@@ -1164,10 +1164,8 @@ static void sdma_load_firmware(const str
@@ -1258,10 +1258,8 @@ static void sdma_load_firmware(const str
const struct sdma_script_start_addrs *addr;
unsigned short *ram_code;
@ -261,7 +261,7 @@ upstream submission.
printk(KERN_ERR
--- a/drivers/gpu/drm/radeon/ni.c
+++ b/drivers/gpu/drm/radeon/ni.c
@@ -806,10 +806,6 @@ int ni_init_microcode(struct radeon_devi
@@ -814,10 +814,6 @@ int ni_init_microcode(struct radeon_devi
out:
if (err) {
@ -288,7 +288,7 @@ upstream submission.
rdev->me_fw->size, fw_name);
--- a/drivers/gpu/drm/radeon/r600.c
+++ b/drivers/gpu/drm/radeon/r600.c
@@ -2311,10 +2311,6 @@ int r600_init_microcode(struct radeon_de
@@ -2312,10 +2312,6 @@ int r600_init_microcode(struct radeon_de
out:
if (err) {
@ -960,7 +960,7 @@ upstream submission.
printk(KERN_ERR "ERROR: Firmware size mismatch "
--- a/drivers/media/pci/cx23885/cx23885-cards.c
+++ b/drivers/media/pci/cx23885/cx23885-cards.c
@@ -1795,11 +1795,7 @@ void cx23885_card_setup(struct cx23885_d
@@ -1797,11 +1797,7 @@ void cx23885_card_setup(struct cx23885_d
cinfo.rev, filename);
ret = request_firmware(&fw, filename, &dev->pci->dev);
@ -1063,7 +1063,7 @@ upstream submission.
--- a/drivers/media/usb/s2255/s2255drv.c
+++ b/drivers/media/usb/s2255/s2255drv.c
@@ -2568,10 +2568,8 @@ static int s2255_probe(struct usb_interf
@@ -2563,10 +2563,8 @@ static int s2255_probe(struct usb_interf
}
/* load the first chunk */
if (request_firmware(&dev->fw_data->fw,
@ -1220,7 +1220,7 @@ upstream submission.
--- a/drivers/net/ethernet/broadcom/bnx2.c
+++ b/drivers/net/ethernet/broadcom/bnx2.c
@@ -3679,16 +3679,13 @@ static int bnx2_request_uncached_firmwar
@@ -3678,16 +3678,13 @@ static int bnx2_request_uncached_firmwar
}
rc = request_firmware(&bp->mips_firmware, mips_fw_file, &bp->pdev->dev);
@ -1242,7 +1242,7 @@ upstream submission.
if (bp->mips_firmware->size < sizeof(*mips_fw) ||
--- a/drivers/net/ethernet/broadcom/bnx2x/bnx2x_main.c
+++ b/drivers/net/ethernet/broadcom/bnx2x/bnx2x_main.c
@@ -12412,11 +12412,8 @@ static int bnx2x_init_firmware(struct bn
@@ -12455,11 +12455,8 @@ static int bnx2x_init_firmware(struct bn
BNX2X_DEV_INFO("Loading %s\n", fw_file_name);
rc = request_firmware(&bp->firmware, fw_file_name, &bp->pdev->dev);
@ -1257,7 +1257,7 @@ upstream submission.
if (rc) {
--- a/drivers/net/ethernet/broadcom/tg3.c
+++ b/drivers/net/ethernet/broadcom/tg3.c
@@ -11123,11 +11123,8 @@ static int tg3_request_firmware(struct t
@@ -11193,11 +11193,8 @@ static int tg3_request_firmware(struct t
{
const struct tg3_firmware_hdr *fw_hdr;
@ -1328,7 +1328,7 @@ upstream submission.
if (ret)
--- a/drivers/net/ethernet/chelsio/cxgb4/cxgb4_main.c
+++ b/drivers/net/ethernet/chelsio/cxgb4/cxgb4_main.c
@@ -1089,11 +1089,8 @@ static int upgrade_fw(struct adapter *ad
@@ -1098,11 +1098,8 @@ static int upgrade_fw(struct adapter *ad
}
ret = request_firmware(&fw, fw_file_name, dev);
@ -1343,7 +1343,7 @@ upstream submission.
vers = ntohl(hdr->fw_ver);
--- a/drivers/net/ethernet/intel/e100.c
+++ b/drivers/net/ethernet/intel/e100.c
@@ -1293,9 +1293,6 @@ static const struct firmware *e100_reque
@@ -1290,9 +1290,6 @@ static const struct firmware *e100_reque
if (err) {
if (required) {
@ -1355,7 +1355,7 @@ upstream submission.
netif_info(nic, probe, nic->netdev,
--- a/drivers/net/ethernet/myricom/myri10ge/myri10ge.c
+++ b/drivers/net/ethernet/myricom/myri10ge/myri10ge.c
@@ -584,8 +584,6 @@ static int myri10ge_load_hotplug_firmwar
@@ -600,8 +600,6 @@ static int myri10ge_load_hotplug_firmwar
unsigned i;
if ((status = request_firmware(&fw, mgp->fw_name, dev)) < 0) {
@ -1465,7 +1465,7 @@ upstream submission.
fwh = (struct at76_fw_header *)(fwe->fw->data);
--- a/drivers/net/wireless/ath/ath9k/hif_usb.c
+++ b/drivers/net/wireless/ath/ath9k/hif_usb.c
@@ -1098,12 +1098,8 @@ static void ath9k_hif_usb_firmware_cb(co
@@ -1082,12 +1082,8 @@ static void ath9k_hif_usb_firmware_cb(co
struct hif_device_usb *hif_dev = context;
int ret;
@ -1545,7 +1545,7 @@ upstream submission.
hdr = (struct b43legacy_fw_header *)((*fw)->data);
--- a/drivers/net/wireless/brcm80211/brcmfmac/dhd_sdio.c
+++ b/drivers/net/wireless/brcm80211/brcmfmac/dhd_sdio.c
@@ -2959,10 +2959,8 @@ static int brcmf_sdbrcm_download_code_fi
@@ -3059,10 +3059,8 @@ static int brcmf_sdbrcm_download_code_fi
ret = request_firmware(&bus->firmware, BRCMF_SDIO_FW_NAME,
&bus->sdiodev->func[2]->dev);
@ -1557,7 +1557,7 @@ upstream submission.
bus->fw_ptr = 0;
memptr = memblock = kmalloc(MEMBLOCK + BRCMF_SDALIGN, GFP_ATOMIC);
@@ -3081,10 +3079,8 @@ static int brcmf_sdbrcm_download_nvram(s
@@ -3181,10 +3179,8 @@ static int brcmf_sdbrcm_download_nvram(s
ret = request_firmware(&bus->firmware, BRCMF_SDIO_NV_NAME,
&bus->sdiodev->func[2]->dev);
@ -1663,15 +1663,15 @@ upstream submission.
}
--- a/drivers/net/wireless/mwifiex/main.c
+++ b/drivers/net/wireless/mwifiex/main.c
@@ -400,11 +400,8 @@ static void mwifiex_fw_dpc(const struct
struct mwifiex_adapter *adapter = context;
struct mwifiex_fw_image fw;
@@ -417,11 +417,8 @@ static void mwifiex_fw_dpc(const struct
struct semaphore *sem = adapter->card_sem;
bool init_failed = false;
- if (!firmware) {
- dev_err(adapter->dev,
- "Failed to get firmware %s\n", adapter->fw_name);
+ if (!firmware)
goto done;
goto err_dnld_fw;
- }
memset(&fw, 0, sizeof(struct mwifiex_fw_image));
@ -1791,7 +1791,7 @@ upstream submission.
if (ret) {
--- a/drivers/net/wireless/p54/p54usb.c
+++ b/drivers/net/wireless/p54/p54usb.c
@@ -929,7 +929,6 @@ static void p54u_load_firmware_cb(const
@@ -930,7 +930,6 @@ static void p54u_load_firmware_cb(const
err = p54u_start_ops(priv);
} else {
err = -ENOENT;
@ -2034,7 +2034,7 @@ upstream submission.
}
--- a/drivers/scsi/qla2xxx/qla_init.c
+++ b/drivers/scsi/qla2xxx/qla_init.c
@@ -5126,8 +5126,6 @@ qla2x00_load_risc(scsi_qla_host_t *vha,
@@ -5134,8 +5134,6 @@ qla2x00_load_risc(scsi_qla_host_t *vha,
/* Load firmware blob. */
blob = qla2x00_request_firmware(vha);
if (!blob) {
@ -2043,7 +2043,7 @@ upstream submission.
ql_log(ql_log_info, vha, 0x0084,
"Firmware images can be retrieved from: "QLA_FW_URL ".\n");
return QLA_FUNCTION_FAILED;
@@ -5228,8 +5226,6 @@ qla24xx_load_risc_blob(scsi_qla_host_t *
@@ -5236,8 +5234,6 @@ qla24xx_load_risc_blob(scsi_qla_host_t *
/* Load firmware blob. */
blob = qla2x00_request_firmware(vha);
if (!blob) {
@ -2054,7 +2054,7 @@ upstream submission.
QLA_FW_URL ".\n");
--- a/drivers/scsi/qla2xxx/qla_nx.c
+++ b/drivers/scsi/qla2xxx/qla_nx.c
@@ -2441,11 +2441,8 @@ try_blob_fw:
@@ -2435,11 +2435,8 @@ try_blob_fw:
/* Load firmware blob. */
blob = ha->hablob = qla2x00_request_firmware(vha);
@ -2069,7 +2069,7 @@ upstream submission.
if (qla82xx_validate_firmware_blob(vha,
--- a/drivers/scsi/qla2xxx/qla_os.c
+++ b/drivers/scsi/qla2xxx/qla_os.c
@@ -5200,8 +5200,6 @@ qla2x00_request_firmware(scsi_qla_host_t
@@ -5316,8 +5316,6 @@ qla2x00_request_firmware(scsi_qla_host_t
goto out;
if (request_firmware(&blob->fw, blob->name, &ha->pdev->dev)) {
@ -2326,7 +2326,7 @@ upstream submission.
--- a/drivers/tty/serial/icom.c
+++ b/drivers/tty/serial/icom.c
@@ -373,7 +373,6 @@ static void load_code(struct icom_port *
@@ -375,7 +375,6 @@ static void load_code(struct icom_port *
/* Load Call Setup into Adapter */
if (request_firmware(&fw, "icom_call_setup.bin", &dev->dev) < 0) {
@ -2334,7 +2334,7 @@ upstream submission.
status = -1;
goto load_code_exit;
}
@@ -393,7 +392,6 @@ static void load_code(struct icom_port *
@@ -395,7 +394,6 @@ static void load_code(struct icom_port *
/* Load Resident DCE portion of Adapter */
if (request_firmware(&fw, "icom_res_dce.bin", &dev->dev) < 0) {
@ -2342,7 +2342,7 @@ upstream submission.
status = -1;
goto load_code_exit;
}
@@ -438,7 +436,6 @@ static void load_code(struct icom_port *
@@ -440,7 +438,6 @@ static void load_code(struct icom_port *
}
if (request_firmware(&fw, "icom_asc.bin", &dev->dev) < 0) {
@ -2506,7 +2506,7 @@ upstream submission.
}
--- a/drivers/usb/serial/io_edgeport.c
+++ b/drivers/usb/serial/io_edgeport.c
@@ -302,11 +302,8 @@ static void update_edgeport_E2PROM(struc
@@ -300,11 +300,8 @@ static void update_edgeport_E2PROM(struc
response = request_ihex_firmware(&fw, fw_name,
&edge_serial->serial->dev->dev);
@ -2521,7 +2521,7 @@ upstream submission.
BootMajorVersion = rec->data[0];
--- a/drivers/usb/serial/io_ti.c
+++ b/drivers/usb/serial/io_ti.c
@@ -782,8 +782,6 @@ static int build_i2c_fw_hdr(__u8 *header
@@ -779,8 +779,6 @@ static int build_i2c_fw_hdr(__u8 *header
err = request_firmware(&fw, fw_name, dev);
if (err) {
@ -2530,7 +2530,7 @@ upstream submission.
kfree(buffer);
return err;
}
@@ -1341,8 +1339,6 @@ static int download_fw(struct edgeport_s
@@ -1338,8 +1336,6 @@ static int download_fw(struct edgeport_s
err = request_firmware(&fw, fw_name, dev);
if (err) {
@ -2541,7 +2541,7 @@ upstream submission.
}
--- a/drivers/usb/serial/ti_usb_3410_5052.c
+++ b/drivers/usb/serial/ti_usb_3410_5052.c
@@ -1571,10 +1571,8 @@ static int ti_download_firmware(struct t
@@ -1499,10 +1499,8 @@ static int ti_download_firmware(struct t
}
status = request_firmware(&fw_p, buf, &dev->dev);
}
@ -2711,7 +2711,7 @@ upstream submission.
}
--- a/sound/pci/hda/hda_intel.c
+++ b/sound/pci/hda/hda_intel.c
@@ -3718,11 +3718,8 @@ static void azx_firmware_cb(const struct
@@ -3771,11 +3771,8 @@ static void azx_firmware_cb(const struct
struct azx *chip = card->private_data;
struct pci_dev *pci = chip->pci;

View File

@ -22,12 +22,12 @@ Signed-off-by: Arnaud Patard <arnaud.patard@rtp-net.org>
config USB_MUSB_DAVINCI
tristate "DaVinci"
depends on ARCH_DAVINCI_DMx
@@ -91,8 +88,6 @@ config USB_MUSB_BLACKFIN
@@ -92,8 +89,6 @@ config USB_MUSB_BLACKFIN
config USB_MUSB_UX500
tristate "U8500 and U5500"
-endchoice
-
choice
prompt 'MUSB DMA mode'
default MUSB_PIO_ONLY if ARCH_MULTIPLATFORM
config USB_MUSB_AM335X_CHILD
tristate

View File

@ -1,18 +0,0 @@
From: Thorsten Glaser <tg@debian.org>
Description: m68k: handle Atari interrupts in multi-platform kernels
Origin: http://thread.gmane.org/gmane.linux.debian.devel.kernel/91476/focus=5003
Forwarded: http://thread.gmane.org/gmane.linux.ports.m68k/5009
--- a/arch/m68k/include/asm/irqflags.h
+++ b/arch/m68k/include/asm/irqflags.h
@@ -67,6 +67,10 @@ static inline void arch_local_irq_restor
static inline bool arch_irqs_disabled_flags(unsigned long flags)
{
+ if (MACH_IS_ATARI) {
+ /* Ignore HSYNC = ipl 2 on Atari */
+ return (flags & ~(ALLOWINT | 0x200)) != 0;
+ }
return (flags & ~ALLOWINT) != 0;
}

View File

@ -20,6 +20,8 @@ rm drivers/staging/ft1000/ft1000-*/*.img
rm drivers/staging/keucr/init.h
rm drivers/staging/rtl8188eu/hal/Hal8188EFWImg_CE.c
unifdef drivers/staging/rtl8192e/rtl8192e/r8192E_hwimg.c -UREMOVE_DFSG
rm drivers/staging/wlags49_h2/ap_*.c

View File

@ -1,37 +0,0 @@
From: Arnaud Patard <arnaud.patard@rtp-net.org>
Subject: imx53-qsb: enable usb power
Forwarded: no
Enable usb power pin by using a fixed regulator. With this and the usb clock
patch is making usb working on my loco.
Signed-off-by: Arnaud Patard <arnaud.patard@rtp-net.org>
[bwh: For 3.10, use macro for PIN_FUNC_ID in GPIO list]
Index: linux/arch/arm/boot/dts/imx53-qsb.dts
===================================================================
--- linux.orig/arch/arm/boot/dts/imx53-qsb.dts 2013-05-20 00:46:34.000000000 +0200
+++ linux/arch/arm/boot/dts/imx53-qsb.dts 2013-05-20 01:06:31.000000000 +0200
@@ -66,6 +66,15 @@
regulator-max-microvolt = <3200000>;
regulator-always-on;
};
+
+ reg_usbpwr: usbpwr {
+ compatible = "regulator-fixed";
+ regulator-name = "usbpwr";
+ regulator-min-microvolt = <5000000>;
+ regulator-max-microvolt = <5000000>;
+ gpio = <&gpio7 8 0>;
+ regulator-always-on;
+ };
};
sound {
@@ -118,6 +127,7 @@
MX53_PAD_EIM_DA12__GPIO3_12 0x80000000
MX53_PAD_EIM_DA13__GPIO3_13 0x80000000
MX53_PAD_PATA_DA_0__GPIO7_6 0x80000000
+ MX53_PAD_PATA_DA_2__GPIO7_8 0x80000000
MX53_PAD_GPIO_16__GPIO7_11 0x80000000
>;
};

View File

@ -63,9 +63,6 @@ bugfix/arm/ixp4xx_iobe.patch
bugfix/x86/viafb-autoload-on-olpc-xo1.5-only.patch
bugfix/all/misc-bmp085-Enable-building-as-a-module.patch
# ARM hardware support
features/arm/imx53-qsb-usb-power.patch
# Miscellaneous features
features/all/x86-memtest-WARN-if-bad-RAM-found.patch
features/all/efi-autoload-efivars.patch
@ -73,9 +70,5 @@ features/all/efi-autoload-efivars.patch
# m68k Kconfig bugfix
bugfix/m68k/ethernat-kconfig.patch
# m68k IRQ bugfix
bugfix/m68k/atari-irqs.patch
bugfix/all/compiler-gcc-4-add-quirk-for-asm-goto-miscompilation-bug.patch
bugfix/all/crypto-ansi_cprng-Fix-off-by-one-error-in-non-block-.patch
features/all/mvsas-Recognise-device-subsystem-9485-9485-as-88SE94.patch