[sparc] cpufreq: Convince genksyms that the ABI didn't change (fixes FTBFS)

svn path=/dists/sid/linux/; revision=20424
This commit is contained in:
Ben Hutchings 2013-07-29 00:41:42 +00:00
parent c54097ab60
commit ee4ea8e1ab
3 changed files with 33 additions and 0 deletions

7
debian/changelog vendored
View File

@ -1,3 +1,10 @@
linux (3.10.3-2) UNRELEASED; urgency=low
* [sparc] cpufreq: Convince genksyms that the ABI didn't change
(fixes FTBFS)
-- Ben Hutchings <ben@decadent.org.uk> Mon, 29 Jul 2013 00:11:35 +0100
linux (3.10.3-1) unstable; urgency=low
* New upstream stable update:

View File

@ -0,0 +1,24 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Mon, 29 Jul 2013 00:05:51 +0100
Subject: [sparc] cpufreq: Convince genksyms that the ABI didn't change
Forwarded: not-needed
genksyms is really stupid: un-including a header whose definitions
didn't appear in the ABI stil changes symbol versions. So restore the
#include <linux/cpu.h> for symbol version purposes.
(This only seems to affect SPARC; on other architectures
<linux/cpu.h> may still be indirectly included.)
--- a/drivers/cpufreq/cpufreq_governor.c
+++ b/drivers/cpufreq/cpufreq_governor.c
@@ -26,6 +26,9 @@
#include <linux/tick.h>
#include <linux/types.h>
#include <linux/workqueue.h>
+#ifdef __GENKSYMS__
+#include <linux/cpu.h>
+#endif
#include "cpufreq_governor.h"

View File

@ -125,3 +125,5 @@ bugfix/all/9p-fix-off-by-one-causing-access-violations-and-memo.patch
# m68k Kconfig bugfix
bugfix/m68k/ethernat-kconfig.patch
debian/sparc-cpufreq-convince-genksyms-that-the-abi-didnt-change.patch