[armhf,sparc64] Force ZONE_DMA to be enabled, reversing ABI change in 4.3.3 (fixes FTBFS)

This commit is contained in:
Ben Hutchings 2015-12-17 17:49:39 +00:00
parent 86eb6b9a54
commit ee4980cb32
3 changed files with 48 additions and 0 deletions

7
debian/changelog vendored
View File

@ -1,3 +1,10 @@
linux (4.3.3-2) UNRELEASED; urgency=medium
* [armhf,sparc64] Force ZONE_DMA to be enabled, reversing ABI change in
4.3.3 (fixes FTBFS)
-- Ben Hutchings <ben@decadent.org.uk> Thu, 17 Dec 2015 17:49:56 +0000
linux (4.3.3-1) unstable; urgency=medium
* New upstream stable update:

View File

@ -0,0 +1,40 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Thu, 17 Dec 2015 17:37:09 +0000
Subject: [armhf,sparc64] Force ZONE_DMA to be enabled
Forwarded: not-needed
CONFIG_ZONE_DMA is supposed to be selected according to the architecture
configuration, not by drivers.
In 4.3.3 several sound drivers were changed to depend on, rather than
selecting, ZONE_DMA. This disabled it and thus broke ABI for most
arm{el,hf}, mips* and sparc64 flavours.
Version 4.3.1-1 FTBFS on armel and didn't finish building on mips* in
time to include an ABI reference for 4.3.3-1. So the mips* flavours
have quietly changed ABI (oops) while armhf and sparc now FTBFS.
Leave mips* as it is, but force ZONE_DMA on to reverse the ABI change
for armhf and sparc64.
---
--- a/arch/arm/Kconfig
+++ b/arch/arm/Kconfig
@@ -204,6 +204,7 @@ config ARCH_MAY_HAVE_PC_FDC
config ZONE_DMA
bool
+ default y if ARCH_MULTI_V7
config NEED_DMA_MAP_STATE
def_bool y
--- a/arch/sparc/Kconfig
+++ b/arch/sparc/Kconfig
@@ -131,7 +131,7 @@ config HIGHMEM
config ZONE_DMA
bool
- default y if SPARC32
+ default y
config NEED_DMA_MAP_STATE
def_bool y

View File

@ -104,3 +104,4 @@ features/arm/arm-dts-add-support-odroid-xu4-board-for-exynos5422-.patch
bugfix/all/revert-vrf-fix-double-free-and-memory-corruption-on-.patch
bugfix/all/vrf-fix-double-free-and-memory-corruption-on-registe.patch
bugfix/all/tipc-fix-kfree_skb-of-uninitialised-pointer.patch
debian/armhf-sparc64-force-zone_dma-to-be-enabled.patch