DocBook: Fix build breakage

svn path=/dists/trunk/linux-2.6/; revision=14656
This commit is contained in:
Ben Hutchings 2009-11-21 04:16:43 +00:00
parent 4107c35abb
commit edcb50627f
4 changed files with 97 additions and 0 deletions

1
debian/changelog vendored
View File

@ -11,6 +11,7 @@ linux-2.6 (2.6.32~rc8-1) UNRELEASED; urgency=low
load it
* r8169: Remove firmware for RTL8168D v1 and v2 and use
request_firmware() to load it
* DocBook: Fix build breakage
[ Bastian Blank ]
* [mips] Don't force EMBEDDED on.

View File

@ -0,0 +1,47 @@
From 8116c08e4d24087d35f7ad949f754a5207e2eef8 Mon Sep 17 00:00:00 2001
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sat, 21 Nov 2009 04:01:56 +0000
Subject: [PATCH 1/2] DocBook/media: copy images after building HTML
The rule for %.html removes the output directory, so there is no point
in copying images before building HTML.
---
Documentation/DocBook/Makefile | 10 +++++-----
1 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/Documentation/DocBook/Makefile b/Documentation/DocBook/Makefile
index ab8300f..22bbf7e 100644
--- a/Documentation/DocBook/Makefile
+++ b/Documentation/DocBook/Makefile
@@ -32,7 +32,7 @@ PS_METHOD = $(prefer-db2x)
###
# The targets that may be used.
-PHONY += xmldocs sgmldocs psdocs pdfdocs htmldocs mandocs installmandocs cleandocs media
+PHONY += xmldocs sgmldocs psdocs pdfdocs htmldocs mandocs installmandocs cleandocs
BOOKS := $(addprefix $(obj)/,$(DOCBOOKS))
xmldocs: $(BOOKS)
@@ -45,15 +45,15 @@ PDF := $(patsubst %.xml, %.pdf, $(BOOKS))
pdfdocs: $(PDF)
HTML := $(sort $(patsubst %.xml, %.html, $(BOOKS)))
-htmldocs: media $(HTML)
+htmldocs: $(HTML)
$(call build_main_index)
+ $(call build_images)
MAN := $(patsubst %.xml, %.9, $(BOOKS))
mandocs: $(MAN)
-media:
- mkdir -p $(srctree)/Documentation/DocBook/media/
- cp $(srctree)/Documentation/DocBook/dvb/*.png $(srctree)/Documentation/DocBook/v4l/*.gif $(srctree)/Documentation/DocBook/media/
+build_images = mkdir -p $(objtree)/Documentation/DocBook/media/ && \
+ cp $(srctree)/Documentation/DocBook/dvb/*.png $(srctree)/Documentation/DocBook/v4l/*.gif $(objtree)/Documentation/DocBook/media/
installmandocs: mandocs
mkdir -p /usr/local/man/man9/
--
1.6.5.2

View File

@ -0,0 +1,47 @@
From 5c9556f8aedbaa6a419b39e4eac6045c6686e944 Mon Sep 17 00:00:00 2001
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sat, 21 Nov 2009 04:06:35 +0000
Subject: [PATCH 2/2] DocBook/media: create links for included sources
If docs are being built in a separate directory, xmlto and xsltproc
can't find included sources. Make links back to the source directory.
---
Documentation/DocBook/Makefile | 13 +++++++++++--
1 files changed, 11 insertions(+), 2 deletions(-)
diff --git a/Documentation/DocBook/Makefile b/Documentation/DocBook/Makefile
index 22bbf7e..50075df 100644
--- a/Documentation/DocBook/Makefile
+++ b/Documentation/DocBook/Makefile
@@ -32,10 +32,10 @@ PS_METHOD = $(prefer-db2x)
###
# The targets that may be used.
-PHONY += xmldocs sgmldocs psdocs pdfdocs htmldocs mandocs installmandocs cleandocs
+PHONY += xmldocs sgmldocs psdocs pdfdocs htmldocs mandocs installmandocs cleandocs xmldoclinks
BOOKS := $(addprefix $(obj)/,$(DOCBOOKS))
-xmldocs: $(BOOKS)
+xmldocs: $(BOOKS) xmldoclinks
sgmldocs: xmldocs
PS := $(patsubst %.xml, %.ps, $(BOOKS))
@@ -55,6 +55,15 @@ mandocs: $(MAN)
build_images = mkdir -p $(objtree)/Documentation/DocBook/media/ && \
cp $(srctree)/Documentation/DocBook/dvb/*.png $(srctree)/Documentation/DocBook/v4l/*.gif $(objtree)/Documentation/DocBook/media/
+xmldoclinks:
+ifneq ($(objtree),$(srctree))
+ for dep in dvb media-entities.tmpl media-indices.tmpl v4l; do \
+ rm -f $(objtree)/Documentation/DocBook/$$dep \
+ && ln -s $(srctree)/Documentation/DocBook/$$dep $(objtree)/Documentation/DocBook/ \
+ || exit; \
+ done
+endif
+
installmandocs: mandocs
mkdir -p /usr/local/man/man9/
install Documentation/DocBook/man/*.9.gz /usr/local/man/man9/
--
1.6.5.2

View File

@ -51,3 +51,5 @@
+ bugfix/arm/videobuf-dma-build-fix.patch
+ bugfix/arm/scsi-osd-build-fix.patch
+ bugfix/mips/drm-ttm-build-fix.patch
+ bugfix/all/DocBook-media-copy-images-after-building-HTML.patch
+ bugfix/all/DocBook-media-create-links-for-included-sources.patch