ALSA: hda - Enable auto-parser as default for Conexant codecs

makes sound really suck *less* on x220, taken from linux-next.

svn path=/dists/trunk/linux-2.6/; revision=17819
This commit is contained in:
Maximilian Attems 2011-07-06 21:22:25 +00:00
parent e65d3cea04
commit ed2152c8dd
3 changed files with 70 additions and 1 deletions

3
debian/changelog vendored
View File

@ -1,4 +1,4 @@
linux-2.6 (3.0.0~rc6-1~experimental.2) experimental; urgency=low
linux-2.6 (3.0.0~rc6-1~experimental.2) UNRELEASED; urgency=low
[ maximilian attems ]
* Topconfig enable modular VIDEO_SR030PC30, VIDEO_NOON010PC30,
@ -6,6 +6,7 @@ linux-2.6 (3.0.0~rc6-1~experimental.2) experimental; urgency=low
SOC_CAMERA_OV9740, USB_YUREX.
* [x86] enable modular VIDEO_VIA_CAMERA.
* [x86_32] enable modular XO15_EBOOK.
* ALSA: hda - Enable auto-parser as default for Conexant codecs.
-- maximilian attems <maks@debian.org> Tue, 05 Jul 2011 14:25:29 +0200

View File

@ -0,0 +1,67 @@
From 7a21b2b3d8af62110b0a564f63a64360af34ac10 Mon Sep 17 00:00:00 2001
From: Takashi Iwai <tiwai@suse.de>
Date: Tue, 28 Jun 2011 14:17:17 +0200
Subject: [PATCH] ALSA: hda - Enable auto-parser as default for Conexant codecs
Let's use auto-parser as default now.
Signed-off-by: Takashi Iwai <tiwai@suse.de>
---
sound/pci/hda/patch_conexant.c | 16 ++++------------
1 files changed, 4 insertions(+), 12 deletions(-)
diff --git a/sound/pci/hda/patch_conexant.c b/sound/pci/hda/patch_conexant.c
index 6e90b6b..4ca880b 100644
--- a/sound/pci/hda/patch_conexant.c
+++ b/sound/pci/hda/patch_conexant.c
@@ -1124,10 +1124,8 @@ static int patch_cxt5045(struct hda_codec *codec)
board_config = snd_hda_check_board_config(codec, CXT5045_MODELS,
cxt5045_models,
cxt5045_cfg_tbl);
-#if 0 /* use the old method just for safety */
if (board_config < 0)
- board_config = CXT5045_AUTO;
-#endif
+ board_config = CXT5045_AUTO; /* model=auto as default */
if (board_config == CXT5045_AUTO)
return patch_conexant_auto(codec);
@@ -1565,10 +1563,8 @@ static int patch_cxt5047(struct hda_codec *codec)
board_config = snd_hda_check_board_config(codec, CXT5047_MODELS,
cxt5047_models,
cxt5047_cfg_tbl);
-#if 0 /* not enabled as default, as BIOS often broken for this codec */
if (board_config < 0)
- board_config = CXT5047_AUTO;
-#endif
+ board_config = CXT5047_AUTO; /* model=auto as default */
if (board_config == CXT5047_AUTO)
return patch_conexant_auto(codec);
@@ -1994,10 +1990,8 @@ static int patch_cxt5051(struct hda_codec *codec)
board_config = snd_hda_check_board_config(codec, CXT5051_MODELS,
cxt5051_models,
cxt5051_cfg_tbl);
-#if 0 /* use the old method just for safety */
if (board_config < 0)
- board_config = CXT5051_AUTO;
-#endif
+ board_config = CXT5051_AUTO; /* model=auto as default */
if (board_config == CXT5051_AUTO)
return patch_conexant_auto(codec);
@@ -3115,10 +3109,8 @@ static int patch_cxt5066(struct hda_codec *codec)
board_config = snd_hda_check_board_config(codec, CXT5066_MODELS,
cxt5066_models, cxt5066_cfg_tbl);
-#if 0 /* use the old method just for safety */
if (board_config < 0)
- board_config = CXT5066_AUTO;
-#endif
+ board_config = CXT5066_AUTO; /* model=auto as default */
if (board_config == CXT5066_AUTO)
return patch_conexant_auto(codec);
--
1.7.2.5

View File

@ -50,3 +50,4 @@
+ bugfix/all/m68k-atari-Reserve-some-ST-RAM-early-on-for-device-b.patch
+ bugfix/all/ALSA-hda-Handle-1-as-invalid-position-too.patch
+ bugfix/all/ALSA-hda-Judge-playback-stream-from-stream-id-in-azx.patch
+ bugfix/all/ALSA-hda-Enable-auto-parser-as-default-for-Conexant-.patch