Update to 4.3-rc3

This commit is contained in:
Ben Hutchings 2015-10-06 23:55:28 +01:00
parent 755c6a0307
commit ec98f72b18
4 changed files with 7 additions and 78 deletions

6
debian/changelog vendored
View File

@ -1,3 +1,9 @@
linux-tools (4.3~rc3-1~exp1) UNRELEASED; urgency=medium
* New upstream release candidate
-- Ben Hutchings <ben@decadent.org.uk> Mon, 28 Sep 2015 01:54:21 +0100
linux-tools (4.2-1) unstable; urgency=medium
* New upstream release

View File

@ -1,49 +1,9 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Thu, 13 Aug 2015 20:48:12 +0200
Subject: liblockdep: Add more headers and definitions needed by lockdep
Subject: liblockdep: Define WRITE_ONCE(), used by <linux/rbtree_augmented.h>.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
--- /dev/null
+++ b/tools/lib/lockdep/uinclude/linux/export.h
@@ -0,0 +1,10 @@
+#ifndef _LINUX_EXPORT_H
+#define _LINUX_EXPORT_H
+
+#define EXPORT_SYMBOL(sym)
+#define EXPORT_SYMBOL_GPL(sym)
+#define EXPORT_SYMBOL_GPL_FUTURE(sym)
+#define EXPORT_UNUSED_SYMBOL(sym)
+#define EXPORT_UNUSED_SYMBOL_GPL(sym)
+
+#endif /* _LINUX_EXPORT_H */
--- a/tools/lib/lockdep/uinclude/linux/kernel.h
+++ b/tools/lib/lockdep/uinclude/linux/kernel.h
@@ -23,7 +23,7 @@
#define WARN_ON(x) (x)
#define WARN_ON_ONCE(x) (x)
#define likely(x) (x)
-#define WARN(x, y, z) (x)
+#define WARN(x, y...) (x)
#define uninitialized_var(x) x
#define __init
#define noinline
--- a/tools/lib/lockdep/preload.c
+++ b/tools/lib/lockdep/preload.c
@@ -5,7 +5,7 @@
#include <stdlib.h>
#include <sysexits.h>
#include "include/liblockdep/mutex.h"
-#include "../../../include/linux/rbtree.h"
+#include <linux/rbtree.h>
/**
* struct lock_lookup - liblockdep's view of a single unique lock
--- a/tools/lib/lockdep/uinclude/linux/rbtree.h
+++ b/tools/lib/lockdep/uinclude/linux/rbtree.h
@@ -1 +1 @@
-#include "../../../include/linux/rbtree.h"
+#include "../../include/linux/rbtree.h"
--- a/tools/lib/lockdep/uinclude/linux/compiler.h
+++ b/tools/lib/lockdep/uinclude/linux/compiler.h
@@ -4,4 +4,10 @@
@ -57,12 +17,3 @@ Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
+#define WRITE_ONCE(x, val) (ACCESS_ONCE(x) = (val))
+
#endif
--- a/tools/lib/lockdep/uinclude/linux/rcu.h
+++ b/tools/lib/lockdep/uinclude/linux/rcu.h
@@ -18,4 +18,6 @@ static inline bool rcu_is_watching(void)
return false;
}
+#define RCU_INIT_POINTER(p, v) (p = v)
+
#endif

View File

@ -6,7 +6,6 @@ usbip-document-tcp-wrappers.patch
kbuild-fix-recordmcount-dependency.patch
usbip-include-uninstalled-linux-usbip-h.patch
tools-perf-man-date.patch
tools-perf-add-empty-build-files-for-architectures-lacking.patch
lockdep-fix-oot-build.patch
lockdep-fix-headers.patch
lockdep-fix-soname.patch

View File

@ -1,27 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Tue, 04 Aug 2015 16:59:53 +0100
Subject: tools/perf: Add empty Build files for architectures lacking them
Forwarded: http://mid.gmane.org/1438704627.7315.2.camel@decadent.org.uk
perf currently fails to build on MIPS as there is no
tools/perf/arch/mips/Build file. Adding an empty file fixes this as
there are no MIPS-specific sources to build.
It looks like the same is needed for Alpha and PA-RISC, though I
haven't been able to test those.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
Fixes: 5e8c0fb6a957 ("perf build: Add arch x86 objects building")
---
--- /dev/null
+++ b/tools/perf/arch/alpha/Build
@@ -0,0 +1 @@
+# empty
--- /dev/null
+++ b/tools/perf/arch/mips/Build
@@ -0,0 +1,1 @@
+# empty
--- /dev/null
+++ b/tools/perf/arch/parisc/Build
@@ -0,0 +1 @@
+# empty