Avoid/ignore more ABI changes in 4.13.y

This commit is contained in:
Ben Hutchings 2017-10-28 20:49:52 +01:00
parent 0b4bd142ab
commit ec3cd54d45
4 changed files with 41 additions and 2 deletions

3
debian/changelog vendored
View File

@ -326,11 +326,12 @@ linux (4.13.9-1) UNRELEASED; urgency=medium
* dax: Avoid most ABI changes in 4.13.5
* SCSI: Avoid ABI change in 4.13.6
* [x86] kvm: Ignore ABI change in 4.13.6
* seq-virmidi: Ignore ABI change in 4.13.8
* inet, l2tp, seq-virmidi, usb/gadget: Ignore ABI changes
* Revert "bpf: one perf event close won't free bpf program attached ..."
to avoid an ABI change
* [armel] security: Enable SECURITY_APPARMOR and disable SECURITY_SELINUX
* security: Enable DEFAULT_SECURITY_APPARMOR
* mac80211: Avoid ABI change in 4.13.5
-- Ben Hutchings <ben@decadent.org.uk> Wed, 18 Oct 2017 20:03:01 +0100

View File

@ -5,6 +5,8 @@ ignore-changes:
bpf_analyzer
cxl_*
dax_flush
inet_add_protocol
inet_del_protocol
iommu_device_*
kvm_async_pf_task_wait
mm_iommu_*
@ -27,11 +29,12 @@ ignore-changes:
module:drivers/scsi/ufs/*
module:drivers/target/**
module:drivers/usb/chipidea/**
module:drivers/usb/gadget/**
module:drivers/usb/host/**
module:drivers/usb/musb/**
module:fs/nfs/**
module:net/ceph/libceph
module:net/l2tp/l2tp_core
module:net/l2tp/**
module:sound/core/seq/snd-seq-virmidi
module:sound/firewire/snd-firewire-lib
# btree library is only selected by few drivers so not useful OOT

View File

@ -0,0 +1,34 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sat, 28 Oct 2017 20:46:43 +0100
Subject: mac80211: Avoid ABI change in 4.13.5
Forwarded: not-needed
Commit 531682159092 ("mac80211: fix VLAN handling with TXQs") replaced
a union with two separate members in ieee80211_tx_info::control. The
one which changed offset (enqueue_time) doesn't appear to be accessed
outside of the mac80211 module, so this shouldn't be an ABI change for
drivers. Therefore hide the ABI change from genksyms.
---
--- a/include/net/mac80211.h
+++ b/include/net/mac80211.h
@@ -919,10 +919,19 @@ struct ieee80211_tx_info {
unsigned long jiffies;
};
/* NB: vif can be NULL for injected frames */
+#ifndef __GENKSYMS__
struct ieee80211_vif *vif;
+#else
+ union {
+ struct ieee80211_vif *vif;
+ codel_time_t enqueue_time;
+ };
+#endif
struct ieee80211_key_conf *hw_key;
u32 flags;
+#ifndef __GENKSYMS__
codel_time_t enqueue_time;
+#endif
} control;
struct {
u64 cookie;

View File

@ -134,3 +134,4 @@ bugfix/all/tools-lib-lockdep-define-pr_cont.patch
debian/scsi-avoid-abi-change-in-4.13.6.patch
debian/dax-avoid-abi-change-in-4.13.5.patch
debian/revert-bpf-one-perf-event-close-won-t-free-bpf-program-atta.patch
debian/mac80211-avoid-abi-change-in-4.13.5.patch