mm: memcontrol: use special workqueue for creating per-memcg caches

This commit is contained in:
Ben Hutchings 2016-10-07 00:59:09 +01:00
parent 224b1e126d
commit ec2dc97fc9
3 changed files with 75 additions and 0 deletions

1
debian/changelog vendored
View File

@ -68,6 +68,7 @@ linux (4.7.6-1) UNRELEASED; urgency=medium
* of_mdio: Enable fixed PHY support if driver is a module
* of_mdio: select fixed phy support unconditionally
* [armhf] Enable driver for SolidRun ClearFog: USB_XHCI_MVEBU as module
* mm: memcontrol: use special workqueue for creating per-memcg caches
[ Cyril Brulebois ]
* Add nls_ascii to the fat-modules udeb, following the change of

View File

@ -0,0 +1,73 @@
From: Vladimir Davydov <vdavydov.dev@gmail.com>
Date: Sat, 1 Oct 2016 16:39:09 +0300
Subject: mm: memcontrol: use special workqueue for creating per-memcg caches
Origin: https://patchwork.kernel.org/patch/9361853/
Bug: https://bugzilla.kernel.org/show_bug.cgi?id=172981
Creating a lot of cgroups at the same time might stall all worker
threads with kmem cache creation works, because kmem cache creation is
done with the slab_mutex held. The problem was amplified by commits
801faf0db894 ("mm/slab: lockless decision to grow cache") in case of
SLAB and 81ae6d03952c ("mm/slub.c: replace kick_all_cpus_sync() with
synchronize_sched() in kmem_cache_shrink()") in case of SLUB, which
increased the maximal time the slab_mutex can be held.
To prevent that from happening, let's use a special ordered single
threaded workqueue for kmem cache creation. This shouldn't introduce any
functional changes regarding how kmem caches are created, as the work
function holds the global slab_mutex during its whole runtime anyway,
making it impossible to run more than one work at a time. By using a
single threaded workqueue, we just avoid creating a thread per each
work. Ordering is required to avoid a situation when a cgroup's work is
put off indefinitely because there are other cgroups to serve, in other
words to guarantee fairness.
Link: https://bugzilla.kernel.org/show_bug.cgi?id=172981
Signed-off-by: Vladimir Davydov <vdavydov.dev@gmail.com>
Reported-by: Doug Smythies <dsmythies@telus.net>
Cc: Christoph Lameter <cl@linux.com>
Cc: David Rientjes <rientjes@google.com>
Cc: Johannes Weiner <hannes@cmpxchg.org>
Cc: Joonsoo Kim <iamjoonsoo.kim@lge.com>
Cc: Michal Hocko <mhocko@kernel.org>
Cc: Pekka Enberg <penberg@kernel.org>
Acked-by: Michal Hocko <mhocko@suse.com>
---
--- a/mm/memcontrol.c
+++ b/mm/memcontrol.c
@@ -2232,6 +2232,8 @@ struct memcg_kmem_cache_create_work {
struct work_struct work;
};
+static struct workqueue_struct *memcg_kmem_cache_create_wq;
+
static void memcg_kmem_cache_create_func(struct work_struct *w)
{
struct memcg_kmem_cache_create_work *cw =
@@ -2263,7 +2265,7 @@ static void __memcg_schedule_kmem_cache_
cw->cachep = cachep;
INIT_WORK(&cw->work, memcg_kmem_cache_create_func);
- schedule_work(&cw->work);
+ queue_work(memcg_kmem_cache_create_wq, &cw->work);
}
static void memcg_schedule_kmem_cache_create(struct mem_cgroup *memcg,
@@ -5811,6 +5813,17 @@ static int __init mem_cgroup_init(void)
{
int cpu, node;
+#ifndef CONFIG_SLOB
+ /*
+ * Kmem cache creation is mostly done with the slab_mutex held,
+ * so use a special workqueue to avoid stalling all worker
+ * threads in case lots of cgroups are created simultaneously.
+ */
+ memcg_kmem_cache_create_wq =
+ alloc_ordered_workqueue("memcg_kmem_cache_create", 0);
+ BUG_ON(!memcg_kmem_cache_create_wq);
+#endif
+
hotcpu_notifier(memcg_cpu_hotplug_callback, 0);
for_each_possible_cpu(cpu)

View File

@ -77,6 +77,7 @@ bugfix/all/kbuild-do-not-use-hyphen-in-exported-variable-name.patch
bugfix/all/ext4-fix-bug-838544.patch
bugfix/all/of_mdio-enable-fixed-phy-support-if-driver-is-a-modu.patch
bugfix/all/of_mdio-select-fixed-phy-support-unconditionally.patch
bugfix/all/mm-memcontrol-use-special-workqueue-for-creating-per-memcg-caches.patch
# Miscellaneous features