[x86] Enable I2C_DESIGNWARE_PLATFORM as module (Closes: #737163)

svn path=/dists/trunk/linux/; revision=21014
This commit is contained in:
Ben Hutchings 2014-02-02 00:48:10 +00:00
parent 9376ffa8a6
commit ebb5e47063
4 changed files with 44 additions and 0 deletions

1
debian/changelog vendored
View File

@ -4,6 +4,7 @@ linux (3.13-1~exp2) UNRELEASED; urgency=low
* [arm] Disable OABI_COMPAT and enable AUDITSYSCALL (except for
armel/{ixp4xx,orion5x}) (Closes: #728975, #736843)
* [x86] Enable R8188EU as module, 88EU_AP_MODE and 88EU_P2P (Closes: #736905)
* [x86] Enable I2C_DESIGNWARE_PLATFORM as module (Closes: #737163)
-- Ben Hutchings <ben@decadent.org.uk> Thu, 23 Jan 2014 15:05:08 +0000

View File

@ -574,6 +574,8 @@ CONFIG_I2C_SIS96X=m
CONFIG_I2C_VIA=m
CONFIG_I2C_VIAPRO=m
CONFIG_I2C_SCMI=m
#. Sony Vaio Duo 13".
CONFIG_I2C_DESIGNWARE_PLATFORM=m
CONFIG_I2C_DESIGNWARE_PCI=m
CONFIG_I2C_EG20T=m
CONFIG_I2C_PARPORT=m

View File

@ -0,0 +1,40 @@
From: Baruch Siach <baruch@tkos.co.il>
Date: Mon, 30 Dec 2013 10:31:19 +0200
Subject: i2c: designware: remove HAVE_CLK build dependecy
Origin: https://git.kernel.org/linus/7ae532e9976e41364bbfa7aaf455c9f1fc5f25e7
Since 93abe8e4 (clk: add non CONFIG_HAVE_CLK routines) code using clk.h
like this platform driver need not depend on HAVE_CLK. Also, remove a
redundant clk.h include from core driver.
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Wolfram Sang <wsa@the-dreams.de>
---
drivers/i2c/busses/Kconfig | 1 -
drivers/i2c/busses/i2c-designware-core.c | 1 -
2 files changed, 2 deletions(-)
diff --git a/drivers/i2c/busses/Kconfig b/drivers/i2c/busses/Kconfig
index 5687b5c..98a3f1f 100644
--- a/drivers/i2c/busses/Kconfig
+++ b/drivers/i2c/busses/Kconfig
@@ -412,7 +412,6 @@ config I2C_DESIGNWARE_CORE
config I2C_DESIGNWARE_PLATFORM
tristate "Synopsys DesignWare Platform"
- depends on HAVE_CLK
select I2C_DESIGNWARE_CORE
help
If you say yes to this option, support will be included for the
diff --git a/drivers/i2c/busses/i2c-designware-core.c b/drivers/i2c/busses/i2c-designware-core.c
index e89e3e2..14c4b30 100644
--- a/drivers/i2c/busses/i2c-designware-core.c
+++ b/drivers/i2c/busses/i2c-designware-core.c
@@ -26,7 +26,6 @@
*
*/
#include <linux/export.h>
-#include <linux/clk.h>
#include <linux/errno.h>
#include <linux/err.h>
#include <linux/i2c.h>

View File

@ -78,3 +78,4 @@ features/all/media-az6007-support-Technisat-Cablestar-Combo-HDCI-.patch
bugfix/all/staging-lustre-Make-LUSTRE_LLITE_LLOOP-tristate.patch
bugfix/arm/xen-pci-fix-build-on-non-x86.patch
bugfix/arm/ARM-orion-provide-C-style-interrupt-handler-for-MULTI_IRQ_HANDLER.patch
bugfix/all/i2c-designware-remove-HAVE_CLK-build-dependecy.patch