linux-perf: Fix reading of build-id from vDSO

This commit is contained in:
Ben Hutchings 2016-01-19 00:18:11 +00:00
parent cfc320102b
commit ea4dea20ad
3 changed files with 30 additions and 0 deletions

3
debian/changelog vendored
View File

@ -2,6 +2,9 @@ linux-tools (4.4-1~exp1) UNRELEASED; urgency=medium
* New upstream release
[ Ben Hutchings ]
* linux-perf: Fix reading of build-id from vDSO
-- Ben Hutchings <ben@decadent.org.uk> Tue, 19 Jan 2016 00:04:27 +0000
linux-tools (4.4~rc4-1~exp1) experimental; urgency=medium

View File

@ -0,0 +1,26 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Wed, 13 Jan 2016 15:16:30 +0000
Subject: perf tools: Fix reading of build-id from vDSO
Forwarded: http://mid.gmane.org/20160113172301.GT28542@decadent.org.uk
We need to use the long name (the filename) when reading the build-id
from a DSO. Using the short name doesn't work for (at least) vDSOs.
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
tools/perf/util/symbol.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tools/perf/util/symbol.c b/tools/perf/util/symbol.c
index cd08027..b60bc49 100644
--- a/tools/perf/util/symbol.c
+++ b/tools/perf/util/symbol.c
@@ -1465,7 +1465,7 @@ int dso__load(struct dso *dso, struct map *map, symbol_filter_t filter)
* Read the build id if possible. This is required for
* DSO_BINARY_TYPE__BUILDID_DEBUGINFO to work
*/
- if (filename__read_build_id(dso->name, build_id, BUILD_ID_SIZE) > 0)
+ if (filename__read_build_id(dso->long_name, build_id, BUILD_ID_SIZE) > 0)
dso__set_build_id(dso, build_id);
/*

View File

@ -15,3 +15,4 @@ tools-hv-fix-fortify-format-warning.patch
revert-perf-build-fix-libunwind-feature-detection-on.patch
alpha-uapi-add-support-for-__sane_userspace_types__.patch
nvme-stop-installing-kernel-only-linux-nvme.h-as-uap.patch
perf-tools-fix-reading-of-build-id-from-vdso.patch