* debian/changelog: Set version to 2.6.20~rc4-1~experimental.1.

* debian/patches/debian/version.patch: Update.
* debian/patches/series/1~experimental.1
  - Remove backport patches.
  - Disable non-working patches.

svn path=/dists/trunk/linux-2.6/; revision=8140
This commit is contained in:
Bastian Blank 2007-01-08 18:19:26 +00:00
parent 0c8c083cc0
commit e9ed917085
3 changed files with 45 additions and 51 deletions

2
debian/changelog vendored
View File

@ -1,4 +1,4 @@
linux-2.6 (2.6.19-1~experimental.1) UNRELEASED; urgency=low
linux-2.6 (2.6.20~rc4-1~experimental.1) UNRELEASED; urgency=low
[ Martin Michlmayr ]
* mipsel: Drop DECstation support (both r3k-kn02 and r4k-kn04).

View File

@ -1,30 +1,54 @@
diff --git a/init/version.c b/init/version.c
index 3ddc3ce..c2111a7 100644
--- a/init/version.c
+++ b/init/version.c
@@ -29,5 +29,15 @@ struct new_utsname system_utsname = {
EXPORT_SYMBOL(system_utsname);
diff --git a/fs/proc/proc_misc.c b/fs/proc/proc_misc.c
index 92ea774..bbab264 100644
--- a/fs/proc/proc_misc.c
+++ b/fs/proc/proc_misc.c
@@ -254,10 +254,18 @@ static int version_read_proc(char *page, char **start, off_t off,
{
int len;
const char linux_banner[] =
- "Linux version " UTS_RELEASE " (" LINUX_COMPILE_BY "@"
- LINUX_COMPILE_HOST ") (" LINUX_COMPILER ") " UTS_VERSION "\n";
+ "Linux version " UTS_RELEASE " "
- /* FIXED STRING! Don't touch! */
len = snprintf(page, PAGE_SIZE,
"%s version %s"
+#ifdef LINUX_COMPILE_SYSTEM_OFFICIAL
+ "(" LINUX_COMPILE_SYSTEM_DISTRIBUTION " "
+ LINUX_COMPILE_SYSTEM_VERSION ") "
+ "(" LINUX_COMPILE_SYSTEM_MAINTAINER ") "
+ " (" LINUX_COMPILE_SYSTEM_DISTRIBUTION " "
+ LINUX_COMPILE_SYSTEM_VERSION ")"
+ " (" LINUX_COMPILE_SYSTEM_MAINTAINER ")"
+#else
+# ifdef LINUX_COMPILE_SYSTEM_VERSION
+ "(" LINUX_COMPILE_SYSTEM_VERSION ") "
+ " (" LINUX_COMPILE_SYSTEM_VERSION ")"
+# endif
+ "(" LINUX_COMPILE_BY "@" LINUX_COMPILE_HOST ") "
" (" LINUX_COMPILE_BY "@" LINUX_COMPILE_HOST ")"
+#endif
+ "(" LINUX_COMPILER ") " UTS_VERSION "\n";
" (" LINUX_COMPILER ")"
" %s\n",
utsname()->sysname,
diff --git a/init/main.c b/init/main.c
index 2b1cdaa..f860297 100644
--- a/init/main.c
+++ b/init/main.c
@@ -484,7 +484,16 @@ void __init __attribute__((weak)) smp_setup_processor_id(void)
static const char linux_banner[] =
"Linux version " UTS_RELEASE
+#ifdef LINUX_COMPILE_SYSTEM_OFFICIAL
+ " (" LINUX_COMPILE_SYSTEM_DISTRIBUTION " "
+ LINUX_COMPILE_SYSTEM_VERSION ")"
+ " (" LINUX_COMPILE_SYSTEM_MAINTAINER ")"
+#else
+# ifdef LINUX_COMPILE_SYSTEM_VERSION
+ " (" LINUX_COMPILE_SYSTEM_VERSION ")"
+# endif
" (" LINUX_COMPILE_BY "@" LINUX_COMPILE_HOST ")"
+#endif
" (" LINUX_COMPILER ")"
" " UTS_VERSION "\n";
diff --git a/init/version.c b/init/version.c
diff --git a/scripts/mkcompile_h b/scripts/mkcompile_h
index d7b8a38..87035a0 100755
--- a/scripts/mkcompile_h
+++ b/scripts/mkcompile_h
@@ -46,16 +46,34 @@ ( echo /\* This file is auto generated,
@@ -46,16 +46,34 @@ UTS_TRUNCATE="sed -e s/\(.\{1,$UTS_LEN\}\).*/\1/"
echo \#define UTS_VERSION \"`echo $UTS_VERSION | $UTS_TRUNCATE`\"

View File

@ -2,42 +2,12 @@
+ debian/kernelvariables.patch
+ debian/doc-build-parallel.patch
+ debian/scripts-kconfig-reportoldconfig.patch
+ debian/powerpc-mkvmlinuz-support-ppc.patch
+ debian/powerpc-mkvmlinuz-support-powerpc.patch
#+ debian/powerpc-mkvmlinuz-support-ppc.patch
#+ debian/powerpc-mkvmlinuz-support-powerpc.patch
+ bugfix/powerpc/build-links.patch
+ bugfix/powerpc/mv643xx-hotplug-support.patch
+ bugfix/powerpc/oldworld-boot-fix.patch
+ bugfix/powerpc/prep-utah-ide-interrupt.patch
+ bugfix/powerpc/serial.patch
+ features/powerpc/efika/0001-Fix-compilation-issue-when-PPC_MPC52xx-and-PPC_MERGE-are-selected.diff
+ features/powerpc/efika/0002-Add-USB-OHCI-glue-for-OpenFirmware-devices.diff
+ features/powerpc/efika/0003-Add-MPC5200-serial-driver.diff
+ features/powerpc/efika/0004-Add-MPC5200-CPU-PIO-driver-using-libata.diff
+ features/powerpc/efika/0005-Add-MPC5200-specific-header.diff
+ features/powerpc/efika/0006-Add-MPC5200-interrupt-controller-driver.diff
+ features/powerpc/efika/0007-Add-MPC5200-ethernet-driver.diff
+ features/powerpc/efika/0008-Add-MPC5200-SDMA-PIO-driver.diff
+ features/powerpc/efika/0009-Added-RTAS-support-for-32bit-PowerPC.diff
+ features/powerpc/efika/0010-Add-Efika-platform.diff
+ features/powerpc/efika/0011-Filter-out-efika.diff
+ features/powerpc/efika/0012-Backport-of_platform.diff
+ features/powerpc/efika/0001-powerpc-Add-support-for-uevent-to-of_platform.txt
+ bugfix/arm/nslu2-disk-leds.patch
+ bugfix/arm/nas100d-artop-temp-fix.patch
+ features/arm/nslu2-setup-mac.patch
+ features/arm/nslu2-eth-mac.patch
+ features/arm/nas100d-setup-mac.patch
+ features/arm/nas100d-eth-mac.patch
+ features/arm/ixp4xx-0.2.1-driver.patch
+ features/arm/ixp4xx-net-driver-fix-qmgr.patch
+ features/arm/ixp4xx-net-driver-improve-mac-handling.patch
+ features/arm/ixp4xx-net-build-fix.patch
+ bugfix/mips/ide-scan.patch
+ bugfix/mips/64bit-tulip.patch
+ bugfix/mips/tulip_dc21143.patch
+ bugfix/mips/eth-napi.patch
+ bugfix/mips/ip22-zilog-console.patch
+ bugfix/mips/sgi-ioc3.patch
+ features/mips/sb1-duart.patch
+ features/mips/qemu-vga.patch