Disable CC_OPTIMIZE_FOR_SIZE (Closes: #635899, fixes FTBFS on mips, mipsel, powerpc)

Leave it enabled for armel/{iop32x,ixp4xx,kirkwood,orion5x} and m68k.
Drop the workaround patch for powerpc.

svn path=/dists/sid/linux/; revision=20732
This commit is contained in:
Ben Hutchings 2013-10-23 11:36:17 +00:00
parent b6c64c49c2
commit e9eb0a0dd2
13 changed files with 14 additions and 69 deletions

3
debian/changelog vendored
View File

@ -7,7 +7,8 @@ linux (3.11.5-2) UNRELEASED; urgency=low
[ Ben Hutchings ]
* kbuild: Use -nostdinc in compile tests (Closes: #726861, workaround
for #717557)
* [powerpc] lib/raid6: Disable altivec8 algorithm (fixes FTBFS)
* Disable CC_OPTIMIZE_FOR_SIZE (Closes: #635899, fixes FTBFS on mips,
mipsel, powerpc) [!armel/{iop32x,ixp4xx,kirkwood,orion5x},m68k]
-- Ian Campbell <ijc@hellion.org.uk> Sat, 19 Oct 2013 10:34:53 +0100

View File

@ -23,6 +23,7 @@
## file: init/Kconfig
##
# CONFIG_AUDITSYSCALL is not set
CONFIG_CC_OPTIMIZE_FOR_SIZE=y
CONFIG_EXPERT=y
# CONFIG_SYSCTL_SYSCALL is not set
#. Saves about 17K, and none of the quirks are likely to be needed

View File

@ -639,6 +639,11 @@ CONFIG_JFFS2_FS=y
##
CONFIG_UBIFS_FS=y
##
## file: init/Kconfig
##
CONFIG_CC_OPTIMIZE_FOR_SIZE=y
##
## file: kernel/power/Kconfig
##

View File

@ -4398,7 +4398,7 @@ CONFIG_SCHED_AUTOGROUP=y
# CONFIG_SYSFS_DEPRECATED_V2 is not set
CONFIG_RELAY=y
CONFIG_BLK_DEV_INITRD=y
CONFIG_CC_OPTIMIZE_FOR_SIZE=y
# CONFIG_CC_OPTIMIZE_FOR_SIZE is not set
# CONFIG_EXPERT is not set
CONFIG_SYSCTL_SYSCALL=y
CONFIG_KALLSYMS=y
@ -4603,6 +4603,11 @@ CONFIG_DEBUG_BUGVERBOSE=y
##
# CONFIG_KGDB is not set
##
## file: lib/Kconfig.kmemcheck
##
# CONFIG_KMEMCHECK is not set
##
## file: lib/xz/Kconfig
##

View File

@ -1001,11 +1001,6 @@ CONFIG_USBPCWATCHDOG=m
##
CONFIG_NFS_FS=y
##
## file: init/Kconfig
##
# CONFIG_CC_OPTIMIZE_FOR_SIZE is not set
##
## file: lib/Kconfig.debug
##

View File

@ -1005,11 +1005,6 @@ CONFIG_USBPCWATCHDOG=m
##
CONFIG_NFS_FS=y
##
## file: init/Kconfig
##
# CONFIG_CC_OPTIMIZE_FOR_SIZE is not set
##
## file: lib/Kconfig.debug
##

View File

@ -424,11 +424,6 @@ CONFIG_INDYDOG=m
# CONFIG_MIXCOMWD is not set
# CONFIG_WDT is not set
##
## file: init/Kconfig
##
# CONFIG_CC_OPTIMIZE_FOR_SIZE is not set
##
## file: mm/Kconfig
##

View File

@ -573,11 +573,6 @@ CONFIG_FRAMEBUFFER_CONSOLE=y
# CONFIG_PCIPCWATCHDOG is not set
# CONFIG_WDTPCI is not set
##
## file: init/Kconfig
##
# CONFIG_CC_OPTIMIZE_FOR_SIZE is not set
##
## file: mm/Kconfig
##

View File

@ -725,11 +725,6 @@ CONFIG_FRAMEBUFFER_CONSOLE=y
CONFIG_NFS_FS=y
CONFIG_ROOT_NFS=y
##
## file: init/Kconfig
##
# CONFIG_CC_OPTIMIZE_FOR_SIZE is not set
##
## file: mm/Kconfig
##

View File

@ -731,11 +731,6 @@ CONFIG_FRAMEBUFFER_CONSOLE=y
CONFIG_NFS_FS=y
CONFIG_ROOT_NFS=y
##
## file: init/Kconfig
##
# CONFIG_CC_OPTIMIZE_FOR_SIZE is not set
##
## file: mm/Kconfig
##

View File

@ -673,11 +673,6 @@ CONFIG_FB_COBALT=m
##
# CONFIG_W1 is not set
##
## file: init/Kconfig
##
# CONFIG_CC_OPTIMIZE_FOR_SIZE is not set
##
## file: mm/Kconfig
##

View File

@ -1,31 +0,0 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Sat, 19 Oct 2013 22:37:58 +0100
Subject: lib/raid6: Disable altivec8 algorithm
Forwarded: no
gcc 4.8 generates code for the altivec8 algorithm that requires
the _restvr_20 and _savevr_20 subroutines from the run-time library.
The kernel does not yet include these subroutines.
--- a/lib/raid6/Makefile
+++ b/lib/raid6/Makefile
@@ -4,7 +4,7 @@ raid6_pq-y += algos.o recov.o tables.o i
int8.o int16.o int32.o
raid6_pq-$(CONFIG_X86) += recov_ssse3.o recov_avx2.o mmx.o sse1.o sse2.o avx2.o
-raid6_pq-$(CONFIG_ALTIVEC) += altivec1.o altivec2.o altivec4.o altivec8.o
+raid6_pq-$(CONFIG_ALTIVEC) += altivec1.o altivec2.o altivec4.o # altivec8.o
hostprogs-y += mktables
--- a/lib/raid6/algos.c
+++ b/lib/raid6/algos.c
@@ -64,7 +64,7 @@ const struct raid6_calls * const raid6_a
&raid6_altivec1,
&raid6_altivec2,
&raid6_altivec4,
- &raid6_altivec8,
+/* &raid6_altivec8, */
#endif
&raid6_intx1,
&raid6_intx2,

View File

@ -80,4 +80,3 @@ bugfix/all/compiler-gcc-4-add-quirk-for-asm-goto-miscompilation-bug.patch
bugfix/all/crypto-ansi_cprng-Fix-off-by-one-error-in-non-block-.patch
features/all/mvsas-Recognise-device-subsystem-9485-9485-as-88SE94.patch
bugfix/all/kbuild-use-nostdinc-in-compile-tests.patch
bugfix/powerpc/lib-raid6-disable-altivec8-algorithm.patch