Update to 3.1-rc2

svn path=/dists/trunk/linux-2.6/; revision=17933
This commit is contained in:
Ben Hutchings 2011-08-15 14:28:10 +00:00
parent cf4365dfbe
commit e9a11b33c1
3 changed files with 3 additions and 56 deletions

7
debian/changelog vendored
View File

@ -1,6 +1,8 @@
linux-2.6 (3.1.0~rc1-1~experimental.1) UNRELEASED; urgency=low
linux-2.6 (3.1.0~rc2-1~experimental.1) UNRELEASED; urgency=low
* New upstream release candidate
- perf: do not look at ./config for configuration (Closes: #632923)
(CVE-2011-2905)
[ Aurelien Jarno ]
* Add configuration files for s390x architecture.
@ -15,9 +17,6 @@ linux-2.6 (3.1.0~rc1-1~experimental.1) UNRELEASED; urgency=low
* aufs: Disable until it is updated for Linux 3.1
* rt: Disable until it is updated for Linux 3.1
[ Jonathan Nieder ]
* perf: do not look at ./config for configuration (Closes: #632923)
-- Ben Hutchings <ben@decadent.org.uk> Wed, 27 Jul 2011 23:58:10 +0200
linux-2.6 (3.0.0-1) unstable; urgency=low

View File

@ -1,51 +0,0 @@
Date: Fri, 5 Aug 2011 18:58:38 +0200
From: Jonathan Nieder <jrnieder@gmail.com>
Subject: [PATCH] perf: do not look at ./config for configuration
In addition to /etc/perfconfig and $HOME/.perfconfig, perf looks for
configuration in the file ./config, imitating git which looks at
$GIT_DIR/config. If ./config is not a perf configuration file, it
fails, or worse, treats it as a configuration file and changes
behavior in some unexpected way.
"config" is not an unusual name for a file to be lying around and perf
does not have a private directory dedicated for its own use, so let's
just stop looking for configuration in the cwd. Callers needing
context-sensitive configuration can use the PERF_CONFIG environment
variable.
Requested-by: Christian Ohm <chr.ohm@gmx.net>
Signed-off-by: Jonathan Nieder <jrnieder@gmail.com>
---
tools/perf/util/config.c | 7 -------
1 files changed, 0 insertions(+), 7 deletions(-)
diff --git a/tools/perf/util/config.c b/tools/perf/util/config.c
index e02d78ca..6c86eca8 100644
--- a/tools/perf/util/config.c
+++ b/tools/perf/util/config.c
@@ -399,7 +399,6 @@ static int perf_config_global(void)
int perf_config(config_fn_t fn, void *data)
{
int ret = 0, found = 0;
- char *repo_config = NULL;
const char *home = NULL;
/* Setting $PERF_CONFIG makes perf read _only_ the given config file. */
@@ -421,12 +420,6 @@ int perf_config(config_fn_t fn, void *data)
free(user_config);
}
- repo_config = perf_pathdup("config");
- if (!access(repo_config, R_OK)) {
- ret += perf_config_from_file(fn, repo_config, data);
- found += 1;
- }
- free(repo_config);
if (found == 0)
return -1;
return ret;
--
1.7.6

View File

@ -40,4 +40,3 @@
+ features/all/cgroups-Allow-memory-cgroup-support-to-be-included-b.patch
+ debian/cgroups-Document-the-Debian-memory-resource-controll.patch
+ bugfix/ia64/nouveau-ACPI-support-is-dependent-on-X86.patch
+ bugfix/all/perf-do-not-look-at-.-config-for-configuration.patch